Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 18:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: помогите решить задачу  (Прочитано 1302 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн keks_feo

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-29
  • Сайт: 
  • Профессия: Ученик 1С
добрый день!
помогите решить задачу ...
вот текст
Процедура ВыводТоваров(ФлагСумм)
Если Режим=1 Тогда
Цена= пересчет(Запрос.Цена,Курс1,Курс2);
Иначе     
Цена= 0;
КонецЕсли;
НачКол = запрос.НачКол;
КонКол = запрос.КонКол;
ПрихКол = запрос.ПрихКол;
РасхКол = запрос.РасхКол;   



Если ТипСуммы=1 тогда
НачСум = пересчет(запрос.НачСум,Курс1,Курс2);
КонСум = пересчет(запрос.КонСум,Курс1,Курс2);
ПрихСум = пересчет(запрос.ПрихСум,Курс1,Курс2);
РасхСум = пересчет(запрос.РасхСум,Курс1,Курс2);
ИначеЕсли ТипСуммы=2 тогда
НачСум = пересчет(запрос.НачСум-запрос.НачНац,Курс1,Курс2);
КонСум = пересчет(запрос.КонСум-запрос.КонНац,Курс1,Курс2);
ПрихСум = пересчет(запрос.ПрихСум-запрос.ПрихНац,Курс1,Курс2);
РасхСум = пересчет(запрос.РасхСум-запрос.РасхНац,Курс1,Курс2);
Если (Режим=1)и(НачКол+КонКол+ПрихКол+РасхКол<>0) Тогда
Цена= пересчет((НачСум+КонСум+ПрихСум+РасхСум)/(НачКол+КонКол+ПрихКол+РасхКол),Курс1,Курс2);
КонецЕсли;
Иначе
Цена= ЦенаПоКатегории(контекст,ВыбКатегория,Запрос.Товар);
НачСум = Цена*НачКол;
КонСум = Цена*КонКол;
ПрихСум = Цена*ПрихКол;
РасхСум = Цена*РасхКол;
КонецЕсли;
Единица= Запрос.Товар.БазоваяЕдиница;
Если ВБазовых=2 Тогда                                     
Если запрос.товар.ЕдиницаСклада.Выбран()=1 Тогда
НачКол= НачКол/запрос.Товар.ЕдиницаСклада.Коэффициент;
КонКол= КонКол/запрос.Товар.ЕдиницаСклада.Коэффициент;
ПрихКол= ПрихКол/запрос.Товар.ЕдиницаСклада.Коэффициент;
РасхКол= РасхКол/запрос.Товар.ЕдиницаСклада.Коэффициент;   
Единица= Запрос.Товар.ЕдиницаСклада.Единица;
Цена = Цена*запрос.Товар.ЕдиницаСклада.Коэффициент;
КонецЕсли;
КонецЕсли;
Если ФлагСумм=1 Тогда
Таб.ВывестиСекцию("Строка"); 

ИтогНачВес = ИтогНачВес + НачКол*Запрос.Товар.Вес;
ИтогПрихВес = ИтогПрихВес + ПрихКол*Запрос.Товар.Вес;
ИтогРасхВес = ИтогРасхВес + РасхКол*Запрос.Товар.Вес;
ИтогКонВес = ИтогКонВес + КонКол*Запрос.Товар.Вес;

ИтогНачКол = ИтогНачКол + начКол;
ИтогПрихКол = ИтогПрихКол + прихКол;
ИтогРасхКол = ИтогРасхКол + расхКол;
ИтогКонКол = ИтогКонКол + конКол;
ИтогНачСум = ИтогНачСум + начсум;
ИтогПрихСум = ИтогПрихСум + прихсум;
ИтогРасхСум = ИтогРасхСум + расхсум;
ИтогКонСум = ИтогКонСум + консум;
НПП = НПП + 1;
Иначе
// Таб.ВывестиСекцию("Документ");
КонецЕсли;
КонецПроцедуры    
этот текст выводит все данные которые есть в таблице, а как сделать чтобы выводил только те, где ячейка "РасхКол" не пустая ... 


Оффлайн keks_feo

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-29
  • Сайт: 
  • Профессия: Ученик 1С
добавлю
Платформа 7.7 (7.70.025)
Конфигурация  ДС (Трейд ред) (2.7.0)

Оффлайн keks_feo

  • *
  • Сообщений: 23
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-29
  • Сайт: 
  • Профессия: Ученик 1С
тю..  :zebzdr: как все просто получилось, спб большое ... буду вникать дальше


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 352
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal