Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 23:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Перехват закрытия openoffice из 1с 8  (Прочитано 2298 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн hiallbb

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-28
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте! Необходимо открыть шаблон документа в Oo writer из 1с, пользователь правит его, нажимает на кнопку закрытия OpenOffice и файл должен автоматически сохраниться во временную папку, т.е. без всяких диалоговых окон. Есть код:
Цитировать
Если СловоДокумент = Неопределено Тогда
        Попытка
            ServiceManager = Новый COMОбъект("com.sun.star.ServiceManager");
            Reflection = ServiceManager.createInstance("com.sun.star.reflection.CoreReflection");
            Desktop = ServiceManager.createInstance("com.sun.star.frame.Desktop");
            Broadcaster = ServiceManager.createInstance("com.sun.star.frame.GlobalEventBroadcaster");
        Исключение
            Сообщить(ОписаниеОшибки(),"!");
            Возврат;
        КонецПопытки;
       
        Если ЗначениеЗаполнено(ВремФайл) Тогда
            УдалитьФайлы(ВремФайл);
        КонецЕсли;
       
        // Получить имя временного файла для хранения документа
 
        ИмяФайла = ПолучитьИмяВременногоФайла(".doc");
        Args = Новый COMSafeArray("VT_DISPATCH", 1);
        Если ДвДанные = Неопределено Тогда
            // Создать новый документ, если не был создан до этого
 
            OOДокумент = Desktop.loadComponentFromURL("private:factory/swriter", "_blank", 0, Args);
            // И сохранить его во временный файл
 
            OOДокумент.storeAsURL(ПреобразоватьВURL(ИмяФайла), Args);
        Иначе
            // Записать данные во временный файл
 
            ДвДанные.Записать(ИмяФайла);
            // Создать новый документ
 
            OOДокумент = Desktop.loadComponentFromURL(ПреобразоватьВURL(ИмяФайла), "_blank", 0, Args);
            OOДокумент.storeAsURL(ПреобразоватьВURL(ИмяФайла), Args);
        КонецЕсли;
       
   
    КонецЕсли;
   
    // Если документ открыт, активизировать его
 
    OOДокумент.getCurrentController().getFrame().getContainerWindow().setFocus();   
   
   

    //Добавить обработчик события от документа OpenOffice
 
    ДобавитьОбработчик OOДокумент.Close(true), ЗакрытиеДокумента;
ДобавитьОбработчик OOДокумент.Close(true)  - вот тут не отрабатывает, тупо выходит из опенофиса. Открывается нужный шаблон и тут же закрывается, хотя должна вызваться процедура ЗакрытиеДокумента(), дабы обработать событие закрытия OpenOffice.
В чем проблема? Как правильно перехватить закрытие openoffice?


Теги:
 

После закрытия месяца пропадает на 41 счете сумма продукции

Автор Наталья СергеевнаРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4578
Последний ответ 26 Апр 2013, 17:36
от MuI_I_Ika
ict 220 Зенит Розница 2.1.4.9 проблема закрытия смены и эквайринговой операции

Автор BHy4okРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1386
Последний ответ 14 Май 2015, 17:25
от BHy4ok
Выполнить обмен данными, после закрытия смены

Автор AfellayРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 332
Последний ответ 25 Май 2017, 14:03
от wise
Чеки сохранялись после закрытия смены

Автор ser333Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2106
Последний ответ 26 Окт 2012, 13:23
от MuI_I_Ika
Установка порядка подразделений для закрытия счетов

Автор Тамара ШестоваРаздел Пользователям "1С - Предприятие 8"

Ответов: 5
Просмотров: 1951
Последний ответ 29 Май 2017, 16:18
от Геннадий ОбьГЭС

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
141 Сообщений
AIFrame
73 Сообщений
ilyay ilyay
65 Сообщений
alex0402
52 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
31 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 287
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal