Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
19 Дек 2018, 12:04
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вызвать функцию модуля в документе! Ошибка!  (Прочитано 5137 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Anton_Nikitin

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-24
  • Сайт: 
  • Профессия: Программист 8.1
Общий модуль!
Функция ГруппировкаЭРИ(ДокументОбъект) Экспорт
МетаданныеДокумента = ДокументОбъект.Метаданные();
   Если ДокументОбъект.ЭтоНовый() ТОгда
    Группа=Справочники.ГруппаЭРИ.СоздатьЭлемент();
    Группа.ДатаПоступления=ДокументОбъект.Дата;
    Группа.Изготовитель=ДокументОбъект.Контрагент;
    Группа.ТипЭРИ=ДокументОбъект.ТабличнаяЧасть.ТипЭРИ;
    Группа.Количество=ДокументОбъект.ТабличнаяЧасть.Количество;
    Группа.Партия=ДокументОбъект.ТабличнаяЧасть.Партия;
    Группа.ДатаИзготовления=ДокументОбъект.ТабличнаяЧасть.ДатаИзг;
    Группа.ЕдИзм=ДокументОбъект.ТабличнаяЧасть.ЕдИзм;
    Группа.Счет=ДокументОбъект.Счет;
    Группа.Записать();
 КонецЕсли;
 КонецФункции
Документ
 Процедура ПередЗаписью()
 УправлениеЭРИ.ГруппировкаЭРИ(ЭтотОбъект);
 КонецПроцедуры
Ошибка
{ОбщийМодуль.УправлениеЭРИ(7)}: Поле объекта не обнаружено (ТипЭРИ)
    Группа.ТипЭРИ=ДокументОбъект.ТабличнаяЧасть.ТипЭРИ;
В чем ошибка подскажите!


Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
**** Группа.ТипЭРИ=ДокументОбъект.ТабличнаяЧасть.ТипЭРИ;**** - Что такое Табличная часть? Может просто:

   Группа.ТипЭРИ=ДокументОбъект.ТипЭРИ
?

Оффлайн Anton_Nikitin

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-24
  • Сайт: 
  • Профессия: Программист 8.1
И так делал, эффект тот же!

Оффлайн Anton_Nikitin

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-24
  • Сайт: 
  • Профессия: Программист 8.1
А ТабличнаяЧать-Табличная Часть документа.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1102
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Одно из двух: или у справочника нет этого реквизита или у табличной части документа (или у документа - вы по ходу дела сами не разобрались?)

Точку останова на этой строчке и станет более ясно...
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Anton_Nikitin

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-24
  • Сайт: 
  • Профессия: Программист 8.1
Все реквизиты есть и у справочника и у таб.части!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1102
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Чудес не бывает )

В любом случае точку останова на этой строчке и смотрите значение у

ДокументОбъект.ТабличнаяЧасть
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
Может в табличной части строчку для начала взять? Она там одна, я так полагаю?
Для каждого Стр из ДокументОбъект.ТабличнаяЧасть Цикл    //(или, может, Стр = ДокументОбъект.ТабличнаяЧасть[0]; )
    Группа.ТипЭРИ=Стр.ТипЭРИ;
    Группа.Количество=Стр.Количество;
    Группа.Партия=Стр.Партия;
    Группа.ДатаИзготовления=Стр.ДатаИзг;
    Группа.ЕдИзм=Стр.ЕдИзм;
КонецЦикла;
   

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Ну в любом случае вот эта запись ошибочна:
Группа.ТипЭРИ=ДокументОбъект.ТабличнаяЧасть.ТипЭРИ;
Если обращаетесь к табличной части, то нужно обращаться к конкретной строке табличной части, то есть как-то так:
Группа.ТипЭРИ=ДокументОбъект.ТабличнаяЧасть[НомерСтроки].ТипЭРИ;
ТипЭРИ - это что такое у документа? Реквизит документа или реквизит табличной части?
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Makifka

  • **
  • Сообщений: 81
  • РЕПУТАЦИЯ: 23
  • КПД: 28%
  • Регистрация: 2010-08-13
  • Сайт: 
  • Профессия: Программист 1С
Может в табличной части строчку для начала взять? Она там одна, я так полагаю?
Для каждого Стр из ДокументОбъект.ТабличнаяЧасть Цикл   
    Группа.ТипЭРИ=Стр.ТипЭРИ;
    Группа.Количество=Стр.Количество;
    Группа.Партия=Стр.Партия;
    Группа.ДатаИзготовления=Стр.ДатаИзг;
    Группа.ЕдИзм=Стр.ЕдИзм;
КонецЦикла;


Теги:
 

Ошибка "Неправильный псевдоним "Т.Ссылка" <<?>> Т.Ссылка как номенклатура"

Автор Андрей БулановРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 287
Последний ответ 13 Окт 2018, 21:51
от Андрей Буланов
При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 5356
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 7148
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5155
Последний ответ 28 Апр 2014, 15:53
от maskito
УТ 10.3 При провеедении реализации выходит ошибка "состояние договора отличается от "договор есть, документы есть", документ подсвечивается серым цветом

Автор MilaZzerberРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 157
Последний ответ 25 Сен 2018, 13:32
от MilaZzerber

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

oleg-x
58 Сообщений
wise wise
42 Сообщений
alex0402
36 Сообщений
LexaK
32 Сообщений
alexandr_ll
31 Сообщений
AIFrame AIFrame
28 Сообщений
byte777
26 Сообщений
antoneus
25 Сообщений
happynattion
22 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
21 Сообщений

* Кто онлайн

  • Точка Гостей: 757
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal