Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 10:45
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Вывод даты с новой строки (метод вывести)  (Прочитано 2386 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Артак

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-23
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, помогите пожалуйста. Я недавно начал обучать 1С и  у меня такая проблема: мне нужно создать отчет, где нужно вывести количество поданных  заявлений  на определенную специальность  на  какую-то дату.  Есть код и вот где комментарий в одном случае нужно вывести, а в 2-х других присоединить. как это сделать?

Процедура КнопкаСформироватьНажатие(Кнопка)
   // Вставить содержимое обработчика.
     ТД=ЭлементыФормы.ТД;
    ТД.Очистить();
    М=ПолучитьМакет("Макет");
   //Заголовок
    З=М.ПолучитьОбласть("Заголовок");
   З.Параметры.Заполнить(ЭтотОбъект);
    ТД.Вывести(З);
   //Шапка
    Ш=М.ПолучитьОбласть("Шапка");
   ТД.Вывести(Ш);
   //ШапкаСтрока
    ШС=М.ПолучитьОбласть("ШапкаСтрока");
   ТД.Вывести(ШС);
    //ШапкаСтолбец
    ШСТ=М.ПолучитьОбласть("ШапкаСтолбец");
   ТД.Вывести(ШСТ);
   
   
З=Новый Запрос("ВЫБРАТЬ РАЗЛИЧНЫЕ
    |   КПЗ.Специальность
    |ИЗ
    |   РегистрНакопления.КПЗ КАК КПЗ
    |ГДЕ
    |   КПЗ.УчебныйГод = &УГ
    |   И КПЗ.ФормОбучения = &ФО
   |УПОРЯДОЧИТЬ ПО КПЗ.Специальность.Наименование");
З.УстановитьПараметр("УГ",УчебныйГод);
З.УстановитьПараметр("ФО",ФормаОбучения);

ТС = З.Выполнить().Выгрузить();
Для каждого э из ТС цикл
   Сообщить("С="+э.Специальность);
КонецЦикла;

З=Новый Запрос("ВЫБРАТЬ
               |   КПЗ.Специальность,
               |   СУММА(КПЗ.К) КАК К,
               |   КПЗ.Период КАК Период
               |ИЗ
               |   РегистрНакопления.КПЗ КАК КПЗ
               |ГДЕ
               |   КПЗ.УчебныйГод = &УГ
               |   И КПЗ.ФормОбучения = &ФО
               |
               |СГРУППИРОВАТЬ ПО
               |   КПЗ.Период,
               |   КПЗ.Специальность
               |
               |УПОРЯДОЧИТЬ ПО
               |   Период,
               |   КПЗ.Специальность.Наименование");

З.УстановитьПараметр("УГ",УчебныйГод);
З.УстановитьПараметр("ФО",ФормаОбучения);

Выборка = З.Выполнить().Выбрать();

Если Выборка.Следующий() тогда
   Д1 = Выборка.Период;
   Выполнять = Истина;   
   Пока Выполнять цикл
      Д1 = Выборка.период;
      //Сообщить("Дата="+Д1+"----------------");
      //Вывод даты с новой строки  (метод вывести)
       
          Для каждого э из ТС цикл
         Если э.Специальность=Выборка.Специальность И Д1=Выборка.Период тогда
            //Сообщить("С="+э.Специальность+" к="+Выборка.К);
            //присоединить
            
            Выполнять=Выборка.Следующий();
            Если Выборка.Период<>Д1 тогда
               Д1 = Выборка.Период;
            КонецЕсли;
         Иначе
            //Сообщить("С="+э.Специальность+" к=0"); 
            //присоединить
            
         КонецЕсли;
      КонецЦикла;
   КонецЦикла;   
КонецЕсли;
КонецПроцедуры
 


Теги:
 

Вывод комментария в документ "Расходная накладная" из документа "Заказ покупателя"

Автор ОльгаПлРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 205
Последний ответ 07 Окт 2017, 19:03
от Norfolk
Вывод результата запроса через условие другого запроса

Автор jonik_jokerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2900
Последний ответ 16 Окт 2013, 15:08
от jonik_joker
Вывод линейной таблицы посредством СКД в виде "шахматки"

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 10714
Последний ответ 19 Апр 2011, 11:12
от Klyacksa
Вывод набора данных "объединение" скд в дерево значений

Автор Gae4kaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1547
Последний ответ 02 Июн 2015, 12:19
от Gae4ka
Как добавить вывод ДоговораКонтрагента в печатную форму "Счет на оплату"

Автор ValentusРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 12930
Последний ответ 09 Июн 2010, 15:25
от Karamelkina

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 843
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal