Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 04:28

Возврат от покупателя проводится с НДС в чеке

Автор Airat16, 16 дек 2017, 11:06

0 Пользователей и 1 гость просматривают эту тему.

Airat16

Цитата: AIFrame от 17 дек 2017, 13:25
Airat16,
Для онлайн-кассы правильным считается оформление возврата аналогично возврату "день в день", просто вы указываете чек прошедшего периода.
Зайдите в РМК, нажмите Возврат (F5) и найдите нужный чек, удалите лишние позиции (если есть) и пробивайте чек (F6, F7, F8, смотря как оплачивался).
В налоговую уйдет чек с признаком "Возврат прихода".
Оформлять Возврат от покупателя при это не нужно.
Это понятно. Только я писал выше что после ремонта ноутбука все данные пропали, я по своей неопытности не делал резервные копии. Соттветственно через F5 не получиться, там просто нет нужного чека

AIFrame

Попробуйте в копии на эмуляторе (в пред. посте добавил).
Чеки, пробитые на эмуляторе, в налоговую не уйдут.

Геннадий ОбьГЭС

Цитата: Airat16 от 16 дек 2017, 13:52
1С:Предприятие 8.3 (8.3.8.2197)
Розница (базовая), редакция 2.2 (2.2.5.27)

Я бы попробовал обновиться
В актуальном релизе 2.2.7.32 от 20.12.2017 среди исправленных ошибок:
Ошибка 00-00135208
https://bugboard.v8.1c.ru/error/000038358.html

Статус: Исправлена в выпущенной версии
Зарегистрирована: 12.12.2017
Исправлена: "1С:Розница 2.1, 2.2", версия 2.2.7.32

Описание:
Ошибка определения вида налогов в документе "Возврат товаров от покупателя"

Способ обхода:
Использовать «Чек ККМ» с видом операции «Возврат» вместо документа «Возврат товаров от покупателя».

Способ исправления:
1.
Документ.ВозвратТоваровОтПокупателя.ФормаДокумента процедура «ПриИзмененииСкладСервер»
Было:
Если НЕ ЗначениеЗаполнено(Объект.Организация) Тогда

    Объект.Организация = Объект.Склад.Организация;
    НастроитьОтображениеРеквизитовСчетаФактуры
      ( ЭтотОбъект,   
        ЗакупкиСервер.ПараметрыПредставленияСчетаФактуры
          (Объект.Ссылка,
           Объект.Организация
           )
       );
КонецЕсли;


Нужно:
Если НЕ ЗначениеЗаполнено(Объект.Организация) Тогда   
    Объект.Организация = Объект.Склад.Организация;   
    ПодключаемоеОборудованиеРТ.ЗаполнитьВидНалога(Объект);
    ЗаполнитьСистемуНалогооблажения
        (Объект.Дата, Объект.Организация);   
     НастроитьОтображениеРеквизитовСчетаФактуры
         ( ЭтотОбъект,
           ЗакупкиСервер.ПараметрыПредставленияСчетаФактуры
               (Объект.Ссылка,
                Объект.Организация
                )
          );
КонецЕсли;


2.
Документ.ВозвратТоваровОтПокупателя.ФормаДокумента
процедура «ПриИзмененииСкладСервер»

Было:
Если ЗначениеЗаполнено(Объект.Склад)
    И НЕ ЗначениеЗаполнено(Объект.Организация) Тогда
        ПриИзмененииСкладСервер();
КонецЕсли;


Нужно:

Если ЗначениеЗаполнено(Объект.Склад)
    И НЕ ЗначениеЗаполнено(Объект.Организация) Тогда   
        ПриИзмененииСкладСервер();
ИначеЕсли
        ЗначениеЗаполнено(Объект.Склад) Тогда ЗаполнитьВидНалога();

КонецЕсли;


3.
Документ.ВозвратТоваровОтПокупателя.ФормаДокумента
добавить процедуру
&НаСервере
Процедура ЗаполнитьВидНалога()
ПодключаемоеОборудованиеРТ.ЗаполнитьВидНалога(Объект);
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск