Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Окт 2019, 08:47
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: автозаполнение элемента формы документа при заполнении другого элемента формы документа  (Прочитано 941 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nc1318

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2017-11-22
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. 1С 8.3. Справочник "Курсы" с полям "Стоимость" и "Наименование(стандартный реквизит)". Документ "ВнесениеОплат" в табличной части "ПереченьОплат" поля "Учайщийся" (тип СправочникСсылка.Клиенты), "Курс" (СправочникСсылка.Курсы) и Сумма (Число). Как сделать так, чтобы после заполнения поля Курс в документе, автоматически заполнялось поле "Сумма" в документе.  Например, в справочнике есть курс "базы данных", стоимость 5000р. Так вот в документе Курс выбирается из списка справочника, а поле "Сумма" документа должно получить значение "5000р".
Пробывал вот так:


&НаКлиенте
Процедура ПереченьОплатКурсПриИзменении(Элемент)
   Стр = Элементы.ПереченьОплат.ТекущиеДанные;
   Стр.Сумма = ФормированиеДокумента(Стр.Курс);   
КонецПроцедуры

&НаСервереБезКонтекста
Функция ФормированиеДокумента(Наименование)
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |   Курсы.Наименование,
        |   Курсы.Стоимость
        |ИЗ
        |   Справочник.Курсы КАК Курсы
        |ГДЕ
        |   Курсы.Наименование = &Наименование";
   Запрос.УстановитьПараметр("Наименование", Наименование);
    Выборка = Запрос.Выполнить().Выбрать();
   Пока Выборка.Следующий() Цикл
      
   Если Строка(Выборка.Наименование)= Наименование Тогда
      
      Возврат Выборка.Стоимость;      
   КонецЕсли;
 
   КонецЦикла;
КонецФункции


Оффлайн alex0402

  • *****
  • Сообщений: 1935
  • РЕПУТАЦИЯ: 346
  • КПД: 18%
  • Регистрация: 2010-09-10
  • Сайт: 
  • Профессия: Программист 1С
Примерно так:
    Запрос = Новый Запрос("ВЫБРАТЬ
        |   Курсы.Стоимость
        |ИЗ
        |   Справочник.Курсы КАК Курсы
        |ГДЕ
        |   Курсы.Ссылка = &Курс");
    Запрос.УстановитьПараметр("Курс",Курс);
    Выборка = Запрос.Выполнить().Выбрать();
    Выборка.Следующий();
    Сообщить(Выборка.Стоимость);
хотя стоимость лучше хранить где-то в регистре сведений.
Спасибо за Сказать спасибо


Теги:
 

Очищается один реквизит объекта на форме при изменении другого реквизита объекта на форме

Автор AsadRomanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 1556
Последний ответ 03 Авг 2018, 17:37
от AsadRoman
Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 5589
Последний ответ 13 Апр 2012, 23:26
от Vit1501
1С 8.3 - Как присвоить стандартному реквизиту "Наименование" одного справочника, ссылку на реквизит другого справочника?

Автор АлирзаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1892
Последний ответ 09 Ноя 2017, 08:47
от alex0402
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5882
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2690
Последний ответ 10 Май 2017, 20:44
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
alexandr_ll
50 Сообщений
wise wise
33 Сообщений
BuhRust
32 Сообщений
KOI8-R
24 Сообщений
LexaK
22 Сообщений
MuI_I_Ika MuI_I_Ika
18 Сообщений
Рашитовна Рашитовна
18 Сообщений
Yamuna
16 Сообщений
DmitriyF DmitriyF
13 Сообщений

* Кто онлайн

  • Точка Гостей: 361
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal