Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
29 Сен 2020, 10:51
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: автозаполнение элемента формы документа при заполнении другого элемента формы документа  (Прочитано 1563 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nc1318

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2017-11-22
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. 1С 8.3. Справочник "Курсы" с полям "Стоимость" и "Наименование(стандартный реквизит)". Документ "ВнесениеОплат" в табличной части "ПереченьОплат" поля "Учайщийся" (тип СправочникСсылка.Клиенты), "Курс" (СправочникСсылка.Курсы) и Сумма (Число). Как сделать так, чтобы после заполнения поля Курс в документе, автоматически заполнялось поле "Сумма" в документе.  Например, в справочнике есть курс "базы данных", стоимость 5000р. Так вот в документе Курс выбирается из списка справочника, а поле "Сумма" документа должно получить значение "5000р".
Пробывал вот так:


&НаКлиенте
Процедура ПереченьОплатКурсПриИзменении(Элемент)
   Стр = Элементы.ПереченьОплат.ТекущиеДанные;
   Стр.Сумма = ФормированиеДокумента(Стр.Курс);   
КонецПроцедуры

&НаСервереБезКонтекста
Функция ФормированиеДокумента(Наименование)
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |   Курсы.Наименование,
        |   Курсы.Стоимость
        |ИЗ
        |   Справочник.Курсы КАК Курсы
        |ГДЕ
        |   Курсы.Наименование = &Наименование";
   Запрос.УстановитьПараметр("Наименование", Наименование);
    Выборка = Запрос.Выполнить().Выбрать();
   Пока Выборка.Следующий() Цикл
      
   Если Строка(Выборка.Наименование)= Наименование Тогда
      
      Возврат Выборка.Стоимость;      
   КонецЕсли;
 
   КонецЦикла;
КонецФункции


Оффлайн alex0402

  • *****
  • Сообщений: 1987
  • РЕПУТАЦИЯ: 357
  • КПД: 18%
  • Регистрация: 2010-09-10
  • Сайт: 
  • Профессия: Программист 1С
Примерно так:
    Запрос = Новый Запрос("ВЫБРАТЬ
        |   Курсы.Стоимость
        |ИЗ
        |   Справочник.Курсы КАК Курсы
        |ГДЕ
        |   Курсы.Ссылка = &Курс");
    Запрос.УстановитьПараметр("Курс",Курс);
    Выборка = Запрос.Выполнить().Выбрать();
    Выборка.Следующий();
    Сообщить(Выборка.Стоимость);
хотя стоимость лучше хранить где-то в регистре сведений.
Спасибо за Сказать спасибо


Теги:
 

Очищается один реквизит объекта на форме при изменении другого реквизита объекта на форме

Автор AsadRomanРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 10
Просмотров: 3230
Последний ответ 03 Авг 2018, 17:37
от AsadRoman
Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6290
Последний ответ 13 Апр 2012, 23:26
от Vit1501
1С 8.3 - Как присвоить стандартному реквизиту "Наименование" одного справочника, ссылку на реквизит другого справочника?

Автор АлирзаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3092
Последний ответ 09 Ноя 2017, 08:47
от alex0402
Заполнение поля табличной части документа из табличной части справочника.

Автор Kurt_WagnerРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 7782
Последний ответ 06 Апр 2015, 20:08
от Kurt_Wagner
Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3658
Последний ответ 10 Май 2017, 20:44
от ilnur75

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
73 Сообщений
oooo800
32 Сообщений
Дмитрий Джей Дмитрий Джей
30 Сообщений
IL2016
29 Сообщений
antoneus antoneus
25 Сообщений
LexaK
25 Сообщений
DmitriyF DmitriyF
17 Сообщений
Ann_
16 Сообщений
мадам брошкина
13 Сообщений
alexandr_ll
12 Сообщений

* Кто онлайн

  • Точка Гостей: 664
  • Точка Скрытых: 1
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal