Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Окт 2018, 13:16
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Клиент-Серверное взаимоотношение в 1с  (Прочитано 774 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн NewProgrammist

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2017-11-13
  • Сайт: 
  • Профессия: Программист 1С
Помогите плиз!!! 4 часа не могу с сервера передать на клиент таблицу значения:(:(. На форме имеется ТЗ без колонок. В процессе выполнения кода не возникает никаких ошибок. Однако ТЗ все равно остается ПУСТОЙ.


&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ПриОткрытииНаСервере();
   Элементы.ТЗ.Обновить();
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииНаСервере()
   Таблица = РеквизитФормыВЗначение("Объект.ТЗ");
   Запрос = новый Запрос("ВЫБРАТЬ
                         |   ПродажиОстатки.Организация,
                         |   ПродажиОстатки.Подразделение,
                         |   ПродажиОстатки.Сотрудник,
                         |   ПродажиОстатки.СуммаОстаток
                         |ИЗ
                         |   РегистрНакопления.Продажи.Остатки КАК ПродажиОстатки");
   
   Таблица = Запрос.Выполнить().Выгрузить();
   ЗначениеВРеквизитФормы(Таблица,"Объект.ТЗ");
КонецПроцедуры


Оффлайн oleg-x

  • *****
  • Сообщений: 856
  • РЕПУТАЦИЯ: 190
  • КПД: 22%
  • Регистрация: 2016-11-02
  • Сайт: 
  • Профессия: Программист 1С
Помогите плиз!!! 4 часа не могу с сервера передать на клиент таблицу значения:(:(. На форме имеется ТЗ без колонок. В процессе выполнения кода не возникает никаких ошибок. Однако ТЗ все равно остается ПУСТОЙ.


&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ПриОткрытииНаСервере();
   Элементы.ТЗ.Обновить();
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииНаСервере()
   Таблица = РеквизитФормыВЗначение("Объект.ТЗ");
   Запрос = новый Запрос("ВЫБРАТЬ
                         |   ПродажиОстатки.Организация,
                         |   ПродажиОстатки.Подразделение,
                         |   ПродажиОстатки.Сотрудник,
                         |   ПродажиОстатки.СуммаОстаток
                         |ИЗ
                         |   РегистрНакопления.Продажи.Остатки КАК ПродажиОстатки");
   
   Таблица = Запрос.Выполнить().Выгрузить();
   ЗначениеВРеквизитФормы(Таблица,"Объект.ТЗ");
КонецПроцедуры
Пройдись отладчиком и посмотри что происходит на каждом этапе
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google


Теги:
 


* Реклама

* Реклама

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal