Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 18:15
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Как УстановитьДействие???  (Прочитано 8227 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн virus555

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-09
  • Сайт: 
  • Профессия: Бухгалтер
Подскажите как написать ф-цию "УстановитьДействие" на "ДополнительныеРеквизиты" в справочнике "Номенклатура".
Знаю что прописывать её надо в модуле формы, а вот в какую процедуру и как правильно написать - не знаю!

Например в процедуре "ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)" пишу:
Объект.ДополнительныеРеквизиты.ЭлементУправления.УстановитьДействие("ПриИзменении", "МояПроцедура");
Синтаксических ошибок не обнаружено, но в 1С вылетает ошибка "Поле объекта не обнаружено (ЭлементУправления) :(

Помогите пожалуйста.

ЗЫ: 1С 8.2 Конфа УТ 11


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Надо найти место где реквизит создается...
Что-то типа

НовыйЭлемент = ЭтаФорма.Добавить(...

и вот потом

НовыйЭлемент.УстановитьДействие("ПриИзменении", "Мояпроцедура");
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн virus555

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-09
  • Сайт: 
  • Профессия: Бухгалтер
Ну написал следущее:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

ДополнительныеРеквизиты = Элементы.ГруппаДополнительныеРеквизиты.ПодчиненныеЭлементы;
ДополнительныеРеквизиты.УстановитьДействие("ПриИзменении", "МояПроцедура");

КонецПроцедуры

&НаКлиенте
Процедура МояПроцедура(Элемент, ДанныеВыбора, СтандартнаяОбработка)
Сообщить("что-нибудь");
КонецПроцедуры
Пишет - Метод объекта не обнаружен (УстановитьДействие)

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
ну правильно. Метод УстановитьДействие() - метод у типа ЭлементУправления (рабочее название, сам придумал ;) ).

Кстати, в вашем случае надо скорее всего было пойти дальше.
ПодчиненныеЭлементы - коллекция элементов управления. То есть надо что то типа

Для каждого ТекЭлУпр Из Элементы.ГруппаДополнительныеРеквизиты.ПодчиненныеЭлементы Цикл
         ТекЭлУпр.УстановитьДействие("ПриИзменении", "МояПроцедура");
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
172 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 580
  • Точка Скрытых: 0
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal