Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 06:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: В чем ошибка заполнения?  (Прочитано 11974 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Доброго времени суток!

Процедура КнопкаВыполнитьНажатие(Кнопка)
Запрос=Новый Запрос;
Запрос.Текст="ВЫБРАТЬ
             | ИнвентаризацияТоваровНаСкладеТовары.Ссылка КАК Ссылка,
             | ИнвентаризацияТоваровНаСкладеТовары.НомерСтроки
             |ИЗ
             | Документ.ИнвентаризацияТоваровНаСкладе.Товары КАК ИнвентаризацияТоваровНаСкладеТовары,
             | Документ.ИнвентаризацияТоваровНаСкладе КАК ИнвентаризацияТоваровНаСкладе";
Выборка=Запрос.Выполнить().Выбрать();
Пока Выборка.Следующий() Цикл;
СтрокаТЧ=ИзмДок.Добавить();
СтрокаТч.Док=Выборка.Ссылка;
ОбъектИзм=СтрокаТЧ.Док.ПолучитьОбъект();
ВыборкаПоДоку=Выборка.Выбрать();
Пока ВыборкаПоДоку.Следующий() Цикл
Строка=ОбъектИзм.Товары.Получить(ЭтотОбъект[ВыборкаПоДоку.НомерСтроки]);
Строка.СчетУчетаБУ=ПланыСчетов.Хозрасчетный.ТоварыНаСкладах;
КонецЦикла;
ОбъектИзм.Записать();
СтрокаТч.Док=Выборка.Ссылка;
КонецЦикла;
КонецПроцедуры

Задача- заполнение колонки "СчетДоходовБУ" значениями. Но колонка почему-то остается пустой. В чем ошибка?


Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Вернее колонка "СчетУчетаБУ"- как и написано в коде

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Поставь точку останова на строке "Выборка=Запрос.Выполнить().Выбрать();" и в табло вставь строчку "Запрос.Выполнить().Выгрузить().Количество()" - запрос не пустой вообще

Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
Табло: Значение=1001. В табличной части все колонки заполнены, кроме нужной.

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
СтрокаТЧ и Строка разные,,,,Строка не доступна для записи...

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
Вот тут "Строка.СчетУчетаБУ=ПланыСчетов.Хозрасчетный.ТоварыНаСкладах;" попробуй поменять на "СтрокаТЧ.СчетУчетаБУ=ПланыСчетов.Хозрасчетный.ТоварыНаСкладах;"

Оффлайн ***Vjacheslav***

  • ***
  • Сообщений: 156
  • РЕПУТАЦИЯ: 35
  • КПД: 22%
  • Регистрация: 2010-08-16
  • Сайт: 
  • Профессия: Программист 1С
Как я понял нужно во всех документах инвентеризации проставить это поле. То может сделать так:

   Запрос.Текст="ВЫБРАТЬ
                |   ИнвентаризацияТоваровНаСкладеТовары.Ссылка КАК Ссылка
                |ИЗ
                |   Документ.ИнвентаризацияТоваровНаСкладе КАК ИнвентаризацияТоваровНаСкладе";
   Выборка=Запрос.Выполнить().Выбрать();
   Пока Выборка.Следующий() Цикл;
      ОбъектИзм=Выборка.Ссылка.ПолучитьОбъект();
      Для Каждого Строка ИЗ ОбъектИзм.Товары Цикл
         Строка.СчетУчетаБУ=ПланыСчетов.Хозрасчетный.ТоварыНаСкладах;
      КонецЦикла;
      ОбъектИзм.Записать();
   КонецЦикла;

Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
СтрокаТЧ - выыводит ссылку на док. "Инвентаризация" - в окно обработки.
Причем было :
ОбъектИзм=СтрокаТЧ.Док.ПолучитьОбъект();
Но
ОбъектИзм.Товары - получает только табличную часть. А нужен РЕКВИЗИТ табЧасти "Товары".

Оффлайн ***Vjacheslav***

  • ***
  • Сообщений: 156
  • РЕПУТАЦИЯ: 35
  • КПД: 22%
  • Регистрация: 2010-08-16
  • Сайт: 
  • Профессия: Программист 1С
А вывод окно обработки: добавь после строки
ОбъектИзм=Выборка.Ссылка.ПолучитьОбъект();
СтрокаТЧ=ИзмДок.Добавить();
СтрокаТч.Док=Выборка.Ссылка;

Оффлайн Nail2010

  • ****
  • Сообщений: 325
  • РЕПУТАЦИЯ: 18
  • КПД: 6%
  • Регистрация: 2010-10-27
  • Сайт: 
***Vjacheslav***, спасибо! Теперь все работает.


Теги:
 

При открытии обр-ки в "Предприятии" есть ошибка, а в "Отладке" нет

Автор proofetРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4521
Последний ответ 21 Сен 2011, 17:35
от proofet
ошибка "Невозможно обработать параметр "ПрофильПолномочийПользователя""

Автор lindeluРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 6069
Последний ответ 06 Июн 2012, 09:15
от lindelu
Синтаксическая ошибка "В" Номенклатура.Ссылка = <<?>> В ИЕРАРХИИ(&Ссылка)

Автор maskitoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4186
Последний ответ 28 Апр 2014, 15:53
от maskito
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8472
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Ошибка при загрузке данных через (Обработка "Выгрузка и загрузка данных XML")

Автор Сергей_87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 8547
Последний ответ 26 Апр 2012, 23:08
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
160 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
35 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
27 Сообщений
Golickoff Golickoff
27 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 275
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal