Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
17 Дек 2017, 08:59
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Значения по умолчанию для параметров функции  (Прочитано 9160 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Shkerin

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 3
  • КПД: 5%
  • Регистрация: 2011-03-01
  • Сайт: 
  • Профессия: Программист 8.1
Добрый день!  B)

При программировании функции у меня возникло желание присвоить одному из параметров, значение по умолчанию.

Пример:
Функция ИзменитьРазмерСтроки(ВхСтрока, ВхРазмер, ВыхСимвол)
                                                   //---->Значениt по умолчанию ВыхСимвол=' '
// текст ф-ии
КонецФункции // ИзменитьРазмерСтроки

Вопрос: реализована поддержка в языке 1С значений по умолчанию?


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
А простите доступ к синтакс-помощнику у вас закрыт паролем?

смОтрите справку по ключевому слову "функция":

Функция (Funсtion)
Синтаксис:
     Функция <Имя_функции>([[Знач] <Парам1>[=<ДефЗнач>], ... ,[Знач] <ПарамN>[=<ДефЗнач>]])[Экспорт]
     Функция <Имя_функции>([[Знач] <Парам1>[=<ДефЗнач>], ... ,[Знач] <ПарамN>[=<ДефЗнач>]])[Экспорт]
     //Объявления локальных переменных;
     // Операторы ;
     ...
     Возврат <Возвращаемое значение>;
     // Операторы ;
     ...
     КонецФункции

Параметры:

     <Имя_функции>
     Назначает имя функции.

     Знач
     Необязательное ключевое слово, которое указывает на то, что следующий за ним параметр передается по значению, т.е. изменение значения формального параметра при выполнении функции никак не повлияет на фактический параметр, переданный при вызове функции. Если это ключевое слово не указано, то параметр функции передается по ссылке, то есть изменение внутри функции значения формального параметра приведет к изменению значения соответствующего фактического параметра.

     <Парам1>, ..., <ПарамN>
     Необязательный список формальных параметров, разделяемых запятыми. Значения формальных параметров должны соответствовать значениям передаваемых при вызове функции фактических параметров. В этом списке определяются имена каждого из параметров так, как они используются в тексте функции. Список формальных параметров может быть пуст.

     =<ДефЗнач>
     Необязательная установка значения параметра по умолчанию. Параметры с установленными значениями по умолчанию можно располагать в любом месте списка формальных параметров (подробнее см. раздел "Передача параметров процедур и функций").

     Экспорт
     Необязательное ключевое слово, которое указывает на то, что данная функция является доступной из других программных модулей.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Shkerin

  • **
  • Сообщений: 56
  • РЕПУТАЦИЯ: 3
  • КПД: 5%
  • Регистрация: 2011-03-01
  • Сайт: 
  • Профессия: Программист 8.1
упс.....то ли лыжи ни едут, то ли я дурак?
Перед тем как задать вопрос, просмотрел справку, книги, в инете поискал. Как говориться: "гляжу в книгу вижу фигу".

Итог следующий:

Функция ИзменитьРазмерСтроки(ВхСтрока, ВхРазмер, ВыхСимвол=" ")
// текст ф-ии
КонецФункции // ИзменитьРазмерСтроки

Спасибо Вам cska-fanat-kz!

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Не за что.
Еще раз простите, если был слишком резок )
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Значения некоторых колонок являются суммами некоторых колонок, которые в свою очередь так же являются суммами других. Как упорядочить?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 290
Последний ответ 26 Июн 2017, 14:32
от AsadRoman
Что быстрее: Загрузить табличную часть в запрос и там добавить колонки, или пробежаться циклом по ТЧ и добавить значения в колонки

Автор ZeedРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 990
Последний ответ 11 Июл 2016, 09:00
от vitasw
Как сложить значения Столбца "Объем"

Автор anton.kislovРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 19
Просмотров: 13567
Последний ответ 04 Май 2017, 10:48
от ospov11789
Ошибка "Итератор для значения не определён"

Автор КараулРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 848
Последний ответ 17 Авг 2016, 11:25
от Караул
Нужна помощь в формировании отчета "Преобразование значения к типу Дата не может быть выполнено"

Автор STLuka1337Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2097
Последний ответ 14 Ноя 2014, 13:24
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
145 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
50 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
42 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 179
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal