Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Авг 2020, 01:46
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5  (Прочитано 1735 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ksander-fars

  • **
  • Сообщений: 78
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2016-05-04
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте. ЗУП 2.5.
Подскажите куда смотреть для решения следующей проблемы. Есть документ "Зарплата к выплате", нужно что бы при подборе сотрудника в документ, в форме списка сотрудников документа подобранные помечались другим цветом, что бы было видно кто уже есть в списке документа а кого нет. Есть следующий листинг при подборе:
Процедура ОткрытьФормуВыбораСотрудникаОрганизации(Владелец, Ключ, ЗакрыватьПриВыборе, ДатаСреза, ГоловнаяОрганизация = Неопределено, Режим = 0, СтандартнаяОбработка = Неопределено, ТекущееЗначение = Неопределено, НеВыбиратьГруппы = Истина, ВыборФизлица = Ложь, ПараметрыПодбора = Неопределено, ПараметрыОтбора = Неопределено) Экспорт

СтандартнаяОбработка = Ложь;

Форма = Справочники.СотрудникиОрганизаций.ПолучитьФормуВыбора(, Владелец, Ключ);

Форма.ДатаСреза = ДатаСреза;
Если НеВыбиратьГруппы Тогда
Форма.ПараметрВыборГруппИЭлементов = ИспользованиеГруппИЭлементов.Элементы;
Иначе
Форма.ПараметрВыборГруппИЭлементов = ИспользованиеГруппИЭлементов.ГруппыИЭлементы;
КонецЕсли;
Форма.РежимВыбора = Истина;
Форма.ЗакрыватьПриВыборе = ЗакрыватьПриВыборе;
Форма.ВыборФизлица = ВыборФизлица;
Форма.мПараметрыПодбора = ПараметрыПодбора;

Если ТекущееЗначение <> Неопределено Тогда
Если ТипЗнч(ТекущееЗначение) = Тип("СправочникСсылка.СотрудникиОрганизаций") Тогда
Форма.ПараметрТекущаяСтрока = ТекущееЗначение;

ИначеЕсли ТипЗнч(ТекущееЗначение) = Тип("СправочникСсылка.ФизическиеЛица") Тогда
Форма.ПараметрТекущаяСтрока = ОсновнойСотрудникФизлица(ТекущееЗначение, ГоловнаяОрганизация);

ИначеЕсли ТипЗнч(ТекущееЗначение) = Тип("Массив") Тогда
Форма.мМассивВыбранныхЗначений = ТекущееЗначение;

Иначе
ОбщегоНазначенияЗК.СообщитьОбОшибке("Неверный тип параметра: " + ТипЗнч(ТекущееЗначение));

КонецЕсли;
КонецЕсли;

//установим отборы
Если ЗначениеЗаполнено(ГоловнаяОрганизация) Тогда
Форма.Отбор.Организация.Установить(ГоловнаяОрганизация);
Форма.Отбор.Организация.Использование = ЗначениеЗаполнено(ГоловнаяОрганизация);
КонецЕсли;

Форма.Отбор.ВидДоговора.ВидСравнения = ВидСравнения.ВСписке;
Форма.Отбор.ВидДоговора.Использование = Истина;
Форма.Отбор.ВидДоговора.Значение = ПроцедурыУправленияПерсоналомПереопределяемый.СписокДоговоровФормыВыбораСотрудника(Режим);

Если НЕ ПараметрыОтбора = Неопределено Тогда

Для каждого ЭлементОтбора Из ПараметрыОтбора Цикл

Если Форма.Отбор.Найти(ЭлементОтбора.Ключ) = Неопределено Тогда
Продолжить;
КонецЕсли;

ЗаполнитьЗначенияСвойств(Форма.Отбор[ЭлементОтбора.Ключ], ЭлементОтбора.Значение);

Если ЭлементОтбора.Значение.Свойство("НастройкаОтбора") Тогда
ТабличноеПоле = Форма.ЭлементыФормы.СправочникСписок;
ТабличноеПоле.НастройкаОтбора[ЭлементОтбора.Ключ].Доступность =  ЭлементОтбора.Значение.НастройкаОтбора;
КонецЕсли;

КонецЦикла;

КонецЕсли;

Форма.Открыть();

КонецПроцедуры // ОткрытьФормуВыбораСотрудникаОрганизации()
Будьте добры направьте на путь истинный :dfbsdfbsdf:


Оффлайн ksander-fars

  • **
  • Сообщений: 78
  • РЕПУТАЦИЯ: 1
  • КПД: 1%
  • Регистрация: 2016-05-04
  • Сайт: 
  • Профессия: Ученик 1С
Самое не понятное как можно пройтись по форме списка сотрудников?
Добавлено: 12 Окт 2017, 04:48

Подсказали решение по аналогии с документом "Сдельный наряд", добавил параметр при обращении к процедуре выше при подборе. Нужно было выгрузить колонку Физлица ТабЧасти зарплата. То есть вот было так:
ПроцедурыУправленияПерсоналом.ОткрытьФормуВыбораСотрудникаОрганизации(ЭлементыФормы.Зарплата, Ссылка, Ложь, Дата, мГоловнаяОрганизация, 0);
а надо так:
ПроцедурыУправленияПерсоналом.ОткрытьФормуВыбораСотрудникаОрганизации(ЭлементыФормы.Зарплата, Ссылка, Ложь, Дата, мГоловнаяОрганизация, 0, 
 ,Зарплата.ВыгрузитьКолонку("Физлицо"));
Плюс я раньше писал где то в модуле изменение цвета текста.

Осталось разобраться как при открытии помечать уже имеющихся сотрудников в документе.

Последний раз редактировалось: ksander-fars; 12 Окт 2017, 04:48. Причина: Объединение сообщений

Оффлайн wise

  • *****
  • Сообщений: 1067
  • РЕПУТАЦИЯ: 155
  • КПД: 15%
  • Кто сгорел, того не подожжешь
  • Регистрация: 2013-03-21
  • Сайт: 
  • Профессия: Ученик 1С
(0) выгрузи в массив ВСЕХ из документа
и на форму выбора поставь НЕ в списке
и НЕ придётся заморачиваться с оформлением...
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6220
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Автоматическое заполнение табличной части документа из табличной части другого

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 21681
Последний ответ 16 Авг 2012, 12:07
от Will
Заполнение столбца табличной части документа по умолчанию и выборка из табличной части.

Автор marshalbratskРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 3164
Последний ответ 25 Май 2016, 19:38
от marshalbratsk
Создание диалога(Да/Нет) и создание документа с проведением

Автор kolkinРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 10290
Последний ответ 17 Дек 2014, 07:59
от has
готовая компонента сканирования/загрузки / распознавания бумажных документов (счетов, налоговых накладных, приходных накладных) из бумажного документа в 1с

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1488
Последний ответ 14 Ноя 2017, 10:43
от oleg-x

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
83 Сообщений
alexandr_ll
27 Сообщений
antoneus antoneus
27 Сообщений
ToryFree ToryFree
25 Сообщений
LexaK
24 Сообщений
DmitriyF DmitriyF
16 Сообщений
BuhRust
16 Сообщений
Алексей_1985_06
15 Сообщений
Алексей Рожков Алексей Рожков
13 Сообщений
fredwriter
10 Сообщений

* Кто онлайн

  • Точка Гостей: 143
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal