Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
31 Мар 2020, 19:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Добавление строки и заполнение строки в ТЗ на форме  (Прочитано 2357 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Св Ч

  • **
  • Сообщений: 87
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2017-06-22
  • Сайт: 
Добрый День! Кто может подсказать? везде описано как добавить строку в ТЗ, но негде не описано если ТЗ на форме.
8.3, интерфейс обычный
вот код
  ТЗ=  Запрос.Выполнить().Выгрузить();
   Счетчик = 1;
   Отбор_дат = новый Соответствие;
   Отбор_сотрудников = новый Соответствие;
 
   Для Каждого Стр Из ТЗ Цикл
Отбор_дат.Вставить(Строка(Стр.Дат), Стр.Дат); 
Отбор_сотрудников.Вставить(Стр.Сотрудник,Стр.Сотрудник);
Счетчик = Счетчик + 1;
   КонецЦикла;   
   
    //добавляем колонки в таблицу значений
Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки.Добавить("отм");

Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки.Добавить("Сотрудник");

   Для Каждого Элемент Из Отбор_дат Цикл
       Сообщить(Строка(Элемент.Ключ) + " " + Элемент.Значение);
    //на каждую дату колонка оплата + колонка часы
   e="Ч"+Строка(День(Элемент.Значение)) + Строка(Месяц(Элемент.Значение));
   ee="О"+Строка(День(Элемент.Значение))+ Строка(Месяц(Элемент.Значение));
   если День(Элемент.Значение)>0 тогда
      Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки.Добавить(e);
      Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки.Добавить(ee);
       конецесли;
    КонецЦикла;    

 //добавляем дополнительные колонки
 //часы за период
  Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки.Добавить("Час_итого");
 //оплата за период
  Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки.Добавить("Опл_итого");
 //карточка за период
  Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки.Добавить("Карточки");
 //удержание
  Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки.Добавить("Удержание");
 //премии
  Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки.Добавить("Премии");
 //штрафы
  Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки.Добавить("Штраф");
 //выдача за период
  Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки.Добавить("Выдача");
  //Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.СоздатьКолонки();
    //добавляем строки в таблицу значений
   Для Каждого Элемент Из Отбор_сотрудников Цикл
      Сообщить(Строка(Элемент.Ключ) + " " + Элемент.Значение);
//по всем сотрудникам
           
 
  Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.ДобавитьСтроку();               
// стр = Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.ТекущаяСтрока;
//   Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке[1][1].Значение=   Элемент.Значение ;
//стр.Сотрудник=    Элемент.Значение;
// Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.Значение
//   Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке[1].Сотрудник = Элемент.Значение;




    КонецЦикла;

   

    ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки["отм"].Ширина=4;

ставлю строку
Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.СоздатьКолонки();
сразу ругается что не видит колонки в строке
ЭлементыФормы.ТабличноеПоле_На_проверке.Колонки["отм"].Ширина=4;
и колонки не добавляет, убираю не ругается и колонки добавляет.
ставлю
стр = Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке.ТекущаяСтрока;
стр.Сотрудник=    Элемент.Значение;

не видит поле стр.Сотрудник и ругается
Цитировать
поле объекта не обнаружено  Сотрудник=
ставлю
 Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке[1][1].Значение=   Элемент.Значение ;
ругается
Цитировать
Получение элемента по индексу для значения не определено
     Этаформа.ЭлементыФормы.ТабличноеПоле_На_проверке[1][1].Значение=   Элемент.Значение ;
как правильно добавить и заполнить строку (форма не управляемая)? Помогите пожалуйста


Оффлайн Св Ч

  • **
  • Сообщений: 87
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2017-06-22
  • Сайт: 


Теги:
 

Заполнение табл. части документа из табл. части другого документа

Автор WillРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 11
Просмотров: 10473
Последний ответ 16 Авг 2012, 21:50
от Will
Группа "СписокКомпоновщикНастроекПользовательскиеНастройки" в форме "Перечисления"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2918
Последний ответ 12 Ноя 2016, 18:08
от Азамат Хубиев
Изменение цвета при подборе сотрудника в форме списка справочника "Сотрудники организации" для документа "Зарплата к выплате организаций" ЗУП 2.5

Автор ksander-farsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1570
Последний ответ 12 Окт 2017, 14:02
от wise
Как настроить отображение на форме "группа плательщика единого налога" при выборе системы налогообложения "Единый налог"?

Автор Nicolayci91Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3190
Последний ответ 17 Авг 2015, 07:48
от cska-fanat-kz
Заполнение табличной части документа табличной частью из другого документа

Автор PeaceownerРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3271
Последний ответ 30 Ноя 2011, 07:10
от has

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
85 Сообщений
LexaK
59 Сообщений
antoneus antoneus
32 Сообщений
alexandr_ll
32 Сообщений
Алексей Рожков Алексей Рожков
31 Сообщений
ef0din
25 Сообщений
wise wise
20 Сообщений
Varg . Varg .
19 Сообщений
Алексей_1985_06
19 Сообщений
Alexbis
15 Сообщений

* Кто онлайн

  • Точка Гостей: 355
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal