Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
12 Дек 2017, 11:21
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: вывод результата в запросе с циклом  (Прочитано 4331 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ldmitriy

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-16
  • Сайт: 
  • Профессия: Программист 8.1
Доброго времени суток, хотел задать следующий вопрос, предприятие выпускает опоры, которые в свою очередь делятся ешё на детали, в запросе необходимо найти всё делали что входят в опору сгруппировать их и посчитать вес по каждой. сам вопрос заключается в следующем, в запросе можно выбрать 2 и более опоры, как сделать так чтобы в результате выполнения запроса с несколькими опорами в макет выводились все найденные делали по всем запрашиваемым опорам а не только по первой. заранее благодарен, не судите строго, месяц только работаю...

Процедура КнопкаСформироватьНажатие(Кнопка)
   Перем Итого;
   Итого=0;
   ТаблицаТаблицаВыбор = ЭлементыФормы.ТаблицаВыбор.Значение.Выгрузить();
   ТабДок = Новый ТабличныйДокумент;
   ТабДок.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РасчетПоВесу";
   Макет = ПолучитьМакет("Комплект");
   ОбластьШапка = Макет.ПолучитьОбласть("ШапкаВерх");
   ОбластьШапка.Параметры.Дата = ТекущаяДата();
   ТабДок.Вывести(ОбластьШапка);
   
   Для Каждого СтрокаТабличнойЧасти Из ТаблицаВыбор Цикл
      ОбластьВыбор=Макет.ПолучитьОбласть("Выбор");
      ОбластьВыбор.Параметры.НаименованиеПродукции = СтрокаТабличнойЧасти.Опоры;   
      ОбластьВыбор.Параметры.Количество = СтрокаТабличнойЧасти.Количество;
      ТабДок.Вывести(ОбластьВыбор);   
   КонецЦикла;
   
   ОбластьШапка = Макет.ПолучитьОбласть("ШапкаНиз");
   ТабДок.Вывести(ОбластьШапка);
   РезультатПоиска = Справочники.ВидыНоменклатуры.НайтиПоКоду("000000002");
   Для Каждого СтрокаТабличнойЧасти Из ТаблицаВыбор Цикл
      ЗапросОпоры = Новый Запрос;
      ЗапросОпоры.УстановитьПараметр("Материал", РезультатПоиска );
      ЗапросОпоры.УстановитьПараметр("Номенклатура", СтрокаТабличнойЧасти.Опоры  );
      ЗапросОпоры.Текст =    "ВЫБРАТЬ
      |   Металлопрокат.Номенклатура КАК НоменклатураМарка,
      |   СУММА(Металлопрокат.Количество * ЕдиницыИзмерения.Вес * Марки.Количество * Пакеты.Количество) КАК Вес
      |ИЗ
      |   РегистрСведений.КомплектующиеНоменклатуры КАК Пакеты
      |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних КАК ПакетыОсновныеСпецификацииСрезПоследних
      |         ЛЕВОЕ СОЕДИНЕНИЕ Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК Марки
      |            ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних КАК МаркиСпецификацииНоменклатурыСрезПоследних
      |               ЛЕВОЕ СОЕДИНЕНИЕ Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК Металлопрокат
      |                  ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ЕдиницыИзмерения КАК ЕдиницыИзмерения
      |                  ПО Металлопрокат.Номенклатура = ЕдиницыИзмерения.Владелец
      |               ПО МаркиСпецификацииНоменклатурыСрезПоследних.СпецификацияНоменклатуры = Металлопрокат.Ссылка
      |            ПО Марки.Номенклатура = МаркиСпецификацииНоменклатурыСрезПоследних.Номенклатура
      |         ПО (Марки.Ссылка = ПакетыОсновныеСпецификацииСрезПоследних.СпецификацияНоменклатуры)
      |      ПО Пакеты.Комплектующая = ПакетыОсновныеСпецификацииСрезПоследних.Номенклатура
      |ГДЕ
      |   Пакеты.Номенклатура = &Номенклатура
      |   И ЕдиницыИзмерения.Ссылка = Металлопрокат.ЕдиницаИзмерения
      |   И Металлопрокат.Номенклатура.ВидНоменклатуры = &Материал
      |
      |СГРУППИРОВАТЬ ПО
      |   Металлопрокат.Номенклатура
      |
      |ОБЪЕДИНИТЬ ВСЕ
      |
      |   ВЫБРАТЬ
      |   Металлопрокат.Номенклатура,
   //   | проверить сумму (позиции.кол-во)
      |   СУММА(Металлопрокат.Количество * ЕдиницыИзмерения.Вес * Позиции.Количество * Марки.Количество * Пакеты.Количество) КАК Вес
      |ИЗ
      |   РегистрСведений.КомплектующиеНоменклатуры КАК Пакеты
      |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних КАК ПакетыОсновныеСпецификацииСрезПоследних
      |         ЛЕВОЕ СОЕДИНЕНИЕ Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК Марки
      |            ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних КАК МаркиСпецификацииНоменклатурыСрезПоследних
      |               ЛЕВОЕ СОЕДИНЕНИЕ Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК Позиции
      |                  ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних КАК ПозицииСпецификацииНоменклатурыСрезПоследних
      |                     ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК Металлопрокат
      |                        ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ЕдиницыИзмерения КАК ЕдиницыИзмерения
      |                        ПО Металлопрокат.Номенклатура = ЕдиницыИзмерения.Владелец
      |                     ПО ПозицииСпецификацииНоменклатурыСрезПоследних.СпецификацияНоменклатуры = Металлопрокат.Ссылка
      |                  ПО Позиции.Номенклатура = ПозицииСпецификацииНоменклатурыСрезПоследних.Номенклатура
      |               ПО МаркиСпецификацииНоменклатурыСрезПоследних.СпецификацияНоменклатуры = Позиции.Ссылка
      |            ПО Марки.Номенклатура = МаркиСпецификацииНоменклатурыСрезПоследних.Номенклатура
      |         ПО (Марки.Ссылка = ПакетыОсновныеСпецификацииСрезПоследних.СпецификацияНоменклатуры)
      |      ПО Пакеты.Комплектующая = ПакетыОсновныеСпецификацииСрезПоследних.Номенклатура
      |ГДЕ
      |   Пакеты.Номенклатура = &Номенклатура
      |
      |СГРУППИРОВАТЬ ПО
      |   Металлопрокат.Номенклатура";
      
      ЗапросОпоры=ЗапросОпоры.Выполнить().Выгрузить();
      ЗапросОпоры.Свернуть("НоменклатураМарка", "Вес");
      ОбластьМеталл = Макет.ПолучитьОбласть("Металл");

      Для Каждого Строка Из ЗапросОпоры Цикл
         
               ЕСЛИ НЕ ЗначениеЗаполнено (Строка.Вес)  ТОГДА
      Иначе
            ОбластьМеталл.Параметры.СпецификацииНоменклатуры = Строка.НоменклатураМарка;
            ОбластьМеталл.Параметры.ВесПоМеталлу = Строка.Вес * СтрокаТабличнойЧасти.Количество;
            ТабДок.Вывести(ОбластьМеталл);
            Итого = Итого + Строка.Вес * СтрокаТабличнойЧасти.Количество;
         КонецЕсли;
      КонецЦикла;
      ОбластьИтого = Макет.ПолучитьОбласть("Итого");
      ОбластьИтого.Параметры.СуммаПоВесу = Итого;
      ТабДок.Вывести(ОбластьИтого);
   КонецЦикла;
   ТабДок.Показать();
КонецПроцедуры


Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Пишу замечания все подряд, как в голову приходили:
1. Области получайте один раз в самом начале процедуры
2. Запрос в цикле не есть хорошо. Очень медленно будет работать.
У вас и так там куча соединений. Что вам стоит добавить еще одно по которому вы цикл крутите? При невозможности добавляйте условие что-то типа "Опора В (&СписокОпор)" и в этот параметр выгружайте колонку из вашей ТЗ.
3. Зачем столько уровней? КомплектующиеНоменклатуры, СпецификацииНоменклатуры, ОсновныеСпецификацииНоменклатуры... Это самописно или что-то типовое? По логике вполне хватает пары уровней: Справочник Опоры и КомплектующиеОпор (последнее либо РегистрСведений, либо подчиненный справочник, либо ТЧ справочника Опоры)
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ldmitriy

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-16
  • Сайт: 
  • Профессия: Программист 8.1
Спасибо буду разбираться...
Уровней столько из-за вложенности, там ситуация такая, что опоры делятся на пакеты, те на марки, те на позиции и те на металлопрокат и по всем надо считать кол-во и перемножать, т.к. например в опоре может быть 6 пакетов, а у тех ещё по 2-3 марки, а посути это и есть подч. таблица исх.компл и регистр сведений.

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Зачем в запросе нужно Объединение?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн ldmitriy

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-16
  • Сайт: 
  • Профессия: Программист 8.1
Зачем в запросе нужно Объединение?

опять же из-за вложенности, в некоторые опорах марки ещё делятся на позиции а потом только на металлопрокат, а в некоторых сразу марки=>металлопрокат, т.е. разное кол-во вложенностей

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Уважаемый ldmitriy, я отказываюсь читать столько кода в таком виде. Отредактируйте, пожалуйста, свое сообщение, используя выделение кода (тег "code"). Или если редактирование уже не доступно - киньте код еще раз в удобочитаемом виде.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн ldmitriy

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-16
  • Сайт: 
  • Профессия: Программист 8.1
Процедура КнопкаСформироватьНажатие(Кнопка)
   Перем Итого;
   Итого=0;
   ТаблицаТаблицаВыбор = ЭлементыФормы.ТаблицаВыбор.Значение.Выгрузить();
   ТабДок = Новый ТабличныйДокумент;
   ТабДок.ИмяПараметровПечати = "ПАРАМЕТРЫ_ПЕЧАТИ_РасчетПоВесу";
   Макет = ПолучитьМакет("Комплект");
   ОбластьШапка = Макет.ПолучитьОбласть("ШапкаВерх");
   ОбластьШапка.Параметры.Дата = ТекущаяДата();
   ТабДок.Вывести(ОбластьШапка);
   
   Для Каждого СтрокаТабличнойЧасти Из ТаблицаВыбор Цикл
      ОбластьВыбор=Макет.ПолучитьОбласть("Выбор");
      ОбластьВыбор.Параметры.НаименованиеПродукции = СтрокаТабличнойЧасти.Опоры;   
      ОбластьВыбор.Параметры.Количество = СтрокаТабличнойЧасти.Количество;
      ТабДок.Вывести(ОбластьВыбор);   
   КонецЦикла;
   
   ОбластьШапка = Макет.ПолучитьОбласть("ШапкаНиз");
   ТабДок.Вывести(ОбластьШапка);
   РезультатПоиска = Справочники.ВидыНоменклатуры.НайтиПоКоду("000000002");
   Для Каждого СтрокаТабличнойЧасти Из ТаблицаВыбор Цикл
      ЗапросОпоры = Новый Запрос;
      ЗапросОпоры.УстановитьПараметр("Материал", РезультатПоиска );
      ЗапросОпоры.УстановитьПараметр("Номенклатура", СтрокаТабличнойЧасти.Опоры  );
      ЗапросОпоры.Текст =    "ВЫБРАТЬ
      |   Металлопрокат.Номенклатура КАК НоменклатураМарка,
      |   СУММА(Металлопрокат.Количество * ЕдиницыИзмерения.Вес * Марки.Количество * Пакеты.Количество) КАК Вес
      |ИЗ
      |   РегистрСведений.КомплектующиеНоменклатуры КАК Пакеты
      |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних КАК ПакетыОсновныеСпецификацииСрезПоследних
      |         ЛЕВОЕ СОЕДИНЕНИЕ Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК Марки
      |            ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних КАК МаркиСпецификацииНоменклатурыСрезПоследних
      |               ЛЕВОЕ СОЕДИНЕНИЕ Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК Металлопрокат
      |                  ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ЕдиницыИзмерения КАК ЕдиницыИзмерения
      |                  ПО Металлопрокат.Номенклатура = ЕдиницыИзмерения.Владелец
      |               ПО МаркиСпецификацииНоменклатурыСрезПоследних.СпецификацияНоменклатуры = Металлопрокат.Ссылка
      |            ПО Марки.Номенклатура = МаркиСпецификацииНоменклатурыСрезПоследних.Номенклатура
      |         ПО (Марки.Ссылка = ПакетыОсновныеСпецификацииСрезПоследних.СпецификацияНоменклатуры)
      |      ПО Пакеты.Комплектующая = ПакетыОсновныеСпецификацииСрезПоследних.Номенклатура
      |ГДЕ
      |   Пакеты.Номенклатура = &Номенклатура
      |   И ЕдиницыИзмерения.Ссылка = Металлопрокат.ЕдиницаИзмерения
      |   И Металлопрокат.Номенклатура.ВидНоменклатуры = &Материал
      |
      |СГРУППИРОВАТЬ ПО
      |   Металлопрокат.Номенклатура
      |
      |ОБЪЕДИНИТЬ ВСЕ
      |
      |   ВЫБРАТЬ
      |   Металлопрокат.Номенклатура,
   //   | проверить сумму (позиции.кол-во)
      |   СУММА(Металлопрокат.Количество * ЕдиницыИзмерения.Вес * Позиции.Количество * Марки.Количество * Пакеты.Количество) КАК Вес
      |ИЗ
      |   РегистрСведений.КомплектующиеНоменклатуры КАК Пакеты
      |      ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних КАК ПакетыОсновныеСпецификацииСрезПоследних
      |         ЛЕВОЕ СОЕДИНЕНИЕ Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК Марки
      |            ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних КАК МаркиСпецификацииНоменклатурыСрезПоследних
      |               ЛЕВОЕ СОЕДИНЕНИЕ Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК Позиции
      |                  ВНУТРЕННЕЕ СОЕДИНЕНИЕ РегистрСведений.ОсновныеСпецификацииНоменклатуры.СрезПоследних КАК ПозицииСпецификацииНоменклатурыСрезПоследних
      |                     ВНУТРЕННЕЕ СОЕДИНЕНИЕ Справочник.СпецификацииНоменклатуры.ИсходныеКомплектующие КАК Металлопрокат
      |                        ЛЕВОЕ СОЕДИНЕНИЕ Справочник.ЕдиницыИзмерения КАК ЕдиницыИзмерения
      |                        ПО Металлопрокат.Номенклатура = ЕдиницыИзмерения.Владелец
      |                     ПО ПозицииСпецификацииНоменклатурыСрезПоследних.СпецификацияНоменклатуры = Металлопрокат.Ссылка
      |                  ПО Позиции.Номенклатура = ПозицииСпецификацииНоменклатурыСрезПоследних.Номенклатура
      |               ПО МаркиСпецификацииНоменклатурыСрезПоследних.СпецификацияНоменклатуры = Позиции.Ссылка
      |            ПО Марки.Номенклатура = МаркиСпецификацииНоменклатурыСрезПоследних.Номенклатура
      |         ПО (Марки.Ссылка = ПакетыОсновныеСпецификацииСрезПоследних.СпецификацияНоменклатуры)
      |      ПО Пакеты.Комплектующая = ПакетыОсновныеСпецификацииСрезПоследних.Номенклатура
      |ГДЕ
      |   Пакеты.Номенклатура = &Номенклатура
      |
      |СГРУППИРОВАТЬ ПО
      |   Металлопрокат.Номенклатура";
     
      ЗапросОпоры=ЗапросОпоры.Выполнить().Выгрузить();
      ЗапросОпоры.Свернуть("НоменклатураМарка", "Вес");
      ОбластьМеталл = Макет.ПолучитьОбласть("Металл");

      Для Каждого Строка Из ЗапросОпоры Цикл
         
               ЕСЛИ НЕ ЗначениеЗаполнено (Строка.Вес)  ТОГДА
      Иначе
            ОбластьМеталл.Параметры.СпецификацииНоменклатуры = Строка.НоменклатураМарка;
            ОбластьМеталл.Параметры.ВесПоМеталлу = Строка.Вес * СтрокаТабличнойЧасти.Количество;
            ТабДок.Вывести(ОбластьМеталл);
            Итого = Итого + Строка.Вес * СтрокаТабличнойЧасти.Количество;
         КонецЕсли;
      КонецЦикла;
      ОбластьИтого = Макет.ПолучитьОбласть("Итого");
      ОбластьИтого.Параметры.СуммаПоВесу = Итого;
      ТабДок.Вывести(ОбластьИтого);
   КонецЦикла;
   ТабДок.Показать();
КонецПроцедуры

вот так?

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Да, так.
Как уже заметил cska-fanat-kz, получать область достаточно один раз:
   ОбластьВыбор=Макет.ПолучитьОбласть("Выбор");
   Для Каждого СтрокаТабличнойЧасти Из ТаблицаВыбор Цикл
      ОбластьВыбор.Параметры.НаименованиеПродукции = СтрокаТабличнойЧасти.Опоры;   
      ОбластьВыбор.Параметры.Количество = СтрокаТабличнойЧасти.Количество;
      ТабДок.Вывести(ОбластьВыбор);   
   КонецЦикла;

Теперь с запросом. Что-то мне подсказывает, что с объединением и количеством таблиц вы переборщили. Давайте разбираться, что где хранится.
Есть Регистр сведений "КомплектующиеНоменклатуры", где хранится связка Номенклатура(опоры)->Комплектующие(детали). так?\
А что у нас есть Спецификации номенклатуры? Исходные комплектующие? Как привызаны единицы измерения?
Опишите подробней.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 4123
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
Вывод комментария в документ "Расходная накладная" из документа "Заказ покупателя"

Автор ОльгаПлРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 204
Последний ответ 07 Окт 2017, 19:03
от Norfolk
РС "СостояниеОСОрганизаций" в запросе

Автор ILLUMIРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1112
Последний ответ 07 Янв 2015, 05:33
от ILLUMI
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 2111
Последний ответ 01 Янв 2017, 20:27
от Геннадий ОбьГЭС
Вывод линейной таблицы посредством СКД в виде "шахматки"

Автор VdegРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 10702
Последний ответ 19 Апр 2011, 11:12
от Klyacksa

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
168 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
55 Сообщений
alex0402
46 Сообщений
andron81_81
42 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 874
  • Точка Скрытых: 0
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal