Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 07:27

Не работают поля поиска в конвертации данных 2

Автор demon3, 18 авг 2017, 12:54

0 Пользователей и 1 гость просматривают эту тему.

demon3

Добрый день. Ситуация такая. Есть ПКО по переносу справочника номенкалтура из БП 2.0 В УПП 1.3.
Так как коды номенклатуры не соответствуют,в базе бп есть реквизит - КодУПП.

При загрузке в базу УПП номенклатуры, указаны поля поиска:

Если НомерВариантаПоиска = 1 Тогда
   Если ЗначениеЗаполнено(СвойстваПоиска["КодУПП"]) Тогда
      СтрокаИменСвойствПоиска = "КодУПП";
    Иначе
      СтрокаИменСвойствПоиска = Строка(НомерВариантаПоиска);
   КонецЕсли;
ИначеЕсли НомерВариантаПоиска = 2 Тогда
   СтрокаИменСвойствПоиска = "Код";
КонецЕсли;

В ПКО в конвертации свойств объекта первым стоит поле - КодУПП, вторым поле Код и у обоих стоит галочка поиска.

Источник КодУПП Приемник Код
Источник Код Приемник Код.

Проблема в том, что по "кодуУПП" из БП номенклатура в УПП не находится при загрузке данных и создается новая номенклатура с кодом элемента(реквизит стандартный - код, из БП)

Почему так происходит? Думаю ,что указан порядок свойств объекта в конвертации не правильный?
Помог ответом, скажи спасибо

oleg-x

Сделай так
Если НомерВариантаПоиска = 1 Тогда
   Если ЗначениеЗаполнено(СвойстваПоиска["КодУПП"]) Тогда
      СтрокаИменСвойствПоиска = "КодУПП";
    Иначе
      СтрокаИменСвойствПоиска = "Код";
   КонецЕсли;
КонецЕсли;
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

demon3

Цитата: oleg-x от 18 авг 2017, 13:38
Сделай так
Если НомерВариантаПоиска = 1 Тогда
   Если ЗначениеЗаполнено(СвойстваПоиска["КодУПП"]) Тогда
      СтрокаИменСвойствПоиска = "КодУПП";
    Иначе
      СтрокаИменСвойствПоиска = "Код";
   КонецЕсли;
КонецЕсли;


Все равно результат не изменился
Помог ответом, скажи спасибо

oleg-x

А галочки стоят на данных реквизитах, что это поля поиска?
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

demon3

Цитата: oleg-x от 21 авг 2017, 10:27
А галочки стоят на данных реквизитах, что это поля поиска?

Да.
Помог ответом, скажи спасибо

oleg-x

Пропишите в начале
Сообщить(СвойстваПоиска["КодУПП"])
Что выдаст
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

demon3

Цитата: oleg-x от 22 авг 2017, 15:36
Пропишите в начале
Сообщить(СвойстваПоиска["КодУПП"])
Что выдаст
Ничего не выводит через сообщить. Там видимо пусто. Попробывал сообщить СтрокаИменСвойствПоиска, получается что он выводит цифру один, так как условие на значениезаполнено(кодупп). Если оно не заполнено то искать цифру 1. Он сначала выводит цифру один а затем код. Но как так,что оно не заполнено,если оно заполнено?
Помог ответом, скажи спасибо

oleg-x

Сделай Сообщить("Здесь что то должно быть:" + СвойстваПоиска["КодУПП"])
Если пусто  выведет только текст.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск