Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
27 сен 2021, 06:03

Вывод контактной информации раздельно

Автор Space_minus, 06 авг 2017, 12:36

0 Пользователей и 1 гость просматривают эту тему.

Space_minus

Здравствуйте! Подскажите, как сделать раздельный вывод контактной информации(Адреса):  Регион - Город - Улица - Дом - Квартира в печатной форме?
Есть запрос который выводит контактную информацию(Адрес)

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Сведения_о_лицах_обучающихся_для_ГИБДД.Ссылка,
| Сведения_о_лицах_обучающихся_для_ГИБДДСписокСтудентов.Студент.Наименование КАК Обучающийся,
| АдресОбучающегося.Представление КАК АдресПоПрописке,
| Сведения_о_лицах_обучающихся_для_ГИБДДСписокСтудентов.Ссылка КАК Ссылка,
| Сведения_о_лицах_обучающихся_для_ГИБДДСписокСтудентов.Студент.ФизЛицо.Наименование КАК ФИО_СтудентаФизЛицоНаименование,
| Сведения_о_лицах_обучающихся_для_ГИБДДСписокСтудентов.Студент.ФизЛицо.РегионРождения.Наименование,
| Сведения_о_лицах_обучающихся_для_ГИБДДСписокСтудентов.Студент.ФизЛицо.Медицинское_Учреждение.Город,
| Сведения_о_лицах_обучающихся_для_ГИБДД.СотрудникГИБДД.Наименование КАК СотрудникГИБДД,
| Сведения_о_лицах_обучающихся_для_ГИБДД.УчебнаяГруппа.Специальность.ВидОбучения.Порядок КАК ВидОбучения,
| Сведения_о_лицах_обучающихся_для_ГИБДД.УчебнаяГруппа.Специальность.Категория.Наименование КАК Категория,
| Сведения_о_лицах_обучающихся_для_ГИБДД.УчебнаяГруппа.Наименование КАК Группа,
| Сведения_о_лицах_обучающихся_для_ГИБДД.УчебнаяГруппа.Дата_Поступления КАК НачОбуч,
| Сведения_о_лицах_обучающихся_для_ГИБДД.УчебнаяГруппа.ДатаОкончанияОбучения КАК ОкончОбуч,
| Сведения_о_лицах_обучающихся_для_ГИБДД.Организация.Наименование КАК Организация,
| Сведения_о_лицах_обучающихся_для_ГИБДД.УчебнаяГруппа.Специальность.ВидОбучения,
| Сведения_о_лицах_обучающихся_для_ГИБДД.Должность.Наименование КАК Должность,
| Сведения_о_лицах_обучающихся_для_ГИБДД.Сотрудник.Наименование КАК Сотрудник
|ИЗ
| Документ.Сведения_о_лицах_обучающихся_для_ГИБДД КАК Сведения_о_лицах_обучающихся_для_ГИБДД
| ЛЕВОЕ СОЕДИНЕНИЕ Документ.Сведения_о_лицах_обучающихся_для_ГИБДД.СписокСтудентов КАК Сведения_о_лицах_обучающихся_для_ГИБДДСписокСтудентов
| ПО Сведения_о_лицах_обучающихся_для_ГИБДД.Ссылка = Сведения_о_лицах_обучающихся_для_ГИБДДСписокСтудентов.Ссылка
| ЛЕВОЕ СОЕДИНЕНИЕ (ВЫБРАТЬ
| ФизическиеЛицаКонтактнаяИнформация.Ссылка КАК Ссылка,
| ФизическиеЛицаКонтактнаяИнформация.Представление КАК Представление,
| ФизическиеЛицаКонтактнаяИнформация.Страна КАК Страна,
| ФизическиеЛицаКонтактнаяИнформация.Регион КАК Регион,
| ФизическиеЛицаКонтактнаяИнформация.Город КАК Город
| ИЗ
| Справочник.ФизическиеЛица.КонтактнаяИнформация КАК ФизическиеЛицаКонтактнаяИнформация
| ГДЕ
| ФизическиеЛицаКонтактнаяИнформация.Тип = ЗНАЧЕНИЕ(Перечисление.ТипыКонтактнойИнформации.Адрес)
| И ФизическиеЛицаКонтактнаяИнформация.Вид = ЗНАЧЕНИЕ(Справочник.ВидыКонтактнойИнформации.АдресПоПрописке)) КАК АдресОбучающегося
| ПО Сведения_о_лицах_обучающихся_для_ГИБДД.СписокСтудентов.Студент.ФизЛицо.Ссылка = АдресОбучающегося.Ссылка
|ГДЕ
| Сведения_о_лицах_обучающихся_для_ГИБДД.Ссылка В(&Ссылка)
|
|УПОРЯДОЧИТЬ ПО
| ФИО_СтудентаФизЛицоНаименование
|АВТОУПОРЯДОЧИВАНИЕ";



вывод адреса полностью на печатную форму:

//вывод контактов
КонтактнаяИнформация = Строка.Студент.ФИзЛицо.КонтактнаяИнформация;
Для каждого СтрАдрес из КонтактнаяИнформация Цикл
Если КонтактнаяИнформация.Количество() > 0 Тогда
Если СтрАдрес.Вид = Справочники.ВидыКонтактнойИнформации.АдресПоПрописке Тогда
ОбластьМакета.Параметры.АдресПоПрописке = СтрАдрес.Представление;
КонецЕсли;
КонецЕсли;
КонецЦикла;



Space_minus

База колледж 1.1.3.2
Нут тут регистра сведений "Контактная информация" со всеми необходимыми реквизитами.

pavl_vs

Space_minus, посмотрите в Синтакс-помощнике (Работа со строками) д/б готовая функция СтрРазделить(АдресПоПрописке,","), которая вернет массив составляющих Адреса.

Space_minus

Пишет: {Документ.Сведения_о_лицах_обучающихся_для_ГИБДД.МодульМенеджера(494,17)}: Процедура или функция с указанным именем не определена (СтрРазделить)
МассивСтрок = <<?>>СтрРазделить(Справочники.ВидыКонтактнойИнформации.АдресПоПрописке,",");   (Проверка: Сервер)


alex0402

В вашей версии платформы СтрРазделить отсутствует, в более поздних - есть.
Можно использовать СтрЗаменить.
Текст = СтрЗаменить(Строка,",",Символы.ПС);
ПреваяСтрока = СтрПолучитьСтроку(Текст,1);
Спасибо за Сказать спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск