Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
24 Май 2018, 06:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Метод Найти работает для многомерных массивов?  (Прочитано 5474 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн nature2002

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-26
  • Сайт: 
  • Профессия: Программист 1С
что-то у меня не работает в двухмерном... Ищу строку с наименованием, чтобы по ней получить ссылку. В массиве есть строки(Наименование номенклатуры) и ссылки(ссылка на нее).

Группы = Новый Массив;

Пока ...
Группа = Справочники.Номенклатура.СоздатьГруппу();
Группа.Наименование = Чтение.Значение;
Родитель = Неопределено;
Позиция = Группы.Найти(Структура.Родитель);
Если НЕ(Позиция=Неопределено) тогда Родитель = Группы[Позиция][1]; КонецЕсли;
Группа.Родитель = ?(Родитель=Неопределено,Справочники.Номенклатура.ПустаяСсылка(),Родитель);
Группа.Записать();
Массив = Новый Массив(2);
Массив.Добавить(Группа.Наименование);
Массив.Добавить(Группа.Ссылка);
Группы.Добавить(Массив);
КонецЦикла;


Оффлайн nature2002

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-26
  • Сайт: 
  • Профессия: Программист 1С
что-то у меня не работает в двухмерном... Ищу строку с наименованием, чтобы по ней получить ссылку. В массиве есть строки(Наименование номенклатуры) и ссылки(ссылка на нее).
Группы = Новый Массив;

Пока....

Группа = Справочники.Номенклатура.СоздатьГруппу();
Группа.Наименование = Чтение.Значение;
Родитель = Неопределено;
Позиция = Группы.Найти(Структура.Родитель);
Если НЕ(Позиция=Неопределено) тогда Родитель = Группы[Позиция][1]; КонецЕсли;
Группа.Родитель = ?(Родитель=Неопределено,Справочники.Номенклатура.ПустаяСсылка(),Родитель);
Группа.Записать();
Массив = Новый Массив(2);
Массив.Добавить(Группа.Наименование);
Массив.Добавить(Группа.Ссылка);
Группы.Добавить(Массив);

КонецЦикла;

Оффлайн nature2002

  • *
  • Сообщений: 25
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-26
  • Сайт: 
  • Профессия: Программист 1С
заменила таблицей. все работает. вопрос решен.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
162 Сообщений
alex0402
76 Сообщений
oleg-x
68 Сообщений
AIFrame AIFrame
61 Сообщений
buketov.av buketov.av
44 Сообщений
wise wise
39 Сообщений
KOI8-R
35 Сообщений
ilyay ilyay
29 Сообщений
Анюта17
29 Сообщений
Alter
29 Сообщений

* Кто онлайн

  • Точка Гостей: 305
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal