Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 сен 2021, 01:36

Ссылка на несуществующий файл

Автор magnifico61, 29 июл 2017, 20:08

0 Пользователей и 1 гость просматривают эту тему.

magnifico61

В базе УТ 11 остались ссылки на удаленные картинка, картинки хранятся в томе на диске. Подскажите, как удалить ссылки на те файлы, которых нет на диске?

oleg-x

Сделай обработку, которая будет проверять по ссылке файл, если прочитать не удалось, то ссылку удалять.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

magnifico61

а как проверить файл на существование из 1С?

alex0402

ЦитироватьФайл.Существует (File.Exist)
Файл (File)
Существует (Exist)
Синтаксис:

Существует()
Возвращаемое значение:

Тип: Булево.
Истина - файл существует; Ложь - в противном случае.
Описание:

Определяет, существует ли файл, соответствующий данному объекту.

Доступность:

Тонкий клиент, веб-клиент, сервер, толстый клиент, внешнее соединение.
Примечание:

Для работы метода на веб-клиенте, необходимо предварительно подключить расширение работы с файлами.
Пример:

Функция ПроверитьСуществованиеКаталога(ИмяКаталога) Экспорт
    КаталогНаДиске = Новый Файл(ИмяКаталога);
    Если КаталогНаДиске.Существует() Тогда
        Возврат Истина;
    Иначе
        Ответ = Вопрос("Каталог не существует. Создать?",
                        РежимДиалогаВопрос.ОКОтмена);
        Если Ответ = КодВозвратаДиалога.ОК Тогда
            СоздатьКаталог(ИмяКаталога);
            Возврат Истина;
        Иначе
            Возврат Ложь;
        КонецЕсли;
    КонецЕсли;
КонецФункции

Спасибо за Сказать спасибо

magnifico61

а более подробно как получить и проверить файл.

alex0402

Цитата: magnifico61 от 31 июл 2017, 11:39
а более подробно как получить и проверить файл.
да куда уж подробнее? С примером кода! Две первых строки функции: КаталогНаДиске = Новый Файл(ИмяКаталога);
Если КаталогНаДиске.Существует() Тогда


Добавлено: 31 июл 2017, 13:13


Файл  каталог проверяются одинаково.
Спасибо за Сказать спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск