Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 01:58
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Промлема с Дополнительными реквизитами.  (Прочитано 2136 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн virus555

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-09
  • Сайт: 
  • Профессия: Бухгалтер
Работаю на 1С 8.2 Конфигурация - Управление торговлей 11.0.4.6
Подскажите пожалуйста - Справочник Номенклатура в модуле ФормаЭлемента я вставил функцию "СформироватьАвтоНаименование ()" (текст ниже) для того что бы Она объединяла поля из пунктов "Дополнительные реквизиты" в одну строчку. Эта строчка с помощью ф-ции "НаименованиеНачалоВыбораИзСписка" вставляется в поле "Наименование" (т.е. нажимаешь на кнопочку открытия списка, и из списка выбираешь сформированную строку).

Так вот хотелось бы сделать так, чтобы при выборе какого-либо пункта из "Дополнительных реквизитов" запускалась ф-ция "СформироватьАвтоНаименование()" и автоматом строка вставлялась в Объект Наименование.

Знаю есть ф-ция "ПриИзменении(Элемент)", но к какому объекту её привязать? Ведь все "Объекты" из "Дополнительных реквизитов" формируются динамически и их нет в реквизитах????????



&НаКлиенте
Функция СформироватьАвтоНаименование()

Элементы.Наименование.СписокВыбора.Очистить();

ИспользоватьСвойства = ПолучитьФункциональнуюОпциюФормы("ИспользоватьДополнительныеРеквизитыИСведения") ;

СтрокаНаименования = "";
Если ИспользоватьСвойства Тогда

НомерСвойства = 0;
Для Каждого ДополнительноеСвойство Из ЭтаФорма.__Свойства_ОписаниеДополнительныхРеквизитов Цикл
ЗначениеСвойства = ЭтаФорма[ДополнительноеСвойство.ИмяРеквизитаЗначение];
Если ЗначениеЗаполнено(ЗначениеСвойства) Тогда
НомерСвойства = НомерСвойства + 1;
СтрокаНаименования = СтрокаНаименования + ?(НомерСвойства = 1,"", ", ") + ЗначениеСвойства;
КонецЕсли;
КонецЦикла;

Если ЗначениеЗаполнено(СтрокаНаименования) Тогда
Элементы.Наименование.СписокВыбора.Добавить(СтрокаНаименования);
Объект.Наименование = СтрокаНаименования;
КонецЕсли;

КонецЕсли;

Возврат СтрокаНаименования;

КонецФункции // СформироватьАвтоНаименование()


&НаКлиенте
Процедура НаименованиеНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;

СформироватьАвтоНаименование();
ВыбранныйЭлемент = ВыбратьИзСписка(Элементы.Наименование.СписокВыбора, Элемент);
Если ВыбранныйЭлемент <> Неопределено Тогда
Объект.Наименование = ВыбранныйЭлемент.Значение;
КонецЕсли;

КонецПроцедуры // НаименованиеНачалоВыбораИзСписка()


Оффлайн virus555

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-09
  • Сайт: 
  • Профессия: Бухгалтер
НомерСвойства = 0;
Для Каждого ДополнительноеСвойство Из ЭтаФорма.__Свойства_ОписаниеДополнительныхРеквизитов Цикл
ЗначениеСвойства = ЭтаФорма[ДополнительноеСвойство.ИмяРеквизитаЗначение];
Если ЗначениеЗаполнено(ЗначениеСвойства) Тогда
НомерСвойства = НомерСвойства + 1;
СтрокаНаименования = СтрокаНаименования + ?(НомерСвойства = 1,"", ", ") + ЗначениеСвойства;
КонецЕсли;
КонецЦикла;

Если ЗначениеЗаполнено(СтрокаНаименования) Тогда
Элементы.Наименование.СписокВыбора.Добавить(СтрокаНаименования);
Объект.Наименование = СтрокаНаименования;
КонецЕсли;

КонецЕсли;

Возврат СтрокаНаименования;

КонецФункции // СформироватьАвтоНаименование()


&НаКлиенте
Процедура НаименованиеНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;

СформироватьАвтоНаименование();
ВыбранныйЭлемент = ВыбратьИзСписка(Элементы.Наименование.СписокВыбора, Элемент);
Если ВыбранныйЭлемент <> Неопределено Тогда
Объект.Наименование = ВыбранныйЭлемент.Значение;
КонецЕсли;

КонецПроцедуры // НаименованиеНачалоВыбораИзСписка()

Оффлайн virus555

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-09
  • Сайт: 
  • Профессия: Бухгалтер
Сори почему-то не получается вставить полный текст

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Форум недолюбливает квадратные скобки (

Для динамически создаваемых ЭУ есть метод УстановитьДействие - задаете имя события и имя процедуры, которая будет по нему выполняться.
Подробности - в СП.
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.


Теги:
 

Заполнение табличной части документа реквизитами табличной части справочника

Автор kaf_infoРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 623
Последний ответ 10 Май 2017, 20:44
от ilnur75
Режим ввода в окне табличной части через вызов формы с реквизитами

Автор Gigi SpokeРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 696
Последний ответ 13 Апр 2017, 17:11
от LexaK
ХЕЛП!!! Заполнение Табличной части документа Реквизитами Бизнес процессв

Автор KuBeR12Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1487
Последний ответ 25 Ноя 2013, 19:27
от MuI_I_Ika
active document, заполнение документа реквизитами из модуля менеджера

Автор vodezРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 8942
Последний ответ 31 Мар 2012, 22:08
от sergejK74
Как отобразить в панели действий общую форму с общими реквизитами

Автор Igig BraveРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 367
Последний ответ 29 Июн 2017, 23:04
от Igig Brave

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
178 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 182
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal