Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 сен 2021, 05:10

Вопросы по функции

Автор Dmitry Qwe, 25 июл 2017, 13:19

0 Пользователей и 1 гость просматривают эту тему.

Dmitry Qwe

Есть функция (Делаю по Радченко)

Функция РозничнаяЦена(АктуальнаяДата, ЭлементНоменклатуры) Экспорт
Отбор = Новый структура("Номенклатура", ЭлементНоменклатуры);
ЗначенияРесурсов = РегистрыСведений.Цены.ПолучитьПоследнее(АктуальнаяДата, Отбор);
Возврат ЗначениеРесурсов.Цена;
КонецФункции;

Не могу понять следующее:
1. Почему в параметры функции мы передаем именно "АктуальнаяДата" и "ЭлементНоменклатуры"
2. В структуре "Отбор" ключ - это измерение регистра, а что тогда есть значение ЭлементНоменклатуры?До этого момента нигде не объявляется такая переменная.
3. АктуальнаяДата - это какая-то зарезервированная системой переменная которая выводит актуальную дату? Если так то не могу найти ее в синтаксис помощнике. Если нет, то почему бы не использовать ТекущаяДата?

pavl_vs

Dmitry Qwe,
1. Цена - аттрибут Номенклатуры, сама по себе, это ни о чем.
2. См. вызывающую процедуру (функцию).
3. АктуальнаяДата не обязательно ТекущаяДата, а если Вам затребуется Конец предыдущего года?

Tsaiger

1. АктуальнаяДата - как выразился коллега выше потому, что мы получаем на определенную дата она может быть не всегда текущая!!!
2. В функции мы можем указывать псевдонимы как хотим. Т.е допустим так:

Процедура КакаяТоТам()

а=2;
КакаяТоТамЕще(а);

КонецПроцедуры

Функция КакаяТоТамЕще(b)

с = b+3;// с будет = 5, так как b=2, и не важно как мы ее назвали в функции, важен порядок передаваемых переменных

КонецФункции


3. Возврат ЗначениеРесурсов.Цена; - это то, что Метод "ПолучитьПоследнее" возвращает структуру, это обращение по ключу.


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск