Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
15 окт 2021, 22:48

Сделать кнопку создания документа на форме внешней обработки

Автор ThreeGun, 24 июл 2017, 16:37

0 Пользователей и 1 гость просматривают эту тему.

ThreeGun

Здравствуйте. Я нуб, подскажите, как сделать, ну или где почитать.
Сделать кнопку на форме внешней обработки, которая бы создавала заполненный документ при нажатии.
Заранее спасибо.

ThreeGun

Точнее соответствующую команду для кнопки.
Добавлено: 24 июл 2017, 17:33


Команду и кнопку я создал. Теперь она создает 1 документ при нажатии.
Что нужно дополнить в код формы, чтобы создавалось сразу несколько документов?

&НаКлиенте
Процедура Накладная (Команда)
СсылкаНаДокумент = СоздатьНовыйДокумент();
ОткрытьЗначение(СсылкаНаДокумент);

КонецПроцедуры

&НаСервере
Функция СоздатьНовыйДокумент()
НовыйДокумент = Документы.Накладная.СоздатьДокумент();
НовыйДокумент.Номер = "а1";
НовыйДокумент.Дата = ТекущаяДата();
НовыйДокумент.Записать();

Возврат НовыйДокумент.Ссылка;
КонецФункции

oleg-x

Как то так :D
&НаКлиенте
Процедура Накладная (Команда)
    ХочуТысячуДокументов = 0;
    Пока ХочуТысячуДокументов < 1001 Цикл
        СсылкаНаДокумент = СоздатьНовыйДокумент(ХочуТысячуДокументов);
        ОткрытьЗначение(СсылкаНаДокумент);
        ХочуТысячуДокументов = ХочуТысячуДокументов + 1;
    КонецЦикла;
КонецПроцедуры

&НаСервере
Функция СоздатьНовыйДокумент(ХочуТысячуДокументов)
    НовыйДокумент = Документы.Накладная.СоздатьДокумент();
    НовыйДокумент.Номер = ("а"+ХочуТысячуДокументов);
    НовыйДокумент.Дата = ТекущаяДата();
    НовыйДокумент.Записать();
   
    Возврат НовыйДокумент.Ссылка;
КонецФункции
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Dethmontt

Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск