Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Июн 2021, 08:04
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Сделать кнопку создания документа на форме внешней обработки  (Прочитано 3584 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ThreeGun

  • *
  • Регистрация: 2017-01-17
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Профессия: Разработчик 1С
Здравствуйте. Я нуб, подскажите, как сделать, ну или где почитать.
Сделать кнопку на форме внешней обработки, которая бы создавала заполненный документ при нажатии.
Заранее спасибо.


Оффлайн ThreeGun

  • *
  • Регистрация: 2017-01-17
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Профессия: Разработчик 1С
Точнее соответствующую команду для кнопки.
Добавлено: 24 Июл 2017, 17:33

Команду и кнопку я создал. Теперь она создает 1 документ при нажатии.
Что нужно дополнить в код формы, чтобы создавалось сразу несколько документов?
&НаКлиенте
Процедура Накладная (Команда)
СсылкаНаДокумент = СоздатьНовыйДокумент();
ОткрытьЗначение(СсылкаНаДокумент);

КонецПроцедуры

&НаСервере
Функция СоздатьНовыйДокумент()
НовыйДокумент = Документы.Накладная.СоздатьДокумент();
НовыйДокумент.Номер = "а1";
НовыйДокумент.Дата = ТекущаяДата();
НовыйДокумент.Записать();

Возврат НовыйДокумент.Ссылка;
КонецФункции

Последний раз редактировалось: ThreeGun; 24 Июл 2017, 17:33. Причина: Объединение сообщений

Оффлайн oleg-x

  • *****
  • Регистрация: 2016-11-02
  • Сообщений: 983
  • РЕПУТАЦИЯ: 238
  • КПД: 24%
  • Профессия: Программист 1С
Как то так :D
&НаКлиенте
Процедура Накладная (Команда)
    ХочуТысячуДокументов = 0;
    Пока ХочуТысячуДокументов < 1001 Цикл
        СсылкаНаДокумент = СоздатьНовыйДокумент(ХочуТысячуДокументов);
        ОткрытьЗначение(СсылкаНаДокумент);
        ХочуТысячуДокументов = ХочуТысячуДокументов + 1;
    КонецЦикла;
КонецПроцедуры

&НаСервере
Функция СоздатьНовыйДокумент(ХочуТысячуДокументов)
    НовыйДокумент = Документы.Накладная.СоздатьДокумент();
    НовыйДокумент.Номер = ("а"+ХочуТысячуДокументов);
    НовыйДокумент.Дата = ТекущаяДата();
    НовыйДокумент.Записать();
   
    Возврат НовыйДокумент.Ссылка;
КонецФункции
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Оффлайн Dethmontt

  • Денис
  • *****
  • Регистрация: 2010-11-01
  • Сообщений: 2892
  • РЕПУТАЦИЯ: 552
  • КПД: 19%
  • Адын Эс
  • Профессия: Программист 1С
НовыйДокумент.УстановитьНовыйНомер("а");
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Лбход элементов табличной части документа(проблема)

Автор metalstorm_tltРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 5383
Последний ответ 12 Сен 2010, 18:16
от metalstorm_tlt
Уменьшение чисел в справочнике при создании документа

Автор KATERINA 861Раздел Пользователям "1С - Предприятие 8"

Ответов: 7
Просмотров: 158
Последний ответ 21 Мая 2021, 13:58
от KATERINA 861
Запись в реквизит документа последнего значения РегСвед.

Автор Алексей_1985_06Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 566
Последний ответ 03 Фев 2020, 07:35
от alexandr_ll
Функция из общего модуля не видна в модуле документа

Автор ЛебедьРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 251
Последний ответ 29 Мая 2020, 15:20
от Геннадий ОбьГЭС
Как скопировать реквизит из одного документа в другой

Автор ReveluvРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 977
Последний ответ 27 Дек 2018, 15:17
от Reveluv

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
69 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
neek666
33 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
25 Сообщений
KATERINA 861
18 Сообщений
Алексей_1985_06
17 Сообщений
SSC
13 Сообщений
alexandr_ll
12 Сообщений
BuhRust
10 Сообщений

* Кто онлайн

  • Точка Гостей: 326
  • Точка Скрытых: 1
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск