Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 июн 2021, 19:22

Вывод розничной цены товара

Автор Саша Алдаев, 19 июл 2017, 15:00

0 Пользователей и 1 гость просматривают эту тему.

Саша Алдаев

Всем привет. Возникла такая проблема. Создаю Чек ККМ на основании другого док-та, а в этом чеке не могу понять, как вывести именно розничную цену. Кто-нибудь знает, например, с каким регистром или справочником надо работать. Действие происходит в 1с 8.3 Комплексная Автоматизация 2.

oleg-x

Наверное регистр цены номенклатуры (по крайне мере в УТ так).
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Саша Алдаев

Цитата: oleg-x от 19 июл 2017, 15:23
Наверное регистр цены номенклатуры (по крайне мере в УТ так).
Делаю

Для каждого ТекСтрока Из Основание.Товары Цикл

   НоваяСтрока.Цена = РегистрыСведений.ЦеныНоменклатуры.Измерения.ВидЦены.Розничные;

   КонецЦикла;


И выдает ошибку, что не найдены измерения.

AIFrame

Цитата: Саша Алдаев от 19 июл 2017, 15:32Для каждого ТекСтрока
Цитата: Саша Алдаев от 19 июл 2017, 15:32НоваяСтрока.Цена

ТекСтрока <> НоваяСтрока
Это раз.
НоваяСтрока.Цена = РегистрыСведений.ЦеныНоменклатуры.Измерения.ВидЦены.Розничные;
Несоответствие типов и неправильный способ получения цены.
Цены выбираются запросом по РегистрСведений.ЦеныНоменклатурыСрезПоследних в вашем случае.


Для каждого ТекСтрока Из Основание.Товары Цикл
    ЦенаРозничная = Справочники.ВидыЦенНоменклатуры.НайтиПоКоду("оывралыовра");
    Запрос = Новый Запрос;
    Запрос.Текст =  "ВЫБРАТЬ
                    |    _.Цена
                    |
                    |ИЗ
                    |    РегистрСведений.ЦеныНоменклатуры.СрезПоследних(,Номенклатура = &Номенклатура И ВидЦены = &ВидЦены) КАК _";
    Запрос.УстановитьПараметр("Номенклатура", ТекСтрока.Номенклатура);
    Запрос.УстановитьПараметр("ВидЦены", ЦенаРозничная);
    Выборка = Запрос.Выполнить().Выбрать();
   
    Если Выборка.Следующий() Тогда       
        ТекСтрока.Цена = Выборка.Цена;
    Иначе
        Сообщить("Для номенклатуры: " + ТекСтрока.Номенклатура + " - не найдена цена.");
    КонецЕсли;

КонецЦикла;

Саша Алдаев

Чуть-чуть подправил и всё заработало, спасибо!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск