Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 09:20

Как заполнить таблицу данными из справочника

Автор Сухраб, 19 июл 2017, 09:30

0 Пользователей и 1 гость просматривают эту тему.

Сухраб

есть справочник ТИРАЖИ: тираж(имя тиража)/кол-во/... Как заполнить таблицу данными из справочника?

Golickoff

Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Сухраб

Цитата: Golickoff от 19 июл 2017, 09:39
Какую таблицу? Какими данными?
Есть справочник например: товары, при нажатии кнопки ЗАПОЛНИТЬ нужно заполнить "таблицу значений", ну грубо говоря, вытянуть от туда наименования товаров в эту табличную часть???

alex0402

Выбока = Справочник.Товары.Выбрать();
Пока Выборка.Следующий() Цикл
    ЗаполнитьЗначенияСвойств(ИмяТабличнойЧасти.Добваить(),Выборка)
КонецЦикла;
Спасибо за Сказать спасибо

Сухраб

Цитата: alex0402 от 24 июл 2017, 15:54
Выбока = Справочник.Товары.Выбрать();
Пока Выборка.Следующий() Цикл
    ЗаполнитьЗначенияСвойств(ИмяТабличнойЧасти.Добваить(),Выборка)
КонецЦикла;

Не работает! вот, только не судите строго:dfbsdfbsdf:
    Процедура Заполнить()                 
   тз = СоздатьОбъект("ТаблицаЗначений");
Выборка = Справочник.Тиражи.Выбрать();
   Пока Выборка.Следующий() Цикл
       ЗаполнитьЗначенияСвойств(Тиражи.Добавить(),Выборка)
   КонецЦикла;   
КонецПроцедуры

alex0402

не работает как? пустая таблица? таблица с незаполненными значениями и т.д.
Спасибо за Сказать спасибо

Tsaiger

Цитата: alex0402 от 25 июл 2017, 10:17
не работает как? пустая таблица? таблица с незаполненными значениями и т.д.
А создать колонки в ТЗ ))))) И желательно одноименные, что бы воспользоваться ЗаполнитьЗначения(...

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск