Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Июн 2021, 16:07
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Неверный тип выделенных строк динамического списка  (Прочитано 1668 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Oread

  • *
  • Регистрация: 2017-07-17
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
Добрый день. Помогите пожалуйста разобраться. Платформа 8.3. Динамический список документов, массив выделенных строк возвращает массив чисел, а не документов. В чем может быть причина?


Оффлайн Golickoff

  • ****
  • Регистрация: 2015-02-05
  • Сообщений: 435
  • РЕПУТАЦИЯ: 47
  • КПД: 11%
  • НЕ Есть Null после шести
  • Профессия: Программист 1С
Вероятнее всего, это массив номеров выделенных строк. Покажите код.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн Oread

  • *
  • Регистрация: 2017-07-17
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
Вероятнее всего, это массив номеров выделенных строк. Покажите код.
МассивДокументов = Новый Массив;
   Для каждого ЗаписьРегистра Из Элементы.ЗачислениеЗарплаты.ВыделенныеСтроки Цикл
      МассивДокументов.Добавить(ЗаписьРегистра.ДокументЗачисленияЗарплаты);
   КонецЦикла;
   

код отлично работает для анлогичного запроса в другой информационной базе. различие только в одном слове в запросе. Документ и ДокументЗачисленияЗаплаты.

Оффлайн Golickoff

  • ****
  • Регистрация: 2015-02-05
  • Сообщений: 435
  • РЕПУТАЦИЯ: 47
  • КПД: 11%
  • НЕ Есть Null после шести
  • Профессия: Программист 1С
код отлично работает для анлогичного запроса в другой информационной базе. различие только в одном слове в запросе. Документ и ДокументЗачисленияЗаплаты.
Это не запрос. Если в массив добавляются числа, значит вы берёте данные не из той колонки.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн Oread

  • *
  • Регистрация: 2017-07-17
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
Я в курсе что это не запрос))) колонки тут вроде как непричем..выделяются строки. Запрос отрабатывает корректно.

Оффлайн Golickoff

  • ****
  • Регистрация: 2015-02-05
  • Сообщений: 435
  • РЕПУТАЦИЯ: 47
  • КПД: 11%
  • НЕ Есть Null после шести
  • Профессия: Программист 1С
Запрос отрабатывает корректно.
Я не вижу запрос.
МассивДокументов = Новый Массив; //Вы создаёте пустой массив
   Для каждого ЗаписьРегистра Из Элементы.ЗачислениеЗарплаты.ВыделенныеСтроки Цикл //Вы обходите все выделенные строки элемента формы с наименованием ЗачислениеЗарплаты
      МассивДокументов.Добавить(ЗаписьРегистра.ДокументЗачисленияЗарплаты); //Вы добавляете в созданный ранее массив значение из колонки с наименованием ДокументЗачисленияЗарплаты из текущей строки элемента формы с наименованием ЗачислениеЗарплаты
   КонецЦикла;
Тут явно есть колонки, раз вы обращаетесь к ним. И если в ней число, значит это не та колонка.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн AIFrame

  • *****
  • Регистрация: 2015-07-22
  • Сообщений: 1395
  • РЕПУТАЦИЯ: 184
  • КПД: 13%
  • Профессия: Программист 1С
Oread,
Просто проверь себя
МассивДокументов = Новый Массив;
   Для каждого ЗаписьРегистра Из Элементы.ЗачислениеЗарплаты.ВыделенныеСтроки Цикл
    Сообщить(ТипЗнч(ЗаписьРегистра.ДокументЗачисленияЗарплаты));
      МассивДокументов.Добавить(ЗаписьРегистра.ДокументЗачисленияЗарплаты);
   КонецЦикла;

Оффлайн alex0402

  • *****
  • Регистрация: 2010-09-10
  • Сообщений: 2000
  • РЕПУТАЦИЯ: 358
  • КПД: 18%
  • Профессия: Программист 1С
Добрый день. Помогите пожалуйста разобраться. Платформа 8.3. Динамический список документов, массив выделенных строк возвращает массив чисел, а не документов. В чем может быть причина?

Цитировать
ТаблицаФормы (FormTable)
ВыделенныеСтроки (SelectedRows)
Использование:

Только чтение.
Описание:

Тип: Массив.
Содержит массив идентификаторов выделенных строк.

Доступность:

Тонкий клиент, веб-клиент, сервер, толстый клиент.
См. также:

Расширение таблицы формы для динамического списка
Расширение таблицы формы для таблицы значений
ТаблицаФормы, метод ДанныеСтроки
ДанныеФормыКоллекция, метод НайтиПоИдентификатору
ДанныеФормыДерево, метод НайтиПоИдентификатору
ДанныеФормыСтруктураСКоллекцией, метод НайтиПоИдентификатору
Спасибо за Сказать спасибо


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
69 Сообщений
LexaK
67 Сообщений
antoneus antoneus
32 Сообщений
Ивашка
27 Сообщений
neek666
25 Сообщений
KATERINA 861
19 Сообщений
SSC
15 Сообщений
alexandr_ll
13 Сообщений
Алексей_1985_06
12 Сообщений
BuhRust
8 Сообщений

* Кто онлайн

  • Точка Гостей: 641
  • Точка Скрытых: 1
  • Точка Пользователей: 7
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск