Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 окт 2021, 00:15

Неверный тип выделенных строк динамического списка

Автор Oread, 17 июл 2017, 10:00

0 Пользователей и 1 гость просматривают эту тему.

Oread

Добрый день. Помогите пожалуйста разобраться. Платформа 8.3. Динамический список документов, массив выделенных строк возвращает массив чисел, а не документов. В чем может быть причина?

Golickoff

Вероятнее всего, это массив номеров выделенных строк. Покажите код.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Oread

Цитата: Golickoff от 17 июл 2017, 11:13
Вероятнее всего, это массив номеров выделенных строк. Покажите код.
МассивДокументов = Новый Массив;
   Для каждого ЗаписьРегистра Из Элементы.ЗачислениеЗарплаты.ВыделенныеСтроки Цикл
      МассивДокументов.Добавить(ЗаписьРегистра.ДокументЗачисленияЗарплаты);
   КонецЦикла;
   

код отлично работает для анлогичного запроса в другой информационной базе. различие только в одном слове в запросе. Документ и ДокументЗачисленияЗаплаты.

Golickoff

Цитата: Oread от 17 июл 2017, 12:33код отлично работает для анлогичного запроса в другой информационной базе. различие только в одном слове в запросе. Документ и ДокументЗачисленияЗаплаты.
Это не запрос. Если в массив добавляются числа, значит вы берёте данные не из той колонки.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Oread

Я в курсе что это не запрос))) колонки тут вроде как непричем..выделяются строки. Запрос отрабатывает корректно.

Golickoff

Цитата: Oread от 17 июл 2017, 12:58
Запрос отрабатывает корректно.
Я не вижу запрос.
МассивДокументов = Новый Массив; //Вы создаёте пустой массив
   Для каждого ЗаписьРегистра Из Элементы.ЗачислениеЗарплаты.ВыделенныеСтроки Цикл //Вы обходите все выделенные строки элемента формы с наименованием ЗачислениеЗарплаты
      МассивДокументов.Добавить(ЗаписьРегистра.ДокументЗачисленияЗарплаты); //Вы добавляете в созданный ранее массив значение из колонки с наименованием ДокументЗачисленияЗарплаты из текущей строки элемента формы с наименованием ЗачислениеЗарплаты
   КонецЦикла;

Тут явно есть колонки, раз вы обращаетесь к ним. И если в ней число, значит это не та колонка.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

AIFrame

Oread,
Просто проверь себя
МассивДокументов = Новый Массив;
   Для каждого ЗаписьРегистра Из Элементы.ЗачислениеЗарплаты.ВыделенныеСтроки Цикл
    Сообщить(ТипЗнч(ЗаписьРегистра.ДокументЗачисленияЗарплаты));
      МассивДокументов.Добавить(ЗаписьРегистра.ДокументЗачисленияЗарплаты);
   КонецЦикла;

alex0402

Цитата: Oread от 17 июл 2017, 10:00
Добрый день. Помогите пожалуйста разобраться. Платформа 8.3. Динамический список документов, массив выделенных строк возвращает массив чисел, а не документов. В чем может быть причина?

ЦитироватьТаблицаФормы (FormTable)
ВыделенныеСтроки (SelectedRows)
Использование:

Только чтение.
Описание:

Тип: Массив.
Содержит массив идентификаторов выделенных строк.

Доступность:

Тонкий клиент, веб-клиент, сервер, толстый клиент.
См. также:

Расширение таблицы формы для динамического списка
Расширение таблицы формы для таблицы значений
ТаблицаФормы, метод ДанныеСтроки
ДанныеФормыКоллекция, метод НайтиПоИдентификатору
ДанныеФормыДерево, метод НайтиПоИдентификатору
ДанныеФормыСтруктураСКоллекцией, метод НайтиПоИдентификатору
Спасибо за Сказать спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск