Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2021, 17:31
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: передача параметров документу при програмном создании  (Прочитано 3184 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн riff666

  • *
  • Регистрация: 2016-06-28
  • Сообщений: 29
  • РЕПУТАЦИЯ: 0
Всем добра. Помогите с решением проблемы. Создаю программно документ. При проведении этого документа надо чтобы заполнялся Регистрсведений. Проведение документа я отловил через подписку на событие. Когда обрабатываю документ при проведении я могу обратиться к его реквизитам. Мне необходимо что бы я мог обратиться к таблицы значений которую как то надо передать в событие ПриПроведении.
Если я могу обратиться к реквизитам документа, то есть мысль создать табличную часть с такой же структурой как у необходимой мне таблицы значений и уже работать с этой табличной частью. Но тогда вся эта табличная часть будет храниться в документе, а она и не нужна. Можно как то передать эту таблицу значений в процедуру Припроведении?
Вообще стоит задача заполнить Регистрсведений данными из таблицы значений. Я только додумался что это можно сделать путем создания документа и установке его как регистратор. Может есть другой способ заполнения регистрасведений?
В первой процедуре я заполняю таблицу значений, а во второй пытаюсь создать документ.
Процедура ЗаполнитьРегистрНажатие(Элемент)
Сообщить("Время начала расчета процентов: "+ТекущаяДата());
Проценты=ЗаполнениеПроцентов(ТекущиеДоговоры,НачалоДня(НачальнаяДата),КонецДня(КонечнаяДата));
СоздатьДок(Проценты);
Сообщить("Время окончания расчета процентов: "+ТекущаяДата());
КонецПроцедуры

&НаСервере
Процедура СоздатьДок(Проценты)
ПП = Документы.АЭ_ЗаполнениеПроцентов.СоздатьДокумент();
ПП.Дата=ТекущаяДата();
ПП.Записать(РежимЗаписиДокумента.Проведение);
КонецПроцедуры



Оффлайн alex0402

  • *****
  • Регистрация: 2010-09-10
  • Сообщений: 2000
  • РЕПУТАЦИЯ: 358
  • КПД: 18%
  • Профессия: Программист 1С
есть мысль создать табличную часть с такой же структурой как у необходимой мне таблицы значений и уже работать с этой табличной частью

Для этого у объекта есть специальный пеквизит ДополнительныеПараметры
Спасибо за Сказать спасибо

Оффлайн riff666

  • *
  • Регистрация: 2016-06-28
  • Сообщений: 29
  • РЕПУТАЦИЯ: 0
есть мысль создать табличную часть с такой же структурой как у необходимой мне таблицы значений и уже работать с этой табличной частью

Для этого у объекта есть специальный пеквизит ДополнительныеПараметры
Вы имели ввиду так?
&НаСервере
Процедура СоздатьДок(Проценты)
ПП = Документы.АЭ_ЗаполнениеПроцентов.СоздатьДокумент();
[b]ПП.ДополнительныеСвойства=Проценты;[/b]
ПП.Дата=ТекущаяДата();
ПП.Записать(РежимЗаписиДокумента.Проведение);
КонецПроцедуры
Если да то вываливается ошибка "{Форма.Форма.Форма(432)}: Поле объекта не обнаружено (ПП)"

Оффлайн alex0402

  • *****
  • Регистрация: 2010-09-10
  • Сообщений: 2000
  • РЕПУТАЦИЯ: 358
  • КПД: 18%
  • Профессия: Программист 1С
Да. ДополнительыеСвойства и это - структура...
Поэтому нужно
ПП.ДополнительныеСвойства.Вставить("Проценты",Проценты);
Спасибо за Сказать спасибо


 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
68 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
antoneus antoneus
33 Сообщений
Ивашка
27 Сообщений
neek666
26 Сообщений
KATERINA 861
19 Сообщений
Алексей_1985_06
15 Сообщений
SSC
15 Сообщений
alexandr_ll
14 Сообщений
pouyo
8 Сообщений

* Кто онлайн

  • Точка Гостей: 439
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск