Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Июн 2021, 16:51
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Работа с формами справочника  (Прочитано 2674 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gaur7

  • *
  • Регистрация: 2017-05-30
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
Имеется справочник - ЕдиницыИзмерения.
В этом справочнике есть: форма элемента и произвольная форма
В произвольной получаю список значений, с помощью выгрузки с сервера в табличную часть формы (реквизиты списка значений - name и guid)
а вот теперь вопрос: как можно в форме элемента сделать так, чтоб при нажатие кнопки (заполнить) оно находило соответствие из произвольной формы - по наименованию и автоматически заполнялось.
тоесть вбиваю в строчку наименование: килограмм
нажимаю кнопку заполнить, и в строчке name подбирает соответствие по данному наименованию.
либо более простой вариант реализации, нажимая кнопку заполнить, открывается список произвольной формы и самому выбрать соответствие
помогите пожалуйста, не знаю даже с чего начать :^454^:


Оффлайн Golickoff

  • ****
  • Регистрация: 2015-02-05
  • Сообщений: 435
  • РЕПУТАЦИЯ: 47
  • КПД: 11%
  • НЕ Есть Null после шести
  • Профессия: Программист 1С
Формы обычные, или управляемые?
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн gaur7

  • *
  • Регистрация: 2017-05-30
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
Golickoff, управляемые

Оффлайн Golickoff

  • ****
  • Регистрация: 2015-02-05
  • Сообщений: 435
  • РЕПУТАЦИЯ: 47
  • КПД: 11%
  • НЕ Есть Null после шести
  • Профессия: Программист 1С
Как вариант, можно попробовать поместить список во временное хранилище, адрес хранилища поместить в структуру и передать её в качестве параметра открытия формы элемента из произвольной формы.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн gaur7

  • *
  • Регистрация: 2017-05-30
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
Golickoff, мне тут подсказали - из формы элемента открыть произвольную форму со свойством Выбор=истина. При выборе, закрывать форму, ловить в первой.
Ток я не понимаю, как это реализовать. Вы не поможете?

Оффлайн Golickoff

  • ****
  • Регистрация: 2015-02-05
  • Сообщений: 435
  • РЕПУТАЦИЯ: 47
  • КПД: 11%
  • НЕ Есть Null после шести
  • Профессия: Программист 1С
Почитайте ответы в этой ветке. Возможно, внесёт ясность.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн gaur7

  • *
  • Регистрация: 2017-05-30
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
Golickoff, да спасибо, вполне помогло
теперь по нажатие кнопки в форме элемента открывает произвольная форма
но значение из списка я выбрать не могу, а только редактировать!

Оффлайн Golickoff

  • ****
  • Регистрация: 2015-02-05
  • Сообщений: 435
  • РЕПУТАЦИЯ: 47
  • КПД: 11%
  • НЕ Есть Null после шести
  • Профессия: Программист 1С
Сегодняшний гармоничный аспект Луны в Водолее к Юпитеру в Весах ослабляет мою экстрасенсорику, поэтому код придётся показать.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Оффлайн gaur7

  • *
  • Регистрация: 2017-05-30
  • Сообщений: 27
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
Golickoff, хорошо
форма элемента
----------------------------------------------------------------------------------------------------
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
   
   Если Не ЗначениеЗаполнено(Объект.Ссылка) Тогда
      Объект.Код = Параметры.Код;
      Объект.Наименование = Параметры.Наименование;
      Объект.НаименованиеПолное = Параметры.НаименованиеПолное;
      Объект.МеждународноеСокращение = Параметры.МеждународноеСокращение;
   КонецЕсли;        
   
КонецПроцедуры

&НаКлиенте
Процедура ЗаполнитьПоДаннымВЕТИС(Команда)
      
    Форма = ПолучитьФорму("Справочник.КлассификаторЕдиницИзмерения.Форма.ФормаПодбораИзКлассификатораВЕТИС", );
     Форма.Открыть();   
   
КонецПроцедуры
------------------------------------------------------------------------------------------------------

произвольная форма выглядит так
её код
-----------------------------------------------------------------------------------------------------
Перем Прокси;

&НаКлиенте
Процедура Заполнить(Команда)
   
   ЗаполнитьНаСервере();
   
КонецПроцедуры

Процедура ЗаполнитьНаСервере()
   
   Прокси = ОбменВЕТИС.ПолучитьПроксиDictionary();
   
   ListOptions = ОбменВЕТИС.ПолучитьListOptionsИзПрокси(Прокси);
   ListOptions.count = 4;
   Смещение = 0;
   //СписокЕдиницИзмерения.Очистить();
   Пока Истина Цикл
      ListOptions.offset = Смещение;   
      СписокВетис = Прокси.GetUnitList(ListOptions);
      Если ТипЗнч(СписокВетис) <> Тип("ОбъектXDTO") Тогда Прервать; КонецЕсли;
      Если СписокВетис.count = 0 Тогда Прервать; КонецЕсли;
      Для Каждого стр из СписокВетис.unit Цикл
         стр1 = СписокЕдиницИзмерения.Добавить();
         ЗаполнитьЗначенияСвойств(стр1, стр);
         стр1.ЕдиницаИзмерения = ОбменВЕТИС.ПолучитьОбъект1сПоGUID(стр1.GUID);
      КонецЦикла;
      Если СписокВетис.count + Смещение >= СписокВетис.total Тогда Прервать; КонецЕсли;
      Смещение = Смещение + ListOptions.Count;
   КонецЦикла;
   
КонецПроцедуры   

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
   
   
КонецПроцедуры
------------------------------------------------------------------------------------------------------
Результат!
При открытие справочника, открывается форма элемента
Нажимаю кнопку: заполнить по данным ветис - открывается произвольная форма
Ну на этом всё! Мне необходимо, чтоб открыв эту произвольную форму и выбрав определённый элемент
У меня после заполнялись поля в элементе формы: name и guid

Оффлайн Golickoff

  • ****
  • Регистрация: 2015-02-05
  • Сообщений: 435
  • РЕПУТАЦИЯ: 47
  • КПД: 11%
  • НЕ Есть Null после шести
  • Профессия: Программист 1С
Голова, доза, проба... Чёт подозрительно.
Форма = ПолучитьФорму("Справочник.КлассификаторЕдиницИзмерения.Форма.ФормаПодбораИзКлассификатораВЕТИС", );
Форма.Открыть();
Меняем на
Форма = ПолучитьФорму("Справочник.КлассификаторЕдиницИзмерения.Форма.ФормаПодбораИзКлассификатораВЕТИС", );
РезультатВыбора = Форма.ОткрытьМодально();
На произвольной форме добавляем жёлтую кнопку с синонимом "Выбрать", которая будет закрывать форму с передачей текущих данных.
Процедура КнопкаНашаКнопкаНажатие(Команда)
    Форма.Закрыть(ЗначенияКоторыеНужноПередать);
КонецПроцедуры;
Если использование модальности не устраивает, воспользуйтесь рефакторингом.
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

Последний раз редактировалось: Golickoff; 12 Июл 2017, 02:33


Теги:
 

Заполнить реквизиты документа из табличной части справочника

Автор Алексей_1985_06Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 484
Последний ответ 16 Сен 2019, 09:38
от LexaK
Заполнение полей документа данными другого документа/справочника

Автор Георгий ШиринкинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 3412
Последний ответ 20 Мая 2016, 09:40
от Георгий Ширинкин
Как записать выбранное значение из одного справочника в другой?

Автор skautРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 402
Последний ответ 02 Июн 2020, 14:21
от skaut
Отчет из Справочника созданием СКД

Автор EbyMixaРаздел Пользователям "1С - Предприятие 8"

Ответов: 8
Просмотров: 1589
Последний ответ 28 Фев 2018, 12:37
от EbyMixa
Сложная подстановка значений их справочника в документ

Автор AlsatiaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 8
Просмотров: 2659
Последний ответ 22 Мая 2015, 15:10
от Дмитрий@

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
69 Сообщений
LexaK
67 Сообщений
antoneus antoneus
32 Сообщений
Ивашка
28 Сообщений
neek666
25 Сообщений
KATERINA 861
19 Сообщений
SSC
15 Сообщений
alexandr_ll
13 Сообщений
Алексей_1985_06
12 Сообщений
MiThO
8 Сообщений

* Кто онлайн

  • Точка Гостей: 605
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск