Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Июн 2021, 16:43
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Розница 2.2.6.22 - обмен с ЕГАИС (не реально работать)  (Прочитано 2003 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн pic-0

  • *
  • Регистрация: 2017-07-01
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
Просьба побольшей части к разработчикам, уже второе обновление 2.2.6, общая команда "выполнить обмен" (кнопка в формах "выполнить обмен") перестала работать должным образом, при вызове процедуры ОбработатьОтветы в ОбщиеМодули.ИнтеграцияЕГАИСКлиент программа виснет напрочь, так как мало того что пытается обработать все сразу УТМ, так она еще и не обрабатывает ответы (тикеты), а пытается сразу загрузить входящие документы.
Вот как выглядела обработка ответов в 2.2.5.27:
НастройкиОбменаЕГАИС.ФормаСпискаРТ:
&НаКлиенте
Процедура ОбработатьОтветы(Команда)

ОповещениеПриЗавершении = Новый ОписаниеОповещения("ОбработкаОтветовИзЕГАИС_Завершение", ЭтотОбъект);
ИнтеграцияЕГАИСКлиент.НачатьОбработкуОтветов(ОповещениеПриЗавершении);

КонецПроцедуры
---->
ИнтеграцияЕГАИСКлиент:
Процедура НачатьОбработкуОтветов(ОповещениеПриЗавершении,
ТранспортныйМодуль = Неопределено, ОтображатьСообщения = Истина, ИдентификаторКлиента = Неопределено,
ДополнительныеПараметры = Неопределено, УстанавливатьКомпонентуHTTPЗапросов = Истина) Экспорт

Контекст = Новый Структура;
Контекст.Вставить("ОповещениеПриЗавершении", ОповещениеПриЗавершении);
Контекст.Вставить("ОтображатьСообщения"    , ОтображатьСообщения);
Контекст.Вставить("ИдентификаторКлиента"   , ИдентификаторКлиента);
Контекст.Вставить("ДополнительныеПараметры", ДополнительныеПараметры);
Контекст.Вставить("УстанавливатьКомпоненту", УстанавливатьКомпонентуHTTPЗапросов);
Контекст.Вставить("Результат"              , ИнтеграцияЕГАИСКлиентСервер.РезультатЗагрузкиВходящихДокументов());

Если ТранспортныйМодуль = Неопределено Тогда
ОповещениеВыбора = Новый ОписаниеОповещения("ОбработкаОтветов_ПослеВыбораТранспортногоМодуля", ЭтотОбъект, Контекст);
НачатьВыборТранспортногоМодуля(ОповещениеВыбора);
Иначе
ОбработкаОтветов_ПослеВыбораТранспортногоМодуля(ТранспортныйМодуль, Контекст);
КонецЕсли;

КонецПроцедуры
А вот стало в 2.2.6 (.18 и .22):
НастройкиОбменаЕГАИС.ФормаСписка:
&НаКлиенте
Процедура ВыполнитьОбмен(Команда)

ИнтеграцияЕГАИСКлиент.ВыполнитьОбмен();

КонецПроцедуры[/color]
--->
ИнтеграцияЕГАИСКлиент:
Процедура ВыполнитьОбмен(ОповещениеПриЗавершении = Неопределено, ТранспортныйМодуль = Неопределено) Экспорт

Если ТранспортныйМодуль = Неопределено Тогда
ТранспортныеМодули = ИнтеграцияЕГАИСВызовСервера.ДоступныеТранспортныеМодули();
Иначе
ТранспортныеМодули = Новый Массив;
ТранспортныеМодули.Добавить(ТранспортныйМодуль);
КонецЕсли;

ДополнительныеПараметры = Новый Структура;

Если ОповещениеПриЗавершении <> Неопределено Тогда
ДополнительныеПараметры.Вставить("ОповещениеПриЗавершении", ОповещениеПриЗавершении);
КонецЕсли;

ОповещениеПриЗавершенииОбмена = Новый ОписаниеОповещения("ПриЗавершенииОбмена", ЭтотОбъект, ДополнительныеПараметры);

Контекст = Новый Структура;
Контекст.Вставить("ТранспортныеМодули",          ТранспортныеМодули);
Контекст.Вставить("РезультатЗагрузкаДокументов", Новый Массив);
Контекст.Вставить("РезультатОбработкаОтветов",   Новый Массив);
Контекст.Вставить("ОповещениеПриЗавершении",     ОповещениеПриЗавершенииОбмена);

ЗагрузитьВходящиеДокументы(Неопределено, Контекст);

КонецПроцедуры

Повторюсь, клиент напрочь виснет при множественном запросе со всех утм (из них некотрые могут быть еще и оффлайн), и загрузка документов из утм заместо обработки тикетов это не правильно, например делаем перемещение, сформировали исходящую накладную или запросили остатки, обрабатываем ответы, а ответов нет, так как мы загружаем документы. Верните обработку запросов из предложенного списка настроек утм.:trhregerhg:


Теги:
 

Розница 2.0 Установка способа оплаты в документе Реализация товаров и услуг

Автор Natascha1990Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3752
Последний ответ 19 Мар 2013, 14:36
от Natascha1990
1С:Розница - тормоза пробития чека

Автор UzzusРаздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 1231
Последний ответ 04 Июл 2020, 11:22
от Каримдат
Розница 2.3: как отключить контроль проверки марок внутри базы

Автор Денис СклюевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 245
Последний ответ 13 Окт 2020, 09:44
от Денис Склюев
Розница Продажа по одной бутылке за раз

Автор maksimkat1Раздел Пользователям "1С - Предприятие 8"

Ответов: 3
Просмотров: 999
Последний ответ 09 Июл 2018, 11:57
от maksimkat1
4 магазина на одном фискальном регистраторе. 1с.Розница 2.2

Автор Михаил ДеминРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 430
Последний ответ 04 Янв 2019, 11:07
от Михаил Демин

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
68 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
68 Сообщений
antoneus antoneus
33 Сообщений
Ивашка
27 Сообщений
neek666
26 Сообщений
KATERINA 861
19 Сообщений
Алексей_1985_06
15 Сообщений
SSC
15 Сообщений
alexandr_ll
14 Сообщений
BuhRust
8 Сообщений

* Кто онлайн

  • Точка Гостей: 586
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск