Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
13 Дек 2017, 00:53
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Общее количество и сумма в Регистрах накопления  (Прочитано 2554 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн proofet

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-11
  • Сайт: 
  • Профессия: Ученик 1С
 :befhbt: При проведении документа "Реализация" нужно проверять в регистре накопления "Остатки", имеется ли заданное количество в остатке, и если для всех номенклатур есть, то делаем движение по регистру "Остатки"....Что нужно добавить в код полученный Конструктором Движений для суммирования по всем документам !?
Реализация:
Процедура ОбработкаПроведения(Отказ, Режим)

Для Каждого ТекСтрокаТовары Из Товары Цикл
// регистр Остатки Расход
Движение = Движения.Остатки.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
Движение.Количество = ТекСтрокаТовары.Количество;
//КонецЦикла;
//Для Каждого ТекСтрокаТовары Из Товары Цикл
// регистр Касса
Движение = Движения.Касса.Добавить();
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
Движение.Стоимость = ТекСтрокаТовары.Сумма;
//КонецЦикла;
//Для Каждого ТекСтрокаТовары Из Товары Цикл
// регистр ЦеныРозничные
Движение = Движения.ЦеныРозничные.Добавить();
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаТовары.Номенклатура;
Движение.Цена = ТекСтрокаТовары.Цена;
КонецЦикла;

КонецПроцедуры


Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Нужно
1. Достать по используемой номенклатуре остатки (запросом)
2. Сравнить их с тем, что хотим списать
3. Если достаточно - списываем, если не достаточно - ругаемся.

При этом, можно все это сделать одним запросом.
1. Выгружаем во временную таблицу Номенклатура-Количество из нашего документа
2. Потом к ней присоединяем текущие остатки
3. Группируем, и сравниваем КоличествоОстаток и Количество (из дока). Если хоть в одной строке товара не достаточно, то возвращаем запросом Ложь, иначе возвращаем - Истина
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Пусть почитает вот здесь:
http://forum-1c.ru/index.php?topic=6580.0

Зря что ли старались писали сообщений на 10 страниц? )
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
Пусть почитает вот здесь:
:ooifh:
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн proofet

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-02-11
  • Сайт: 
  • Профессия: Ученик 1С
Благодарю за помощь!)


Теги:
 

Отличие проводки по регистру сведений от проводки по регистру накопления?

Автор DirecTwiXРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4842
Последний ответ 18 Апр 2012, 02:19
от Dethmontt
Не заполняются колонки "Цена" и "Сумма" в отчете "Остатки товаров принятых на комиссию". УТ11

Автор VladimirMelnychenkoРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 467
Последний ответ 18 Янв 2017, 11:42
от VladimirMelnychenko
колонка "сумма"

Автор otabekРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1924
Последний ответ 01 Мар 2014, 14:13
от DmitriyF
В чем отличие регистра сведений от регистра накопления?

Автор Dmitry QweРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 483
Последний ответ 11 Сен 2017, 10:50
от ilyay
Строка в ВПФ итоговая строка, сумма прописью

Автор ali50Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 41
Просмотров: 17814
Последний ответ 20 Ноя 2012, 16:46
от ali50

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
170 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
38 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 222
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal