Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 15:23
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Программное заполнение реквизитов документа.  (Прочитано 8245 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
Добрый день.

Ответ на мой вопрос, как то уже дала уважаемая  Klyacksa, но к сожалению предложенный ею вариант у меня не сработал.
Мне необходимо из одной формы, открыть Форму конкретного документа и автоматически заполнить реквизиты этой формы.

Делаю следующее:

//закрываю тикущую форму
Закрыть(0);
//получаю документ
Документ = Документы.АктПриемаОборудования.СоздатьДокумент();
//заполняю реквизиты
Документ.ТипПриема = Перечисления.ТипПриема.ГарантийныйРемонт;
//открываю форму документа
Документ.ПолучитьФорму("ФормаДокумента").Открыть()

В результате этого форма открывается, но абсолютно пустая...что я делаю не так, или как правильно?

С уважением Александр.



Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
//закрываю тикущую форму
Закрыть(0);
//получаю документ
ДокументОбъект = Документы.АктПриемаОборудования.СоздатьДокумент();
//открываю форму документа
ФормаДокумента = ДокументОбъект.ПолучитьФорму("ФормаДокумента");
ФормаДокумента.ТипПриема = Перечисления.ТипПриема.ГарантийныйРемонт;
ФормаДокумента.Открыть();
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
Спасибо большее cska-fanat-kz ! Все работает четко.
Только вот предложенный вариант позволяет заполнить реквизиты документа а табличную часть не получается.

У меня в документе есть табличная часть "ПереченьОборудования" а ней есть колонкии SN, Наименование и прочии..Как быть с ними?

Делаю так:
...
ФормаДокумента.ПереченьОборудования.SN = ЭлементыФормы.Оборудование.SN.Значение;

Ругается, что элемент не найден?

ЭлементыФормы.Оборудование.SN.Значение - Это поле табличного документа, первой формы, значение которого я хочу передать в документ.


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
НС = ДокументОбъект.ПереченьОборудования.Добавить()
НС.Наименование = ...;

Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
cska-fanat-kz Вы как всегда в точку!
Есть еще одна проблемма. Помните мы вместе с Вами создовали ТаблицуЗначений+ТабличноеПоле+КоманднуюПанель из встроенного языка? Так вот теперь мне необходимо данные из этой ТаблицыЗначений перенести в соответствующее ТабличноеПоле документа.


Вот код ТаблицыЗначений+ТабличногоПоля+КоманднойПанели:

 //Создаем табличное поле для ввода оборудования
Если ЭлементыФормы.Найти("Оборудование") = Неопределено Тогда
ТабЗн = Новый ТаблицаЗначений;
ТабЗн.Колонки.Добавить("SN", Новый ОписаниеТипов("СправочникСсылка.СерийныеНомера"));
ТабЗн.Колонки.SN.Ширина = 32;
ТабЗн.Колонки.Добавить("Оборудование", Новый ОписаниеТипов("СправочникСсылка.Номенклатура"));
ТабЗн.Колонки.Оборудование.Ширина = 32;
ТабЗн.Колонки.Добавить("Комплектация", Новый ОписаниеТипов("Строка"));
ТабЗн.Колонки.Комплектация.Ширина = 35;
ТабЗн.Колонки.Добавить("ВнешнийВид", Новый ОписаниеТипов("Строка"));
ТабЗн.Колонки.ВнешнийВид.Ширина = 35;
ТабЗн.Колонки.Добавить("Кол", Новый ОписаниеТипов("Строка"));
ТабЗн.Колонки.Кол.Ширина = 10;
ТабЗн.Колонки.Добавить("ОтПоставщика", Новый ОписаниеТипов("ПеречислениеСсылка.ПринятоОтПоставщика"));
ТабЗн.Колонки.ОтПоставщика.Ширина = 20;
ТабЗн.Колонки.Добавить("Диагноз", Новый ОписаниеТипов("Строка"));
ТабЗн.Колонки.Диагноз.Ширина = 35;
ТабЗн.Колонки.Добавить("ПредЦена", Новый ОписаниеТипов("Строка"));
ТабЗн.Колонки.ПредЦена.Ширина = 12;




//НоваяСтрока = ТабЗн.Добавить();
//НоваяСтрока.SN = Справочники.СерийныеНомера.НайтиПоКоду(000002);

ТабПоле = ЭлементыФормы.Добавить(Тип("ТабличноеПоле"), "Оборудование", Истина);
ТабПоле.Лево = 15; ТабПоле.Верх = 195;
ТабПоле.Ширина = ЭтаФорма.Ширина - 30;
ТабПоле.Высота = 70;
ТабПоле.ТолькоПросмотр = ЛОЖЬ;
ТабПоле.ТипЗначения = Новый ОписаниеТипов("ТаблицаЗначений");
ТабПоле.Значение = ТабЗн;
ТабПоле.СоздатьКолонки();

КПанель = ЭлементыФормы.Добавить(Тип("КоманднаяПанель"), "КоманднаяПанельКТаблице", Истина);
Кпанель.Лево = 15;
Кпанель.Верх = 170;
Кпанель.Ширина = Этаформа.Ширина - 30;
Кпанель.Высота = 20;

КПанель.ИсточникДействий = ЭлементыФормы.Оборудование;
Кпанель.АвтоЗаполнение = Истина;
Иначе
ЭлементыФормы.Оборудование.Видимость = Истина;
ЭлементыФормы.КоманднаяПанельКТаблице.Видимость = Истина;
КонецЕсли;



КонецПроцедуры

ТП = ДокументОбъект.ПереченьОборудования.Добавить();
ТП.SN = ТабЗн.??????;

Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
Простите progmikon Вам конечно тоже спасибо большее!

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Не за что.

1. Если вам нужно из ТЗ загрузить в табличную часть, то можно:
ДокументОбъект.ПереченьОборудования.Загрузить(ТЗ);// если имена колонок совпадают, то это самый быстрый вариант
или
Для Каждого ТекСтрока Из ТЗ Цикл
ТП = ДокументОбъект.ПереченьОборудования.Добавить();
ТП.SN = ТекСтрока.СерийныйНомер;
КонецЦикла;

Оффлайн |R|U|D|E|N

  • ***
  • Сообщений: 217
  • РЕПУТАЦИЯ: 3
  • КПД: 1%
  • Регистрация: 2011-01-09
  • Компания: Virtual-Kernel | KVM | Xen
  • Профессия: Разработчик 1С
progmikon спасибо!  :zebzdr:

ДокументОбъект.ПереченьОборудования.Загрузить(ТЗ);
- Это самая генеальная, простая и эффективная синтаксическая конструкция из всех что я пока видел в 1с))

Все работает! Тема закрыта.


Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 4476
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 7746
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4784
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 8519
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 7343
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
177 Сообщений
ilyay ilyay
69 Сообщений
alex0402
52 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal