Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 07:22

Значение не является значением объектного типа (ХарактеристикаНоменклатуры)

Автор ksru, 25 июн 2017, 21:51

0 Пользователей и 1 гость просматривают эту тему.

ksru

занимаюсь 1с не много так что не судите строго. Помогите найти ошибку
вылезает ошибка
{Документ.ИнвентаризацияТоваровНаСкладе.Форма.ФормаДокумента.Форма(1167)}: Значение не является значением объектного типа (ХарактеристикаНоменклатуры)
Для каждого СтрокаТабличнойЧасти Из СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры Цикл


Вот сам код
Процедура ПриИзмененииДанных()
//



СтрокаТабличнойЧасти = ЭлементыФормы.Товары.ТекущиеДанные;



Для каждого СтрокаТабличнойЧасти Из СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры Цикл


Строка = СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры;
// возьмём начиная с 15 индекса 11 символа
ВозвратДата=(Сред(Строка, 16, 10)); // дата 01.01.0001
День=(Сред(ВозвратДата, 1, 2));
Месяц=(Сред(ВозвратДата, 4, 2));
Год=(Сред(ВозвратДата, 7, 4));
НачалаПроизводства=Дата(Год, Месяц, День);
//вычисляем смену
Переменная =СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры;
Позиция = Найти(Переменная, ", Д");
Если Позиция=26 Тогда Смена=НачалаПроизводства+3*60*60*24;
ИначеЕсли Позиция=0 тогда
Позиция = Найти(Переменная, ", Н");
Если Позиция=26  Тогда Смена=НачалаПроизводства+3*60*60*24+(60*60*12);
иначе СтрокаТабличнойЧасти.Партия="";
КонецЕсли;
КонецЕсли;
Если Смена>ТекущаяДата() тогда
СтрокаТабличнойЧасти.Партия="На созревании до, "+Смена+", Н";
иначе СтрокаТабличнойЧасти.Партия="Готово, "+Смена+", Д";
КонецЕсли;
//
КонецЦикла ;
КонецПроцедуры


oleg-x

У твоей характеристики есть табличная часть? Ты в этом уверен?
И ни когда не делай так
Для каждого СтрокаТабличнойЧасти Из СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры Цикл
Нужно, это если у твой характеристики была бы табличная чать
Для каждого стр (но не повторять) Из СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры.ТвояТаблица Цикл
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

ksru

Цитата: oleg-x от 25 июн 2017, 22:09
У твоей характеристики есть табличная часть? Ты в этом уверен?

вроде как есть

oleg-x

Цитата: ksru от 25 июн 2017, 22:11
Цитата: oleg-x от 25 июн 2017, 22:09
У твоей характеристики есть табличная часть? Ты в этом уверен?

вроде как есть
Открой конфигурацию и посмотри данный справочник и найди название табличной части
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

ksru

Цитата: oleg-x от 25 июн 2017, 22:15
Цитата: ksru от 25 июн 2017, 22:11
Цитата: oleg-x от 25 июн 2017, 22:09
У твоей характеристики есть табличная часть? Ты в этом уверен?

вроде как есть
Открой конфигурацию и посмотри данный справочник и найди название табличной части


это Документ «Инвентаризация товаров на складе»


oleg-x

В документе табличная часть, в которой есть колонка характеристика номенклатуры, и ты хочешь обратиться к таблицы этой характеристики? или Табличной части самого документа?
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

ksru

Цитата: oleg-x от 25 июн 2017, 22:57
В документе табличная часть, в которой есть колонка характеристика номенклатуры, и ты хочешь обратиться к таблицы этой характеристики? или Табличной части самого документа?
хочу обратиться к табличной части в которой есть колонка характеристика номенклатуры

oleg-x

Тогда Для каждого СтрокаТабличнойЧасти Из ЭлементыФормы(объект/ссылка).ИмяТаблицы Цикл
Характеристика = СтрокаТабличнойЧасти.ХарактеристикаНоменклатуры;
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск