Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Дек 2017, 05:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Новичок! установление новых цен в справочнике!  (Прочитано 2235 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн аня

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-05-28
  • Сайт: 
Добрый вечер!
в поступление сделала кнопку обновить цены в справочнике, повесила на нее процедуру, но не могу сделать что бы обновлялась только та номенклатура у которой цена повысилась, а не уменьшилась.
Процедура...
создаю спр.цен
выбираю строки
получаю строку
использую владельца
и по том ищу по реквизиту и устанавливаю цену на дату документа.
 конецпроцедуры

помогите кто знает!!!


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
// C прошедшими праздниками !!!
//Набрось на форму  элемент диалога "ТипЦеныТек"
//тип "справочник.ТипыЦен"

Цены = СоздатьОбъект("Справочник.Цены");   
ВыбратьСтроки();
Пока ПолучитьСтроку() = 1  Цикл
Активизироватьстроку(НомерСтроки)
   Цены.ИспользоватьВладельца(Номенклатура.ТекущийЭлемент());
   Цены.ВыбратьЭлементы();
   
   Пока Цены.ПолучитьЭлемент()  = 1 Цикл   
      Если ТипЦеныТек.Рассчитывается = 1  тогда

      
      СпрТипыЦен = СоздатьОбъект("Справочник.ТипыЦен");
       СпрТипыЦен.ВыбратьЭлементы();
      Пока СпрТипыЦен.ПолучитьЭлемент() = 1 Цикл         
      Если (СпрТипыЦен.ТекущийЭлемент() = ТипЦеныТек) Тогда
         // Если цена рассчитывается
         Если глВернутьЦену(СпрНом1.ТекущийЭлемент(), ТипЦеныТек, ДатаДок, ЦенаЦены, ЕдЦены, ) = 1 Тогда
            
         
            РеалЦенаОб         = ТипЦеныТек;
            РеалЦена        = ЦенаЦены;
            Прервать;
         КонецЕсли;
      КонецЕсли;
       КонецЦикла;
      

      
       ИначеЕсли ТипЦеныТек.Рассчитывается <> 1 Тогда
         Если Цены.ТипЦен <> ТипЦеныТек Тогда
             Продолжить;
          КонецЕсли;
           РеалЦенаОб = Цены.ТекущийЭлемент();
            РеалЦена = РеалЦенаОб.Цена.Получить(ДатаДок);
   
       КонецЕсли;   
   КонецЦикла;
  Если  РеалЦена <> Цена  тогда
  Цена = РеалЦена;
  КонецЕсли;
КонецЦикла;

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
это не на " больше  меньше"
это пример - как отловить цену,
тут замена в документе от справочника,
а если надо назначить цену  на датудока  в самом справочнике,
то надо просто внутри цикла при получении.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
180 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
51 Сообщений
alex0402
49 Сообщений
andron81_81
39 Сообщений
AIFrame
37 Сообщений
MuI_I_Ika MuI_I_Ika
34 Сообщений
BuhRust
29 Сообщений
Golickoff Golickoff
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 228
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal