Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 сен 2021, 05:27

Передать и вставить значение в ФормыВыбора

Автор Igig Brave, 18 июн 2017, 13:51

0 Пользователей и 1 гость просматривают эту тему.

Igig Brave

Всем привет!
Сталкнулся с проблемой ... требуеться Ваша помощь.
Нужно два раза запустить ФормуВыбора и в самим вставленные поля пойска каждой вставить нужное значения выбора элемента.
Внизу процедура кнопки.
И дело в том, что то, что обозначенно коментарием: "ЗАПУСК 1" работает нормально. Т.е. когда форма открылась нужное значение успешно всавляеться в нужное поле Формы на верхней ее панели.
Но уже во втором случае (в месте обозначеном: "ЗАПУСК 2"), никак не получаеться получить то же самое, что и при ЗАПУСКЕ 1
Т.е. переменные в: Предупреждение(ОБЪЕКТимя+" -- "+знТочкаСнабжения); передаются, но вторая: "ТочкаСнабжения" НУ НИКАК НЕ ВСТАВЛЯЕТЬСЯ в поле формы: "ТочкаСнабжения"
Не пойму в чем причина.
Рассчитываю на Вашу помощь

&НаКлиенте
Процедура СубТочка_Выбрать(Команда)
Если Объект.Код = ""  Тогда
Предупреждение("Для определения суб-точек учета объект не сохранен!");
Перейти ~Выход;
Иначе
ОБЪЕКТимя=Объект.Найменование;
КонецЕсли;
//=============== ЗАПУСК 1 ============================
ФормаВыбор_ТочкаСнабжение=ПолучитьФорму("Справочник.ТОЧКА.ФормаВыбора",,ЭтаФорма);
ФормаВыбор_ТочкаСнабжение.ОбъектПринадлежности=ОБЪЕКТимя;
//-------------------------------------------
Выбор_ТочкаСнабжение = ФормаВыбор_ТочкаСнабжение.ОткрытьМодально();
//=====================================================
Если Выбор_ТочкаСнабжение <> Неопределено Тогда
//=============== ЗАПУСК 2 ============================
знВыборПолучить = ПолучитьФорму("Справочник.ТОЧКА.ФормаОбъекта", новый Структура("Ключ", Выбор_ТочкаСнабжение));
знТочкаСнабжения=знВыборПолучить.Объект.Найменование;
//################## ФРАГМЕНТ КОДА ДЛЯ ИСПРАВЛЕНИЯ #############################
ФормаВыбор_ТочкаПодключение = ПолучитьФорму("Справочник.ТОЧКА.ФормаВыбора",,); //ФормаВыбор_ТочкаПодключение = ПолучитьФорму("Справочник.ТОЧКА.Форма.ФормаВыбора",,);
//ТУТ ПОЛЕ ФормыВыбора: "ТочкаСнабжения", НУ НИКАК НЕ ХОЧЕТ ПРИНИМАТЬ ЗНАЧЕНИЕ ПЕРЕМЕННОЙ; "ТочкаСнабжения". НИКАК ЗАРАЗА!
//УЖЕ ПРИ ВТОРОМ ЗАПУСКЕ ФормыВыбора ПРОСТО ИГНОРИРУЕТ ЕЕ ... ПРОПУСКАЕТ
ФормаВыбор_ТочкаПодключение.ТочкаСнабжения=знТочкаСнабжения;
ФормаВыбор_ТочкаПодключение.Открыть();
Предупреждение(ОБЪЕКТимя+" -- "+знТочкаСнабжения);
//################## ФРАГМЕНТ КОДА ДЛЯ ИСПРАВЛЕНИЯ #############################
КонецЕсли;
//===========================================
~Выход:;
КонецПроцедуры

Буду очень признателен Вам!





Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск