Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Янв 2018, 08:55
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: УЧИМСЯ программировать! ПОМОГИТЕ!!!!  (Прочитано 6825 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн надюшка

  • чайник
  • **
  • Сообщений: 96
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2011-02-25
  • Сайт: 
  • Профессия: Консультант 1С
 ui;;t;Пол года работы консультантом 1С закончились тем что мне дали задачи сделать обработку выгрузки данных из Excel-я в 1С. Языка и навыков программирования очень мало, когда-то года 3 назад было маленькое знакомства с 1С кодом. Поэтому выдаю ряд вопросов с которыми столкнулась при написании обработки.

Помогите пожалуйста!!!! :lol:

1. Во внешней обработке создаю, заполняю и провожу документ Поступление товаров и услуг
 
НовДок = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();

НовДок.Записать(РежимЗаписиДокумента.Проведение);

на основе этого документа нужно создать счет фактуру и ее провести

2. При не котором условии я не могу все данные в форму завести програмно, поэтому нужно чтоб форма была открыта и выдано сообщение для заполнение данных полей пользователем. Как видно форму я не получаю. Как провести данную операцию???
 после Документы.ПоступлениеТоваровУслуг.ПолучитьФорму() - как проводиться запись данных в эту форму???
С каждого по мысле, мне на программу


Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Так все сумбурно :). Отвечу, как понял ваш вопрос: проверить, заполнен ли реквизит можно так:
Если НЕ ЗначениеЗаполнено(НовДокумент.Реквизит1) Тогда
Сообщить("Не заполнен реквизит 1");
КонецЕсли;
Надо сказать, что без заполнения ряда реквизитов, документ попросту не проведется.

Открыть форму можно так:
Форма = НовДокумент.ПолучитьФорму("Форма");
Форма.Открыть();

Оффлайн надюшка

  • чайник
  • **
  • Сообщений: 96
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2011-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Реквизит заполнен, ИНН в базе есть!!!
Просто ответ на строку кода - пустая ссылка, поэтому скорее всего где-то проблема именно с кодом!!! - только где??

Как получить форму и ее открыть я знаю, а вот как заполнить реквизиты в открытой форме программно??

Форма.Дата =
???
С каждого по мысле, мне на программу

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
на основе этого документа нужно создать счет фактуру и ее провести
Ну как. Создаем док. счет-фактура так же, как и ПТУ, заполняем (хоть данными из НовДок, хоть какими-то другими), и проводим :)
Все аналогично, как в п1. у тебя написано.
Цитировать
2. При не котором условии я не могу все данные в форму завести програмно, поэтому нужно чтоб форма была открыта и выдано сообщение для заполнение данных полей пользователем. Как видно форму я не получаю. Как провести данную операцию???
 после Документы.ПоступлениеТоваровУслуг.ПолучитьФорму() - как проводиться запись данных в эту форму???
Структура получается такая:
НовДок = Документы.ПоступлениеТоваровУслуг.СоздатьДокумент();
<<заполняем нужные данные>>
Если <<выполняется условие, и нужно открыть форму на заполнение>> тогда
       Сообщить("Заполните недостающие данные");
       НовДок.ПолучитьФорму().Открыть();
КонецЕсли;
НовДок.Записать(РежимЗаписиДокумента.Проведение);
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Цитировать
Как получить форму и ее открыть я знаю, а вот как заполнить реквизиты в открытой форме программно??
Нужно не у формы реквизиты заполнять, а у объекта. То есть, вы создали док. НовДок, вот у него и заполняйте НовДок.Дата=...
А потом открывайте форму
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн надюшка

  • чайник
  • **
  • Сообщений: 96
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2011-02-25
  • Сайт: 
  • Профессия: Консультант 1С
3. как найти сумму по документу если данные у меня заносятся по циклу

Для каждого Строка из Таблица Цикл

Если Счет<> NСчет Тогда

попытка проведения
Создание документа и заполнение шапки

КонецЕсли

Формирование табличной части

КонецЦикла

Проведение документа
С каждого по мысле, мне на программу

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Получить можно так:
НовДок.ТабличнаяЧасть1.Итог("Сумма") + НовДок.ТабличнаяЧасть2.Итог("Сумма");

Оффлайн надюшка

  • чайник
  • **
  • Сообщений: 96
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2011-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Всем огромное спасибо!!
С каждого по мысле, мне на программу

Оффлайн надюшка

  • чайник
  • **
  • Сообщений: 96
  • РЕПУТАЦИЯ: 3
  • КПД: 3%
  • Регистрация: 2011-02-25
  • Сайт: 
  • Профессия: Консультант 1С
Вскрылась интересная ошибка:

СчетФактура.ДокументОснование = НовДок;

где НовДок документ ПоступлениеТоваровУслуг, который я создаю ранее и провожу.

Счет фактура заполняется и проводиться замечательно, но вот бухгалтер заходит в данный документ и обнаруживает, что счетфактура (проведенная) без обязательного реквизита - документ основание!!!

как такое исправить???
С каждого по мысле, мне на программу

Оффлайн progmikon

  • *****
  • Сообщений: 2090
  • РЕПУТАЦИЯ: 371
  • КПД: 18%
  • Регистрация: 2010-10-09
  • Компания: http://progmikon.blogspot.com/
  • Профессия: Программист 1С
Если мне не изменяет память, документыОснования нужно писать в тч

НС = ДокументСчетФактура.ДокументыОснования.Добавить();
НС.ДокументОснование = ДокументПоступление;


Теги:
 

Помогите срочно!! В вкладке "Сервис"--> "Журнал регистрации" отражаются все операции как можно определить сделаны ли операции "задним числом" и как вычислить первоначальную информацию какой расчет поменял на другой?

Автор 2ronРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 4386
Последний ответ 24 Дек 2015, 15:34
от дфтын
Помогите подобрать Back-office и Front-office

Автор avrnskРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5648
Последний ответ 07 Сен 2010, 12:01
от mohock
Помогите с отчётами в УТ 10.3. (Ведомость по товарам и ведомость по заказам)

Автор chum710Раздел Пользователям "1С - Предприятие 8"

Ответов: 2
Просмотров: 5977
Последний ответ 28 Мар 2012, 13:02
от chum710
Помогите с отчетом "Валовая прибыль"

Автор Dm109Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4560
Последний ответ 10 Сен 2015, 13:57
от Dm109
помогите с отчетом "характеристики контрагентов"

Автор Vasya PovarРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 2030
Последний ответ 07 Дек 2016, 15:53
от Kironten

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
102 Сообщений
AIFrame
86 Сообщений
alex0402
34 Сообщений
pavl_vs
23 Сообщений
kiksi
19 Сообщений
alexandr_ll
17 Сообщений
andron81_81
16 Сообщений
Norfolk
15 Сообщений
Artibon
13 Сообщений
LexaK
13 Сообщений

* Кто онлайн

  • Точка Гостей: 601
  • Точка Скрытых: 0
  • Точка Пользователей: 10
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal