Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 сен 2021, 04:10

Выгрузка Номенклатуры

Автор gaur7, 14 июн 2017, 09:50

0 Пользователей и 1 гость просматривают эту тему.

gaur7

Добрый день, господа программисты и начинающие программаторы:D
Помогите решить задачку. Вообщем получаю в табличной части формы список номенклатуры с сервера.
Теперь необходимо создать кнопку на форме, чтоб нажав на неё весь этот список номенклатуры (таблица) выгружался в отдельный справочник
подскажите пожалуйста какой код нужен? *PS* 2 месяц работаю в 1с

gaur7

тоесть грубо говоря необходима выгрузка в справочник с сервера

alex0402

Для Каждого тСтр Из мТаблица Цикл
    НовыйЭлемент = Справочники.ИмяСправочника.СоздатьЭлемент();
    НовыйЭлемент.Наименование =
    .....
    .......
    НовыйЭлемент.Записать();
КонецЦикла
Спасибо за Сказать спасибо

gaur7

Цитата: alex0402 от 14 июн 2017, 10:43
Для Каждого тСтр Из мТаблица Цикл
    НовыйЭлемент = Справочники.ИмяСправочника.СоздатьЭлемент();
    НовыйЭлемент.Наименование =
    .....
    .......
    НовыйЭлемент.Записать();
КонецЦикла


А можно немного подробней
Что необходимо в номенклатуре создать?
А в коде обработки после .Наименование что прописывать?
Тоесть после каждого реквизита после знака =

alex0402

Цитата: gaur7 от 14 июн 2017, 10:53А в коде обработки после .Наименование что прописывать?
Тоесть после каждого реквизита после знака =

ну то что хочется видеть в реквизите Наименование в справочнике и дальше прописать все остальные реквизиты....
Спасибо за Сказать спасибо

gaur7

Цитата: alex0402 от 14 июн 2017, 11:08
Цитата: gaur7 от 14 июн 2017, 10:53А в коде обработки после .Наименование что прописывать?
Тоесть после каждого реквизита после знака =

ну то что хочется видеть в реквизите Наименование в справочнике и дальше прописать все остальные реквизиты....

Ну вот смотрите, у меня есть справочник НоменклатураВетис (он абсолютно пустой)
Есть вот это обработка где я создал кнопку Выгрузить
Код:
Процедура Кнопка1Нажатие(Элемент)   
  Для Каждого ТекущСтроки Из ТаблицаНоменклатуры Цикл
    НовыйЭлемент = Справочники.НоменклатураВетис.СоздатьЭлемент();
    НовыйЭлемент.Наименование =  Справочники.НоменклатураВетис.СоздатьЭлемент();
   НовыйЭлемент.GUID = Справочники.НоменклатураВетис.СоздатьЭлемент();
   НовыйЭлемент.Код = Справочники.НоменклатураВетис.СоздатьЭлемент();
   НовыйЭлемент.Статус = Справочники.НоменклатураВетис.СоздатьЭлемент();
    НовыйЭлемент.UUID =   Справочники.НоменклатураВетис.СоздатьЭлемент();                  
    НовыйЭлемент.Записать();
  КонецЦикла   
КонецПроцедуры

Нажимаю Выгрузить - ошибка Процедура Кнопка1Нажатие(Элемент)
    Поле объекта не обнаружено (GUID)
   НовыйЭлемент.GUID = Справочники.НоменклатураВетис.СоздатьЭлемент();

Создаю в справочнике нужные реквизиты
ПИШЕТ: Ошибка метданных

alex0402

Цитата: gaur7 от 14 июн 2017, 11:24НовыйЭлемент.Наименование =  Справочники.НоменклатураВетис.СоздатьЭлемент();

изучай мат.часть! как можно в Наименование тип строка запихнуть объект?
Спасибо за Сказать спасибо

gaur7


Добавлено: 14 июн 2017, 11:53


Цитата: alex0402 от 14 июн 2017, 11:43
Цитата: gaur7 от 14 июн 2017, 11:24НовыйЭлемент.Наименование =  Справочники.НоменклатураВетис.СоздатьЭлемент();

изучай мат.часть! как можно в Наименование тип строка запихнуть объект?

Всё выгрузка успешно проходит
Только вот какая проблема, очень много номенклатуры с одинаковыми кодами
Выводит: Значение "0201" поля "Код" не уникально
Как это решить?
Добавлено: 14 июн 2017, 12:03


Всё спасибо, уже разобрался во всём

oleg-x

Цитата: gaur7 от 14 июн 2017, 11:49

Добавлено: 14 июн 2017, 11:53


Цитата: alex0402 от 14 июн 2017, 11:43
Цитата: gaur7 от 14 июн 2017, 11:24НовыйЭлемент.Наименование =  Справочники.НоменклатураВетис.СоздатьЭлемент();

изучай мат.часть! как можно в Наименование тип строка запихнуть объект?

Всё выгрузка успешно проходит
Только вот какая проблема, очень много номенклатуры с одинаковыми кодами
Выводит: Значение "0201" поля "Код" не уникально
Как это решить?
Добавлено: 14 июн 2017, 12:03


Всё спасибо, уже разобрался во всём

Не присваивай код, пусть сама создаст код. Либо предварительный поиск по коду и если есть такой, то не создавать.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

gaur7

Цитата: oleg-x от 14 июн 2017, 12:46
Цитата: gaur7 от 14 июн 2017, 11:49

Добавлено: 14 июн 2017, 11:53


Цитата: alex0402 от 14 июн 2017, 11:43
Цитата: gaur7 от 14 июн 2017, 11:24НовыйЭлемент.Наименование =  Справочники.НоменклатураВетис.СоздатьЭлемент();

изучай мат.часть! как можно в Наименование тип строка запихнуть объект?

Всё выгрузка успешно проходит
Только вот какая проблема, очень много номенклатуры с одинаковыми кодами
Выводит: Значение "0201" поля "Код" не уникально
Как это решить?
Добавлено: 14 июн 2017, 12:03


Всё спасибо, уже разобрался во всём

Не присваивай код, пусть сама создаст код. Либо предварительный поиск по коду и если есть такой, то не создавать.

Олег, вы что-то намудрили с ответом
Мне всего-то надо было в нумерации убрать контроль уникальности
Добавлено: 14 июн 2017, 13:04


А как реализовать чтоб он ещё выгружал Тип продукции
Его я указываю, как строка выбора, а не таблицой

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск