Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
17 сен 2021, 16:44

Отбор после запроса

Автор антон худин9, 11 июн 2017, 12:34

0 Пользователей и 1 гость просматривают эту тему.

антон худин9

Делаю запрос по выбору записей по остаткам, в итоге нужно чтобы в табличную часть элемента справочника рабочего места помещалось номенклатура с остатком по открытому рабочему месту.
Т.е. открываю элемент рабочего места и там в ТЧ выводится вся его номенклатура с остатком.
&НаСервере
Процедура ПриОткрытииНаСервере()
Запрос = Новый Запрос;
Запрос.Текст ="ВЫБРАТЬ
               | ОстаткиЕдиницКонфигурацийОстатки.КоличествоОстаток КАК Количество,
               | ОстаткиЕдиницКонфигурацийОстатки.Номенклатура,
               | ОстаткиЕдиницКонфигурацийОстатки.РабочиеМеста
               |ИЗ
               | РегистрНакопления.ОстаткиЕдиницКонфигураций.Остатки КАК ОстаткиЕдиницКонфигурацийОстатки";
   
   
   РезультатЗапроса = Запрос.Выполнить();
   Выборка = РезультатЗапроса.Выбрать();
   Пока Выборка.Следующий()Цикл
   Если Выборка.РабочиеМеста.Наименование = ЭтотОбъект.Объект.Наименование Тогда
   Объект.СписокЕдиниц.Загрузить();
   Иначе
 
   КонецЕсли;

  КонецЦикла;
     

   

КонецПроцедуры

сделал пока так, подскажите как отбор сделать, я новичек простоЮ чтобы после отбора записывал все в ТЧ.

Теги: Запрос Отбор 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск