Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
11 Дек 2017, 22:11
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Нарушена подчиненность справочника единиц  (Прочитано 2517 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Stra

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-04
  • Сайт: 
  • Профессия: Программист 7.7
Платформа 7.7 (7.70.027)
Конфигурация  ТиС (Торговля и склад 9.0)

Обнаружилась такая проблема: в некоторых случаях элемент справочника единицыИзмерения оказывается подчиненным совсем не тому элементу которому должен.
Обнаружилось это так:
формируется штрих код в модуле формы элемента справочника Номенклатуры, и при записи этот штрих код должен записываться в базовую единицу измерения (подчиненный спарвочник). Однако введенный штрих код попадает в Единицу подчиненную совсем другому элементу Номеклатуры и там благополучно записывается..
И потом, при использовании сканера штрих кодов курсор позиционируется на на втором, неправильном товаре.
В Отладчике это выглядит так:

Процедура ПриЗаписи()
...
//ТекущийЭлемент()=Товар1

БазоваяЕдиница.ШтрихКод=ШтрКод;

//БазоваяЕдиница.Владелец=Товар20 !!!

....

Причем, ручная перезапись БазовойЕдиницы - не помогает.
дополнение подчиненного справочника Единиц другими единицами (кг, кор. и т.п.) и установка их в качестве базовой - тоже ни к чему не приводит.

Вопрос: Как лечить??




Тестированием и исправлением это не вылечивается (




Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
н...дя.......было у нас такое...как лечил к сожалению не помню...........эээээ.....хотя посмотри справочник типа неиспользованные штрихкоды...или типа того..........да...у нас был справочник и сканер прежде чем искать штрихкод он проверял этот штрихкод на его наличие в данном справочнике...а он там был..причем на другую номенклатуру...вот он ее брал и вываливал...как-то так :)

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Контрольуникальности не снята галка?

Оффлайн Stra

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-04
  • Сайт: 
  • Профессия: Программист 7.7
Стоит галка. Да и при чем тут она?

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн Stra

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-04
  • Сайт: 
  • Профессия: Программист 7.7
Перепроверил сейчас базу, - У части номенклатуры владелец базовой единицы - чужой элемент причем один и тот же!
Какие будут предложения?

Оффлайн Myti

  • *****
  • Сообщений: 679
  • РЕПУТАЦИЯ: 79
  • КПД: 12%
  • Любые работы по автоматизации вашего бизнеса!!!
  • Регистрация: 2009-10-12
  • Компания: Infostart.ru
  • Профессия: Программист 1С
подобный справочник смотрел???

Оффлайн Stra

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-04
  • Сайт: 
  • Профессия: Программист 7.7
Просто запустил отчетик:
...
Спр.ВыбратьЭлементы();
   Пока Спр.ПолучитьЭлемент()=1 Цикл
      Если Спр.ЭтоГруппа()=0 Тогда
         Если Спр.БазоваяЕдиница.Владелец<>Спр.ТекущийЭлемент() Тогда
            ТекЭлемент=Спр.Код+" "+Спр.Наименование;
            Владелец=Спр.БазоваяЕдиница.Владелец.Код+" "+Спр.БазоваяЕдиница.Владелец.Наименование;
            Таб.ВывестиСекцию("Строка");
         КонецЕсли;
      КонецЕсли;
   КонецЦикла;
...
Так вот в качестве Владельца всегда один и тот же элемент показывается.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
166 Сообщений
ilyay ilyay
75 Сообщений
oleg-x
56 Сообщений
alex0402
46 Сообщений
andron81_81
44 Сообщений
AIFrame
36 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
28 Сообщений
BuhRust
28 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 321
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal