Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 04:44

Индикация поля в табличной части.

Автор amazonka96, 05 июн 2017, 19:55

0 Пользователей и 1 гость просматривают эту тему.

amazonka96

В документе есть реквизит сотрудник, который ответственен за заказ и индикация подразделения, к которой относится сотрудник.
В документе. при выборе сотрудника автозаполняется его подразделение.
Есть справочник Сотрудники, справочник Подразделения и регистр сведений о закреплении сотрудников за подразделениями. Не могу понять как правильно сформировать запрос, а именно фрагмент.  -

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        //НАДО ЗАПОЛНИТЬ

КонецЦикла;


Вот код -

&НаКлиенте
Процедура СведенияСотрудникПриИзменении(Элемент)
//СтрокаТабличнойЧасти = Элементы.Сведения.ТекущиеДанные;
ТекСтрока = Элементы.Сведения.ТекущиеДанные ;
Значение = ТекСтрока.Сотрудник;
Значение1 = ТекСтрока.Подразделение ;
Дата1 = ТекущаяДата();
Заполнение(Значение, Значение1);

КонецПроцедуры


&НаСервере
Процедура Заполнение(Значение, Значение1)
//СтрокаТабличнойЧасти = Элементы.Сведения.ТекущиеДанные;
   
    Запрос = Новый Запрос;
    Запрос.Текст =
        //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
// Данный фрагмент построен конструктором.
// При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
                                                           
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ЗакреплениеСрезПоследних.ФИО,
| ЗакреплениеСрезПоследних.Закрепление
|ИЗ
| РегистрСведений.Закрепление.СрезПоследних(&МоментВремени, ФИО = &ФИО) КАК ЗакреплениеСрезПоследних";

Запрос.УстановитьПараметр("ФИО",Значение);
Запрос.УстановитьПараметр("МоментВремени", ТекущаяДата());

РезультатЗапроса = Запрос.Выполнить().Выбрать();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        //НАДО ЗАПОЛНИТЬ

КонецЦикла;

//}}КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
   
КонецПроцедуры

Fominv

Сделай не процедуру , а функцию и передавай в неё только сотрудника.
Присваивать значение лучше на клиенте,а не на сервере.



&НаКлиенте
Процедура СведенияСотрудникПриИзменении(Элемент)
     //СтрокаТабличнойЧасти = Элементы.Сведения.ТекущиеДанные;
     ТекСтрока = Элементы.Сведения.ТекущиеДанные ;
     Значение = ТекСтрока.Сотрудник;
     //Значение1 = ТекСтрока.Подразделение ;
     ТекСтрока.Подразделение = ПолучитьПодразделение(Значение);
КонецПроцедуры

   
&НаСервере
Функция ПолучитьПодразделение(Значение)
        //СтрокаТабличнойЧасти = Элементы.Сведения.ТекущиеДанные;
   
    Запрос = Новый Запрос;
    Запрос.Текст =
            //{{КОНСТРУКТОР_ЗАПРОСА_С_ОБРАБОТКОЙ_РЕЗУЛЬТАТА
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!
                                                               
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    ЗакреплениеСрезПоследних.ФИО,
        |    ЗакреплениеСрезПоследних.Закрепление
        |ИЗ
        |    РегистрСведений.Закрепление.СрезПоследних(&МоментВремени, ФИО = &ФИО) КАК ЗакреплениеСрезПоследних";
   
    Запрос.УстановитьПараметр("ФИО",Значение);
    Запрос.УстановитьПараметр("МоментВремени", ТекущаяДата());
   
    РезультатЗапроса = Запрос.Выполнить().Выбрать();
   
    ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
    Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
        //НАДО ЗАПОЛНИТЬ
        Возврат ВыборкаДетальныеЗаписи.Закрепление;
    КонецЦикла;
   

   
КонецФункции

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск