Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 июн 2021, 11:32

Не выбирается номенклатура

Автор magnifico61, 01 июн 2017, 20:29

0 Пользователей и 1 гость просматривают эту тему.

magnifico61

в УТ 11 на форме есть реквизит (Список значений) в котором стоит ограничение по виду
&НаКлиенте
Процедура НоменклатурнаяГруппаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
НоменклатураНаСервере();
КонецПроцедуры

Процедура НоменклатураНаСервере()
ТипыСписка = "СправочникСсылка.Номенклатура";
ДоступныеТипы = Новый ОписаниеТипов(ТипыСписка);
Объект.НоменклатурнаяГруппа.ТипЗначения = ДоступныеТипы;
КонецПроцедуры


При выборе дает выбрать только группу номенклатуры, а самой номенклатуры в открывающемся списке нет. В чем проблема?

Геннадий ОбьГЭС

Цитата: magnifico61 от 01 июн 2017, 20:29
в УТ 11
4 цифры версии озвучьте

Цитата: magnifico61 от 01 июн 2017, 20:29на форме есть реквизит (Список значений)
форме чего?
какой формы - формы списка?
реквизит формы? объекта?

Цитата: magnifico61 от 01 июн 2017, 20:29в котором стоит ограничение по виду
&НаКлиенте
Процедура НоменклатурнаяГруппаНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
НоменклатураНаСервере();
КонецПроцедуры

Процедура НоменклатураНаСервере()
ТипыСписка = "СправочникСсылка.Номенклатура";
ДоступныеТипы = Новый ОписаниеТипов(ТипыСписка);
Объект.НоменклатурнаяГруппа.ТипЗначения = ДоступныеТипы;
КонецПроцедуры


При выборе дает выбрать только группу номенклатуры, а самой номенклатуры в открывающемся списке нет. В чем проблема?
Ну, потому что стоит ограничение-отбор в соответствии с контекстом, это же видно из кода

Это не проблема, это by-design

А контекст того, о чём Вы спрашиваете известен только Вам

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск