Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 сен 2021, 04:55

Служебные сообщения

Автор Alex8603, 01 июн 2017, 18:31

0 Пользователей и 1 гость просматривают эту тему.

Alex8603

Добрый день!
Имеется вот такой код:
Процедура ПриНачалеРаботыСистемы()
Спр = Документы.ДокументПутевка.Выбрать();
  Пока спр.Следующий() Цикл
   Если Лев(Спр.Оплаченно,10)<Лев(Спр.Оплатить,10) Тогда
    Сообщить("Заявка № "+СокрЛП(Спр.Номер)+" от "+СокрЛП(Спр.Дата)+"  "+СокрЛП(Спр.Контрагент)+" осталось оплатить "+Число((Спр.Стоимость)-(Спр.ПроцентСкидки)-Спр.Оплаченно)+" рублей. ");
   КонецЕсли;
КонецЦикла;      
КонецПроцедуры

В итоге в служебном сообщении, при запуске 1С выводится следующее сообщение:
Заявка № 116 от 21.05.2010 11:10:03  Иванов Иван Иванович осталось оплатить 5 800 рублей.
Заявка № 167 от 08.07.2016 15:20:49  Иванов Петр Сергеевич осталось оплатить 10 200 рублей.
Заявка № 169 от 09.07.2017 16:56:01  Петров Иван Иванович осталось оплатить 125 500 рублей.
Заявка № 002 от 30.05.2017 11:01:40  Сидоров Иван Олегович осталось оплатить 49 600 рублей.

Мне нужно чтобы не выводилось время 11:01:40 после даты  и цикл делал проверку по дате с начала текущего года, а не по всей базе. Т.е. даже если были какие-нибудь неоплаты в 2007,2010, и т.д., проверка шла только с начала текущего года.

Сразу скажу, я не программист. Обычный пользователь, кое как смог написать данный код, а вот с временем и с проверкой на начало года никак не выходит.

Dethmontt

Цитата: Alex8603 от 01 июн 2017, 18:31+" от "+СокрЛП(Спр.Дата)
+" от "+Формат(Спр.Дата,"ДФ=dd.MM.yyyy")

Цитата: Alex8603 от 01 июн 2017, 18:31Спр = Документы.ДокументПутевка.Выбрать();
Спр = Документы.ДокументПутевка.Выбрать(НачалоГода(ТекущаяДата()));
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Alex8603

Цитата: Dethmontt от 02 июн 2017, 03:14
Цитата: Alex8603 от 01 июн 2017, 18:31+" от "+СокрЛП(Спр.Дата)
+" от "+Формат(Спр.Дата,"ДФ=dd.MM.yyyy")

Цитата: Alex8603 от 01 июн 2017, 18:31Спр = Документы.ДокументПутевка.Выбрать();
Спр = Документы.ДокументПутевка.Выбрать(НачалоГода(ТекущаяДата()));

Спасибо вам огромное за помощь. Все работает как надо :D

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск