Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2021, 08:02

ПриНачалеРаботыСистемы

Автор zoika45, 30 мая 2017, 11:35

0 Пользователей и 1 гость просматривают эту тему.

zoika45

Здравствуйте.
Подскажите, пожалуйста, проблема состоит в следующем: при запуске системы необходимо сообщить "Зайдите в отчет", но нужно сообщать не всем пользователям, пользователю с ролью Директор, сообщать этого не нужно.

Процедура ПриНачалеРаботыСистемы()

Сообщить("Вы вошли в систему как "+ ОбщийМодуль3.ПолПоз());
Сообщить(ОбщийМодуль3.ТП());
Если не ОбщийМодуль3.ПолПоз()="Директор" тогда
Сообщить("НЕ ЗАБУДЬТЕ ЗАЙТИ В ОТЧЕТ НАПОМИНАНИЯ!!!!!!!!!");
КонецЕсли;

КонецПроцедуры


Написала процедуру, но все равно выводит всем пользователям, директору в том числе.
Что я делаю не так?:dfbsdfbsdf:

wise

Если РольДоступна("Директор") Тогда
    Сообщить("НЕ ЗАБУДЬТЕ ЗАЙТИ В ОТЧЕТ");
КонецЕсли;
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

zoika45

{МодульУправляемогоПриложения(3,15)}: Процедура или функция с указанным именем не определена (РольДоступна)
           Если <<?>>РольДоступна("Директор") Тогда (Проверка: Тонкий клиент)

wise

Цитата: zoika45 от 30 мая 2017, 11:35Если не ОбщийМодуль3.ПолПоз()="Директор" тогда

а ПОЧЕМУ здесь условие "не" ??
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Dethmontt

Цитата: zoika45 от 30 мая 2017, 11:52Если <<?>>РольДоступна("Директор") Тогда (Проверка: Тонкий клиент)

точно так же как у вас было, через общий модуль...
Добавлено: 01 июн 2017, 00:48


Цитата: wise от 30 мая 2017, 11:56а ПОЧЕМУ здесь условие "не" ??

потому что сообщение предназначается НЕ директору
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Теги:

Похожие темы (3)

Рейтинг@Mail.ru Rambler's Top100

Поиск