Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 сен 2021, 05:45

удаление элементов -табличное поле

Автор leoshko84, 25 мая 2017, 10:40

0 Пользователей и 1 гость просматривают эту тему.

leoshko84

   
Есть элемент формы "СвойстваИЗначения", данные "ОбработкаОбъектЗначенияСвойств.СвойстваИЗначения". В процедуре этот элемент заполняется из "Планов видов характеристик".
Я хочу пробежаться по элемену и удалить не нужные мне строки. Вот что я делаю:
Для каждого стр из ЭлементыФормы.СвойстваИЗначения.Значение  цикл
Если Стр.Свойство.ДляНоменклатурыТипХарактеристики<>ССылка.ТипХарактеристики Тогда
            ОбработкаОбъектЗначенияСвойств.СвойстваИЗначения.Удалить(Стр.НомерСтроки);
           
КонецЕсли;
КонецЦикла;
Но в цикле пропускается один элемент. Как правильно сделать удаление строк?

wise

(0) перебирать С ПОСЛЕДНЕГО к первому:

МаксИндекс = ЭлементыФормы.СвойстваИЗначения.Значение.Количество()-1;
Пока МаксИндекс>=0 Цикл
    ТекЗначение = ЭлементыФормы.СвойстваИЗначения.Значение[МаксИндекс];
    Если ТекЗначение.Свойство.ДляНоменклатурыТипХарактеристики<>ССылка.ТипХарактеристики Тогда
        ОбработкаОбъектЗначенияСвойств.СвойстваИЗначения.Удалить(ТекЗначение.НомерСтроки);
    КонецЕсли;
    МаксИндекс = МаксИндекс - 1;
КонецЦикла;
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск