Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Июн 2021, 09:49
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Вытащить данные со второй строки табличной части  (Прочитано 1207 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн J_Nothing

  • *
  • Регистрация: 2017-05-23
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Вывожу на печать таблицу
Нужно сделать так чтобы, по кнопке, выводилось сразу две таблицы, и записывало значения из первых двух строк
Как выводить на выбор две таблицы я разобрался
Но значения хватает только из первой
Подозреваю дело в цикле обхода по строкам
Прошу помочь знающих мастеров
Процедура ПечатьЗаяви()
    Таб = СоздатьОбъект("Таблица");   
    Таб.ИсходнаяТаблица("Заява");
                   
       СЗ = СоздатьОбъект("СписокЗначений");
        СЗ.ДобавитьЗначение("Заява","Заява1");
        СЗ.ДобавитьЗначение("Заява","Заява2");
        Табл = 0;
        Результат = СЗ.ВыбратьЗначение(Табл,,,,1);
        Если Результат <> 1 Тогда
            Возврат;
        КонецЕсли;
            Таб.ИсходнаяТаблица(""+Табл);
           
    глУстПропись(Гривня);
    Датад = Формат(ДатаДок, "ДДДММММГГГГ");     
    ПечСНДСПропись = глСуммаПрописью(СуммаСНДС,Валюта);
    НП = 1;           
   
   
    ВыбратьСтроки();
    ПолучитьСтроку();
        Номер = ККА.Наименование;
        Тип = Строка(ККА.ТипККАСпр);     
        ВерсияПО = Строка(ККА.ТипККАСпр.ВерсияПО);     
        ФискальныйНомер = Строка(ККА.ФискальныйНомер); 
        МодемМодель = Строка(ККА.МодемМодель);     
        МодемНомер = Строка(ККА.МодемНомер);
        Производитель = Строка(ККА.ТипККАСпр.Производитель);
        ДатаИзготовления = Строка(ККА.ДатаИз); 
        Таб.ВывестиСекцию("Шапка");
        ВыбратьСтроки();   
                                     

    Пока ПолучитьСтроку() = 1 Цикл   
       

        Номер = ККА.Наименование;   
        Тип = Строка(ККА.ТипККАСпр);           
        Производитель = Строка(ККА.ТипККАСпр.Производитель);
   
     
      НП = НП + 1;
    КонецЦикла;   
 
    Таб.Защита(Константа.ФлагЗащитыТаблиц);
    Таб.ТолькоПросмотр(1);   
    Таб.Опции(0,0,,);
    Таб.ПараметрыСтраницы(1,100,,10,0,10,0,0,0,0);
    Таб.Показать("ПЕЧАТЬ: Договор на сервисное обслуживание","");     
    Таб.Показать("ПЕЧАТЬ: Договор на сервисное обслуживание","");
    глУстПропись(Гривня);
КонецПроцедуры


Оффлайн alex0402

  • *****
  • Регистрация: 2010-09-10
  • Сообщений: 2000
  • РЕПУТАЦИЯ: 358
  • КПД: 18%
  • Профессия: Программист 1С
 ВыбратьСтроки();
    ПолучитьСтроку(); // первая строка пропущена
.......
Пока ПолучитьСтроку() = 1 Цикл // отчет со второй строки
Спасибо за Сказать спасибо


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

LexaK
69 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
67 Сообщений
neek666
33 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
25 Сообщений
KATERINA 861
18 Сообщений
Алексей_1985_06
17 Сообщений
SSC
13 Сообщений
alexandr_ll
12 Сообщений
BuhRust
10 Сообщений

* Кто онлайн

  • Точка Гостей: 593
  • Точка Скрытых: 1
  • Точка Пользователей: 9
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск