Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 06:45

Вытащить данные со второй строки табличной части

Автор J_Nothing, 23 мая 2017, 11:47

0 Пользователей и 1 гость просматривают эту тему.

J_Nothing

Вывожу на печать таблицу
Нужно сделать так чтобы, по кнопке, выводилось сразу две таблицы, и записывало значения из первых двух строк
Как выводить на выбор две таблицы я разобрался
Но значения хватает только из первой
Подозреваю дело в цикле обхода по строкам
Прошу помочь знающих мастеров

Процедура ПечатьЗаяви()
    Таб = СоздатьОбъект("Таблица");   
    Таб.ИсходнаяТаблица("Заява");
                   
       СЗ = СоздатьОбъект("СписокЗначений");
        СЗ.ДобавитьЗначение("Заява","Заява1");
        СЗ.ДобавитьЗначение("Заява","Заява2");
        Табл = 0;
        Результат = СЗ.ВыбратьЗначение(Табл,,,,1);
        Если Результат <> 1 Тогда
            Возврат;
        КонецЕсли;
            Таб.ИсходнаяТаблица(""+Табл);
           
    глУстПропись(Гривня);
    Датад = Формат(ДатаДок, "ДДДММММГГГГ");     
    ПечСНДСПропись = глСуммаПрописью(СуммаСНДС,Валюта);
    НП = 1;           
   
   
    ВыбратьСтроки();
    ПолучитьСтроку();
        Номер = ККА.Наименование;
        Тип = Строка(ККА.ТипККАСпр);     
        ВерсияПО = Строка(ККА.ТипККАСпр.ВерсияПО);     
        ФискальныйНомер = Строка(ККА.ФискальныйНомер); 
        МодемМодель = Строка(ККА.МодемМодель);     
        МодемНомер = Строка(ККА.МодемНомер);
        Производитель = Строка(ККА.ТипККАСпр.Производитель);
        ДатаИзготовления = Строка(ККА.ДатаИз); 
        Таб.ВывестиСекцию("Шапка");
        ВыбратьСтроки();   
                                     

    Пока ПолучитьСтроку() = 1 Цикл   
       

        Номер = ККА.Наименование;   
        Тип = Строка(ККА.ТипККАСпр);           
        Производитель = Строка(ККА.ТипККАСпр.Производитель);
   
     
      НП = НП + 1;
    КонецЦикла;   

    Таб.Защита(Константа.ФлагЗащитыТаблиц);
    Таб.ТолькоПросмотр(1);   
    Таб.Опции(0,0,,);
    Таб.ПараметрыСтраницы(1,100,,10,0,10,0,0,0,0);
    Таб.Показать("ПЕЧАТЬ: Договор на сервисное обслуживание","");     
    Таб.Показать("ПЕЧАТЬ: Договор на сервисное обслуживание","");
    глУстПропись(Гривня);
КонецПроцедуры

alex0402

ВыбратьСтроки();
    ПолучитьСтроку(); // первая строка пропущена
.......
Пока ПолучитьСтроку() = 1 Цикл // отчет со второй строки
Спасибо за Сказать спасибо

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск