Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 июн 2021, 00:00

не получается обратиться к перечислению

Автор Сергей Федоров, 18 мая 2017, 12:59

0 Пользователей и 1 гость просматривают эту тему.

Сергей Федоров

хотел реализовать следующее, по кнопке пробить выполняется проверка, если номенклатура из списка "услуги" и склад стоит розничный , то пробить не удастся, не получается правильно обратиться к перечислению
&НаКлиенте
Процедура ПробитьЧекВыполнить(Команда)
Если  Объект.СтруктурнаяЕдиница = ПредопределенноеЗначение("Перечисление.ТипыСтруктурныхЕдиниц.Розница") И
Объект.Запасы.Номенклатура   = ПредопределенноеЗначение("Перечисления.ТипыНоменклатуры.Услуга") Тогда
ТекстСообщения = НСтр("ru='На данном складе нельзая пробивать данные товары '");   
УправлениеНебольшойФирмойСервер.СообщитьОбОшибке(ЭтотОбъект,ТекстСообщения,,,"Склад",Отказ);
КонецЕсли;
КонецПроцедуры

wise

(0)
Цитата: Сергей Федоров от 18 мая 2017, 12:59ПредопределенноеЗначение("Перечисления.ТипыНоменклатуры.Услуга")

Перечислени!Е!
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Сергей Федоров

Цитата: wise от 18 мая 2017, 15:29
(0)
Цитата: Сергей Федоров от 18 мая 2017, 12:59ПредопределенноеЗначение("Перечисления.ТипыНоменклатуры.Услуга")

Перечислени!Е!
нет , дело не в этом, я уже исправил ,все также
Если  Объект.СтруктурнаяЕдиница =ПредопределенноеЗначение("Перечисление.ТипыСтруктурныхЕдиниц.Розница") И
      Объект.Запасы.Номенклатура   = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Услуга") Тогда
      ТекстСообщения = НСтр("ru='На данном складе нельзя продавать услуги '");   
      УправлениеНебольшойФирмойСервер.СообщитьОбОшибке(ЭтотОбъект,ТекстСообщения,,,"Склад",Отказ);
   КонецЕсли;

wise

1. ты завёл тему в разделе 7.7
2. Объект.СтруктурнаяЕдиница это ЧТО..?
3. Объект.Запасы.Номенклатура это ЧТО..?

РАЗВЕ 2 и 3 имеют типЗначения перечисления..?
скорее всего
Цитата: Сергей Федоров от 18 мая 2017, 15:54Объект.Запасы.Номенклатура   = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Услуга")
а НАДО:
Объект.Запасы.Номенклатура.ТипНоменклатуры   = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Услуга")
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

alex0402

Цитата: wise от 18 мая 2017, 16:21Объект.Запасы.Номенклатура.ТипНоменклатуры   = ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Услуга")

так не получится:
Объект.Запасы.Номенклатура.ТипНоменклатуры - код для сервера
ПредопределенноеЗначение("Перечисление.ТипыНоменклатуры.Услуга") - код для клиента
Спасибо за Сказать спасибо

Теги:
Рейтинг@Mail.ru Rambler's Top100

Поиск