Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 сен 2021, 06:23

Обмен между Штрих-М: Кассир v. 5.0 и УТ 11.2

Автор Collasso, 15 мая 2017, 17:54

0 Пользователей и 1 гость просматривают эту тему.

Collasso

Доброго времени суток, уважаемые форумчане!

Имеем: УТ 11 как бэк-офис, программное решение на кассах в лице Штрих-М: Кассир v. 5, кассовый аппарат Ритейл-01Ф, эквайринг ipp 320, Arcus2. Обмен между УТ и Кассиром 5 происходит через загрузка-выгрузка файлов с товарами и отчетом (.erp). Обмен настроен через "Обмен с подключаемым оборудованием Offline".

Проблема: При выгрузке отчета с Кассира 5 в УТ отсутствуют отражения операций по эквайрингу.
Т.е. в УТ в документе "Отчеты по розничным продажам" все транзакции проводятся как оплата наличными, соответственно вкладка "Оплата платежными картами", остается пуста.
На сайте СофтШтрих-М в разделе: Транзакции "Штрих-М: Кассир 5". Группировка по типу транзакции, в таблице указано, что Параметру безналичной оплаты, соответствует транзакция за номером 140. В УТ в модуле ПодключаемоеОборудованиеШтрихМККМOffline в Функция РазобратьОтчет(ТекстовыйДокумент, ВыходныеПараметры) имеем:

ЦитироватьИначеЕсли ТипТранзакции = 150 Или ТипТранзакции = 151 Или ТипТранзакции = 152 Или ТипТранзакции = 153 Или ТипТранзакции = 155 Или ТипТранзакции = 140 Тогда
            // Запуск программы, Оплата в платежной системе, Возврат в платежной системе, Отмена в платежной системе,
            // Авторизация.
         ИначеЕсли ТипТранзакции = 140 Тогда
            // Параметры безналичной оплаты.
         Иначе
            ОписаниеОшибки = НСтр("ru='Обнаружена неизвестная транзакция: %ТипТранзакции%. Данные по транзакции не были загружены!'");
            ОбщегоНазначенияКлиентСервер.СообщитьПользователю(СтрЗаменить(ОписаниеОшибки, "%ТипТранзакции%", Строка(ТипТранзакции)));
            НеизвестнаяТранзакция = Истина;
            Продолжить; // Неизвестная транзакция (продолжаем перебор).
         КонецЕсли;
      КонецЦикла;
      
      Если НеизвестнаяТранзакция Тогда
         ОбщегоНазначенияКлиентСервер.СообщитьПользователю(НСтр("ru='Не все данные были загружены из отчета. Обратитесь к администратору системы!'"));
      КонецЕсли;

Подскажите пожалуйста природу данной проблемы, где копать, что делать? Поддержка Штрих'а утверждает что это забота 1С. Сильно не пинайте.
Заранее спасибо за любой конструктив! С Уважением!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск