Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 июн 2021, 19:59

Заполнить столбец табличной части одним и тем же значением из регистра сведений

Автор balanarchik, 10 мая 2017, 23:20

0 Пользователей и 1 гость просматривают эту тему.

balanarchik

Здравствуйте!
Имеется регистр сведений с измерением "Категория" и ресурсом "Сумма". Так же имеется запись в этом регистре с категорией "Продуктивно" и Суммой "100"
Есть документ с табличной частью и столбцом Стоимость продуктивности.
Как для всех строчек автоматически заполнить столбец Стоимость продуктивности значением 100 из регистра сведений?

Norfolk

Цитата: balanarchik от 10 мая 2017, 23:20
Здравствуйте!
Имеется регистр сведений с измерением "Категория" и ресурсом "Сумма". Так же имеется запись в этом регистре с категорией "Продуктивно" и Суммой "100"
Есть документ с табличной частью и столбцом Стоимость продуктивности.
Как для всех строчек автоматически заполнить столбец Стоимость продуктивности значением 100 из регистра сведений?
//можно при открытии формы
Запрос = Новый Запрос;
Запрос.Текст = "Выбрать Категория, Сумма из РегистрыСведений.ВашРегистрСведений где Категория = &Категория";
//здесь нужно определить что у вас будет в качестве параметра - какое значение
Запрос.УстановитьПараметр("Категория", КатегорияПродуктивности);
Выборка = Запрос.Выполнить().Выбрать();
Для каждого стр из ВашаТабличнаяЧасть цикл
    стр.СтоимостьПродуктивности = Выборка.Сумма;
КонецЦикла
Примерно как-то так.

Gennadiyy

а можно сразу
Для Каждого Стр Из ТЧ Цикл
    Стр.СтоимостьПродуктивности = 100;
КонецЦикла;


Norfolk

Цитата: Gennadiyy от 12 мая 2017, 09:52
а можно сразу
Для Каждого Стр Из ТЧ Цикл
    Стр.СтоимостьПродуктивности = 100;
КонецЦикла;

Конечно, можно. Но вдруг он запись в регистре поменяет. И будет не 100, а 200 например...

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск