Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
05 Апр 2020, 05:28
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Заполнение табличной части документа реквизитами табличной части справочника  (Прочитано 3274 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kaf_info

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2015-04-30
  • Сайт: 
  • Профессия: Ученик 1С
Добрый вечер!
Помогите, пожалуйста, разобраться. Есть справочник Номенклатура с табличной частью ДанныеТоваров, в которой реквизит ЕдиницаИзмерения и документ РеализацияТоваров с табличной частью Товары и реквизитами Товар - тип Ссылка.Справочник.Номенклатура и ЕдиницаИзмерения. Нужно при выборе в документе товара автоматически подставить единицу измерения.
Использовала запрос, проблема с параметром.

Заранее спасибо!!!!

&НаСервере
Процедура ЗаполнитьРеквизиты()
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| НоменклатураДанныеТоваров.ЕдиницаИзмерения
|ИЗ
| Справочник.Номенклатура.ДанныеТоваров КАК НоменклатураДанныеТоваров
|ГДЕ
| НоменклатураДанныеТоваров.Ссылка = &Ссылка";

Запрос.УстановитьПараметр("Ссылка", Товар);

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
Стр=Товары.Добавить();
Стр.ЕдиницаИзмерения=ВыборкаДетальныеЗаписи.ЕдиницаИзмерения;
КонецЦикла;

КонецПроцедуры

&НаКлиенте
Процедура НоменклатураТоварПриИзменении(Элемент)
ЗаполнитьРеквизиты();
КонецПроцедуры



Теги:
 

Не открывает форму сохраненного документа, открывает форму нового.

Автор EHOTРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 6081
Последний ответ 13 Апр 2012, 23:26
от Vit1501
Добавление сведений в графу "основание" документа "ТОРГ-12"

Автор Ярослав1984Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 9740
Последний ответ 20 Авг 2013, 18:45
от Ярослав1984
"Не совпадают сумма документа и общая сумма по платежным ведомостям"

Автор yunovoРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 8454
Последний ответ 11 Янв 2015, 02:55
от MuI_I_Ika
При создании нового документа "Заявка на кассовый расход" Ошибка "Значение 9 поля "номер" не уникально

Автор ppkmliteРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 13373
Последний ответ 22 Ноя 2014, 04:50
от cska-fanat-kz
Фамилия руководителя в печатных формах документа "Акт сверки", "Акт об оказании"

Автор MKozzlikРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 9139
Последний ответ 03 Фев 2012, 17:27
от Dinah

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
69 Сообщений
LexaK
50 Сообщений
alexandr_ll
30 Сообщений
antoneus antoneus
20 Сообщений
Алексей Рожков Алексей Рожков
19 Сообщений
Varg . Varg .
17 Сообщений
Musulmanin
16 Сообщений
Алексей_1985_06
15 Сообщений
wise wise
14 Сообщений
DmitriyF DmitriyF
12 Сообщений

* Кто онлайн

  • Точка Гостей: 189
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal