Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Июн 2021, 00:29
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: Итератор значения не определен  (Прочитано 1731 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ospov11789

  • *
  • Регистрация: 2016-03-09
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
Добрый день. Прошу ответить где ошибка если знаете
Задача такова Необходимо проверить правильность составления расписания занятий
Понятно, что в одну и ту же дату и в одно и то же время не могут проводится два разных занятия в одной группе
Поэтому необходимо сделать так, что если время проведения занятий и дата совпадают в двух разных строках табличной части система выдавала бы ошибку сразу
Поэтому был написан следующий код
Процедура ПравильностьСоставленияРасписания(СтрокаТабличнойЧасти)Экспорт
   
    Для каждого  СтрокаТабличнойЧасти Из СтрокаТабличнойЧасти Цикл;
      
   
       Если СтрокаТабличнойЧасти.Дата=СтрокаТабличнойЧасти.Дата и  СтрокаТабличнойЧасти.СправочникСсылка.ВремяПроведенияЗанятий =СтрокаТабличнойЧасти.СправочникСсылка.ВремяПроведенияЗанятий  Тогда
          Сообщить= "РасписаниеСоставленоНеверно";
      
         
      
      Иначе
        Сообщить= "Расписание составлено верно";
         
      
      КонецЕсли;
   
    КонецЦикла; 
   
 
    
 
 КонецПроцедуры
    А в модуле формы был написан следующий код
&НаКлиенте
Процедура РасписаниеВремяПроведенияЗанятияПриИзменении(Элемент)
СтрокаТабличнойЧасти=Элементы.Расписание.ТекущиеДанные;
 ПроверкаПравильностиЗаполнения.ПравильностьСоставленияРасписания(СтрокаТабличнойЧасти);
КонецПроцедуры
В конфигураторе никаких ошибок нет
Зато в приложении при запуске пишет Итератор значения не определен
Как решить проблему
С уважением Осипов Михаил Юрьевич


Оффлайн Igmok

  • *
  • Регистрация: 2017-04-10
  • Сообщений: 32
  • РЕПУТАЦИЯ: 0
  • Профессия: Ученик 1С
СтрокаТабличнойЧасти

Инициализируй это
Добавлено: 04 Мая 2017, 11:16

Нет секунду,
СтрокаТабличнойЧасти Из СтрокаТабличнойЧасти
Что это?
Инициализируй другой итератор. Ну там пустую переменную, строку, или как там.

Оффлайн ilyay

  • 1С:Специалист, 1С:Эксперт
  • *****
  • Регистрация: 2011-06-09
  • Сообщений: 562
  • РЕПУТАЦИЯ: 104
  • КПД: 19%
  • Профессия: Разработчик 1С
Строка у вас одна, вы ее в функцию передаете. Зачем по ней пытаетесь цикл сделать? В этом и ошибка. Цикл не нужен. Обращение через ссылку в цикле не стоит делать.

Задача решается проще: выгружаете табличную часть в таблицу значений, добавляете колонку "Количество" числовую, заполняете ее единицей. Выполняете метод таблицы значений Свернуть("Поле1, Поле2", "Количество"). Где больше одного, там и ошибка.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
65 Сообщений
LexaK
62 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
26 Сообщений
neek666
23 Сообщений
KATERINA 861
19 Сообщений
SSC
15 Сообщений
alexandr_ll
13 Сообщений
Алексей_1985_06
11 Сообщений
BuhRust
8 Сообщений

* Кто онлайн

  • Точка Гостей: 150
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск