Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
14 Июн 2021, 23:25
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
МультиВход
 
collapse

Автор Тема: 1C 8.3 Ошибка при обращении к функции модуля объекта внешней обработки  (Прочитано 1221 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн bakirov.ildus

  • *
  • Регистрация: 2017-05-03
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Профессия: Программист 1С
Доброго дня.
Столкнулся с подобной проблемой, но все вышеуказанные замечания не помогли.
Задача такая - из общего модуля нужно запустить процедуру находящуюся в модуле формы внешней обработки.
Процедура экспортная, вроде все делаю абсолютно точно так же, как написано здесь (и не только здесь), но один черт возникает ошибка "Метод объекта не обнаружен". Весь день на убил. Подскажите, что я делаю не так?

Код:
Процедура Команда1НаСервере() 

ВнешняОбработкаСсылка = Справочники.ДополнительныеОтчетыИОбработки.НайтиПоНаименованию("РасчетРасходов");
ИмяФайла = ПолучитьИмяВременногоФайла("epf");
ДвоичныеДанные = ВнешняОбработкаСсылка.ХранилищеОбработки.Получить();
ДвоичныеДанные.Записать(ИмяФайла);

ВнешняОбработкаОбъект = НеОпределено;
ВнешняОбработкаОбъект = ВнешниеОбработки.Создать(ИмяФайла);

ВнешняОбработкаОбъект.НайтиОтчетНаСервере();

КонецПроцедуры

&НаКлиенте
Процедура Команда1(Команда)
Команда1НаСервере();
КонецПроцедуры

А этот код во внешней обработке "РасчетРасходов"
&НаСервере
Процедура НайтиОтчетНаСервере() Экспорт

КонецПроцедуры


Оффлайн Dethmontt

  • Денис
  • *****
  • Регистрация: 2010-11-01
  • Сообщений: 2892
  • РЕПУТАЦИЯ: 552
  • КПД: 19%
  • Адын Эс
  • Профессия: Программист 1С
bakirov.ildus, из модуля формы на сервере???
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Оффлайн Dethmontt

  • Денис
  • *****
  • Регистрация: 2010-11-01
  • Сообщений: 2892
  • РЕПУТАЦИЯ: 552
  • КПД: 19%
  • Адын Эс
  • Профессия: Программист 1С
&НаСервере
Функция Б()
    ИмяОбработки = ВнешниеОбработки.Подключить(ПолучитьНавигационнуюСсылку(ВнешняОбработкаСсылка, "ХранилищеОбработки"), "МояСуперПуперОбработка");
    Возврат ИмяОбработки ;
   
&НаКлиенте
Процедура А()
  ИмяОбработки = Б();
 МояФорма = ПолучитьФорму("ВнешняяОбработка." + ИмяОбработки + ".Форма.Форма");
    МояФорма.НайтиОтчетНаСервере();
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!


Теги:
 

Формат теста при чтении

Автор magnifico61Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 604
Последний ответ 12 Апр 2018, 15:30
от oleg-x
перерасчет НДФЛ при изменении статуса временно проживающего в РФ

Автор Валерия-СПбРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 869
Последний ответ 27 Июл 2017, 17:17
от Валерия-СПб
проблема с оформлением документа расчет с работником при увольнении

Автор лидаРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 2688
Последний ответ 16 Мая 2009, 11:55
от лида
Как эффективно определить порядок видов расчетов при расчете начислений, и самое главное - как отловить зацикливание (код внутри)

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1003
Последний ответ 27 Сен 2017, 08:34
от alex0402
Не заполняется поле "Цена" при формировании документа "Пересчет товаров"

Автор InnakechaРаздел Пользователям "1С - Предприятие 8"

Ответов: 4
Просмотров: 3377
Последний ответ 29 Дек 2016, 09:54
от Innakecha

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Последние вакансии

* Том 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
72 Сообщений
LexaK
62 Сообщений
antoneus antoneus
31 Сообщений
Ивашка
27 Сообщений
neek666
23 Сообщений
KATERINA 861
23 Сообщений
alexandr_ll
15 Сообщений
SSC
15 Сообщений
Алексей_1985_06
11 Сообщений
MiThO
8 Сообщений

* Кто онлайн

  • Точка Гостей: 229
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Инструменты

* Дополнительно

Поиск