Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
16 окт 2021, 06:38

Не работает 1 с предприятие

Автор ospov11789, 02 мая 2017, 15:07

0 Пользователей и 1 гость просматривают эту тему.

ospov11789

Добрый день! У меня такая проблема. Не знаю, как ее решить. Пересталли проводится документы в системе
Пишет При подписке ПриУстановкеНовогоНомера на событие ПриУстановкеНовогоНомера произошла ошибка. Метод обработчика события УстановитьПрефиксИнформационнойБазыИОрганизации не найден. Как решить проблему
Не знаю, что делать

MuI_I_Ika

База типовая или доработанная?

ospov11789

Цитата: ospov11789 от 02 мая 2017, 15:07
Добрый день! У меня такая проблема. Не знаю, как ее решить. Пересталли проводится документы в системе
Пишет При подписке ПриУстановкеНовогоНомера на событие ПриУстановкеНовогоНомера произошла ошибка. Метод обработчика события УстановитьПрефиксИнформационнойБазыИОрганизации не найден. Как решить проблему
Не знаю, что делать
Объединил со старой конфигурацией.
Получаю следующую ошибку при проведении документа. Ошибка при выполнении обработчика - 'ПриУстановкеНовогоНомера'
по причине:
{ОбщийМодуль.ПрефиксацияОбъектовСобытия.Модуль(77)}: Поле объекта не обнаружено (Организация)
      ПрефиксОрганизации = ПолучитьФункциональнуюОпцию("ПрефиксыОрганизаций", Новый Структура("Организация", Источник.Организация));
Спрашивается это каким же простите за выражение надо быть ui;;t;, чтобы основные команды документа связывать с перфиксом организации и с неизвестным механизмом исправления. Если при любом обновлении или доработке канфигурации система ляжет, по таким причинам то как эту ошибку исправлять. Неужели разработчикам 1 с предприятия так трудно слелать чтобы основные команды приложения провести и закрыть не были завязаны и не могли быть завязаны на общий модули внутри системы, записать и закрыть не были бы завяаны на общие модули внутри системы
Систему учета надо строить таким образом, что основные команды технологической платформы такие как создать, запсать, провести, провести и закрыть никак не могут и не должны быть завязаны на редактируемые модули или иные объекты системы в конфигураторе. Наличие возможности привязать  основные команды технологической платформы такие как создать, запсать, провести, провести и закрыть к модулям, редавктируемым в конфигураторе - это фундаментальная ошибка, которая может приводить к очень тяжелым последствиям, поскольку достаточно видоизменить модуль, на которые завязаны основные команды системы и все. Система не работает. И как исправить ее неизвестно.
Пожалуйта поскажите, как освободить основные команды технологической платформы от привязки к объектам системы в конфигураторе, то есть на выполнение данных команд не должны влиять содержимое ни одного из обьектов конфигурации



MuI_I_Ika

Цитата: ospov11789 от 02 мая 2017, 16:13Систему учета надо строить таким образом, что основные команды технологической платформы такие как создать, запсать, провести, провести и закрыть никак не могут и не должны быть завязаны на редактируемые модули или иные объекты системы в конфигураторе.

Вас очень не хватает в фирме 1С в качестве архитектора платформы.


Цитата: ospov11789 от 02 мая 2017, 16:13Наличие возможности привязать  основные команды технологической платформы такие как создать, запсать, провести, провести и закрыть к модулям, редавктируемым в конфигураторе - это фундаментальная ошибка, которая может приводить к очень тяжелым последствиям, поскольку достаточно видоизменить модуль, на которые завязаны основные команды системы и все. Система не работает. И как исправить ее неизвестно.

Ну надеюсь поскольку теперь вы это поняли, то больше так делать не будете? По крайней мере без архива базы данных.

ospov11789


Dethmontt

Цитата: MuI_I_Ika от 02 мая 2017, 16:18Вас очень не хватает в фирме 1С в качестве архитектора платформы.

:D :D :D

Цитата: ospov11789 от 02 мая 2017, 16:13Пожалуйта поскажите, как освободить основные команды технологической платформы от привязки к объектам системы в конфигураторе, то есть на выполнение данных команд не должны влиять содержимое ни одного из обьектов конфигурации
Так не бывает, иначе нафига нужен Конфигуратор ВОООБЩЕ...
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

ospov11789

Цитата: MuI_I_Ika от 02 мая 2017, 16:18
Цитата: ospov11789 от 02 мая 2017, 16:13Систему учета надо строить таким образом, что основные команды технологической платформы такие как создать, запсать, провести, провести и закрыть никак не могут и не должны быть завязаны на редактируемые модули или иные объекты системы в конфигураторе.

Вас очень не хватает в фирме 1С в качестве архитектора платформы.


Цитата: ospov11789 от 02 мая 2017, 16:13Наличие возможности привязать  основные команды технологической платформы такие как создать, запсать, провести, провести и закрыть к модулям, редавктируемым в конфигураторе - это фундаментальная ошибка, которая может приводить к очень тяжелым последствиям, поскольку достаточно видоизменить модуль, на которые завязаны основные команды системы и все. Система не работает. И как исправить ее неизвестно.

Ну надеюсь поскольку теперь вы это поняли, то больше так делать не будете? По крайней мере без архива базы данных.
Архив баз данных есть, но он ничего не дает. Мне нужно решить проблему
Вот код сбойного модуля
////////////////////////////////////////////////////////////////////////////////
// ЭКСПОРТНЫЕ ВНЕШНИЕ ПРОЦЕДУРЫ

// Устанавливает префикс источника подписки в соответствии с префиксом организации.
// Источник подписки должен содержать
// обязательный реквизит шапки "Организация", тип: "СправочникСсылка.Организации"
//
// Параметры:
//  Источник - Источник события подписки.
//             Любой объект из множества [Справочник, Документ, План видов характеристик, Бизнес процесс, Задача]
// СтандартнаяОбработка - Булево - флаг стандартной обработки подписки
// Префикс - Строка - префикс объекта, который нужно изменить
//
Процедура УстановитьПрефиксОрганизации(Источник, СтандартнаяОбработка, Префикс) Экспорт

УстановитьПрефикс(Источник, Префикс, Ложь, Истина);

КонецПроцедуры

// Устанавливает префикс источника подписки в соответствии с префиксом информационной базы.
// Ограничения на реквизиты источника не накладываются
//
// Параметры:
//  Источник - Источник события подписки.
//             Любой объект из множества [Справочник, Документ, План видов характеристик, Бизнес процесс, Задача]
// СтандартнаяОбработка - Булево - флаг стандартной обработки подписки
// Префикс - Строка - префикс объекта, который нужно изменить
//
Процедура УстановитьПрефиксИнформационнойБазы(Источник, СтандартнаяОбработка, Префикс) Экспорт

УстановитьПрефикс(Источник, Префикс, Истина, Ложь);

КонецПроцедуры

// Устанавливает префикс источника подписки в соответствии с префиксом информационной базы и префиксом организации.
// Источник подписки должен содержать
// обязательный реквизит шапки "Организация", тип: "СправочникСсылка.Организации"
//
// Параметры:
//  Источник - Источник события подписки.
//             Любой объект из множества [Справочник, Документ, План видов характеристик, Бизнес процесс, Задача]
// СтандартнаяОбработка - Булево - флаг стандартной обработки подписки
// Префикс - Строка - префикс объекта, который нужно изменить
//
Процедура УстановитьПрефиксИнформационнойБазыИОрганизации(Источник, СтандартнаяОбработка, Префикс) Экспорт

УстановитьПрефикс(Источник, Префикс, Истина, Истина);

КонецПроцедуры

////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ

Процедура УстановитьПрефикс(Источник, Префикс, УстановитьПрефиксИнформационнойБазы, УстановитьПрефиксОрганизации)

ПрефиксИнформационнойБазы = "";
ПрефиксОрганизации        = "";

// устанавливаем привилегированный режим
УстановитьПривилегированныйРежим(Истина);

Если УстановитьПрефиксИнформационнойБазы Тогда

ПрефиксИнформационнойБазы = ПолучитьФункциональнуюОпцию("ПрефиксИнформационнойБазы");

// если функциональная опция ПрефиксИнформационнойБазы не найдена (подсистема Обмен данными не встроена)
Если ПрефиксИнформационнойБазы = Неопределено Тогда

ПрефиксИнформационнойБазы = "";

КонецЕсли;

КонецЕсли;

Если УстановитьПрефиксОрганизации Тогда

ПрефиксОрганизации = ПолучитьФункциональнуюОпцию("ПрефиксыОрганизаций", Новый Структура("Организация", Источник.Организация));

// если функциональная опция ПрефиксОрганизации не найдена (подсистема Организации не встроена)
Если ПрефиксОрганизации = Неопределено Тогда

ПрефиксОрганизации = "";

// если задана пустая ссылка на организацию
ИначеЕсли ТипЗнч(ПрефиксОрганизации) <> Тип("Строка") Тогда

ПрефиксОрганизации = "";

КонецЕсли;

КонецЕсли;

// отключаем привилегированный режим
УстановитьПривилегированныйРежим(Ложь);

ОсновнойПрефикс = ПрефиксОрганизации + ПрефиксИнформационнойБазы;

Разделитель = ?(ПустаяСтрока(ОсновнойПрефикс), "", "-");

Префикс = ОсновнойПрефикс + Разделитель + Префикс;

// если префикс не задан, то устанавливаем значение по умолчанию
Если ПустаяСтрока(Префикс) Тогда

Префикс = "";

КонецЕсли;

КонецПроцедуры

Хоть убей не пойму, где ошибка

Dethmontt

ospov11789, или восстановись из БЭКАПА полностью

или выгрузи Конфигурацию из БЭКАПА - сними текущую конфигурацию с поддержки и загрузи в текующую конфигурацию, конфигурацию БЭКАПА

После восстановления, попробуешь еще раз обновить конфигурацию до нового релиза, но уже с анализом какой код можно переносить, а какой НЕЛЬЗЯ!
Добавлено: 02 мая 2017, 16:36


ospov11789, Уважаемый, не факт что ошибка только здесь...

Скорее всего вы криво обновили конфигурацию, частично убили свои "Доработки", нужно откатываться и обновляться еще РАЗ, но с умом...
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

ospov11789

Цитата: Dethmontt от 02 мая 2017, 16:30
Цитата: MuI_I_Ika от 02 мая 2017, 16:18Вас очень не хватает в фирме 1С в качестве архитектора платформы.

:D :D :D

Цитата: ospov11789 от 02 мая 2017, 16:13Пожалуйта поскажите, как освободить основные команды технологической платформы от привязки к объектам системы в конфигураторе, то есть на выполнение данных команд не должны влиять содержимое ни одного из обьектов конфигурации
Так не бывает, иначе нафига нужен Конфигуратор ВОООБЩЕ...
Конфигуратор нужен для того, чтобы создавать объекты баз данных с помощью инструментов, предоставляемых конфигуратором
Технологическая же платформа - это своеобразная система управления базами данных
Какое спрашивается отношение имеет перфикс организации к документам, в которых нет реквизита организация.
ui;;t; Я смотрел учебник и ничего об этом не нашел. Это явный сбой технологической платформы или ее недоработка
Но мне нужно главным образом решить проблему и понять причину того, что происходит и как решить данную проблему, то есть сделать так, чтобы система заработала вновь и допускала проведение документов, не образая внимания на данный модуль, в котором есть ошибка. Подскажите как это сделать


Dethmontt

Цитата: ospov11789 от 02 мая 2017, 17:10Какое спрашивается отношение имеет перфикс организации к документам, в которых нет реквизита организация.

Платформа - это общее. Возможность создавать объекты
А вот наличие или отсутствие Организации или модуля по установке префикса - это частное! И имеет отношение только к конкретной конфигурации создаваемой уже разработчиками НЕ ПЛАТФОРМЫ 1С
А так же платформа позволяет вмешиваться в механизмы обработки данных реализованные в созданных объектах (таких как проведение, запись, создание и т.д.) эти механизмы описывает так же НЕ программист ПЛАФТФОРМЫ, а программист КОНФИГУРАЦИИ 1С

И при обновлении "доработанной" КОНФИГУРАЦИИ есть риски сломать доработки, удалить или перемешать КОД разных разработчиков
Добавлено: 02 мая 2017, 17:31


Цитата: ospov11789 от 02 мая 2017, 17:10Но мне нужно главным образом решить проблему и понять причину того, что происходит и как решить данную проблему, то есть сделать так, чтобы система заработала вновь и допускала проведение документов, не образая внимания на данный модуль, в котором есть ошибка. Подскажите как это сделать

Самый простой способ я вам уже написал ВЫШЕ:

Цитата: Dethmontt от 02 мая 2017, 16:34восстановись из БЭКАПА
где все работает

Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск