Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 сен 2021, 06:31

не работает запрос, подскажите в чем причина

Автор Сергей Федоров, 01 мая 2017, 13:32

0 Пользователей и 1 гость просматривают эту тему.

Сергей Федоров

&НаСервере
Процедура РасчитатьНаСервере()
   Запрос = Новый Запрос;
   Запрос.Текст ="ВЫБРАТЬ
                 |   СчетТовары.Номенклатура,
                 |   СчетТовары.СрокРезервирования,
                 |   СчетТовары.Ссылка.Дата
                 |ПОМЕСТИТЬ Счет
                 |ИЗ
                 |   Документ.Счет.Товары КАК СчетТовары
                 |ГДЕ
                 |   СчетТовары.Ссылка = &Ссылка
                 |;
                 |
                 |////////////////////////////////////////////////////////////////////////////////
                 |ВЫБРАТЬ
                 |   СнятиеСРезерва.Дата,
                 |   СнятиеСРезерва.Номенклатура
                 |ПОМЕСТИТЬ Снятие
                 |ИЗ
                 |   Документ.СнятиеСРезерва КАК СнятиеСРезерва
                 |;
                 |
                 |////////////////////////////////////////////////////////////////////////////////
                 |ВЫБРАТЬ
                 |   Счет.Номенклатура,
                 |   Счет.Дата,
                 |   РезервыНоменклатурыОстатки.ПоСчету,
                 |   РезервыНоменклатурыОстатки.РезервОстаток,
                 |   Снятие.Дата КАК СнятиеСРезерва
                 |ИЗ
                 |   Снятие КАК Снятие,
                 |   Счет КАК Счет
                 |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрНакопления.РезервыНоменклатуры.Остатки(
                 |            &Момент,
                 |            Номенклатура В
                 |               (ВЫБРАТЬ
                 |                  Счет.Номенклатура
                 |               ИЗ
                 |                  Счет КАК Счет)) КАК РезервыНоменклатурыОстатки
                 |      ПО Счет.Номенклатура = РезервыНоменклатурыОстатки.Номенклатура";
   Запрос.УстановитьПараметр("Ссылка",Ссылка);
    Запрос.УстановитьПараметр("Дата",ТекущаяДата());
   Результат = Запрос.Выполнить();
   Выборка = Результат.Выбрать();
   ОсталосьРезерва = Дата + Выборка.РезервОстаток * 86400 ;
   Пока Выборка.Следующий() Цикл   
      Если     ОсталосьРезерва < Дата Тогда
         Отказ = Истина;
      КонецЕсли;   
   КонецЦикла;
КонецПроцедуры

pavl_vs

Сергей Федоров,
Цитироватьне работает запрос
это не вопрос.
Что-нибудь сообщается?

ilnur75

наверняка у ТС руки до консоли запросов не доходят

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск