Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 сен 2021, 20:00

Как доделать?

Автор Булат Насретдинов, 30 апр 2017, 08:56

0 Пользователей и 1 гость просматривают эту тему.

Булат Насретдинов

Вот задание:
Создать внешнюю обработку, которая циклически выводит на экран сообщение с наименованием организации (использовать вызов менеджера Константы) при нажатии на кнопку Вывести организацию.

Вывод осуществлять на сервере без контекста

Цикл должен выполнить 10 итераций. При этом вывод сообщения нужно производить на каждую итерацию кроме первой и последний. (т.е. сообщение должно вывестись 8 раз)

Вот что написал я в модуле формы:

&НаСервереБезКонтекста
Процедура ВывестиОрганизациюНаСервере(Знач НаименованиеКомпании)

Для а = 1 по 9 Цикл
Если а > 1 и а < 9 тогда
Сообщить (Константы.НаименованиеКомпании.Получить());
КонецЕсли;
КонецЦикла;
КонецПроцедуры

&НаКлиенте
Процедура ВывестиОрганизацию(Команда)
ВывестиОрганизациюНаСервере(Объект.НаименованиеКомпании);
КонецПроцедуры



Я не могу понять, что нужно еще написать чтобы при запуске в пользовательском режиме при нажатии кнопки открывалась форма для заполнения Наименования Компании
Подскажите, пожалуйста)))

MuI_I_Ika

По описанию задачи вы все правильно сделали? А зачем вам еще вводить наименование?

Ну создайте форму в обработке и открывайте ее. Потом читайте то что туда перадели.

L33r01

Используй функцию ввести ззначение и ложи туда свою константу


Отправлено с моего iPhone используя Tapatalk

Теги:

Похожие темы (2)

14189

Ответов: 4
Просмотров: 2756

4755

Ответов: 2
Просмотров: 2141

Рейтинг@Mail.ru Rambler's Top100

Поиск